Desktop Intelligence Users Guide
Reporting Techniques and Formatting
Chapter 1  Report Basics and Report Manager  

Overview  ......................................................... 16
Starting Desktop Intelligence  .................................. 16
  Logging on to Desktop Intelligence via the Windows Start menu  .................................................. 17
  Using offline mode  ........................................... 17
Logging into Desktop Intelligence via InfoView  .............. 19
Installing Desktop Intelligence .................................. 21
Desktop Intelligence workspace  ................................ 21
  Menus and toolbars  .......................................... 22
Report Manager pane  ........................................ 25
Status bar  ....................................................... 26
Right-click menus  ............................................ 27
Keyboard shortcuts  ............................................ 27
Customizing your workspace  .................................... 27
  Setting the display size  ..................................... 28
Setting Windows display properties  .......................... 28
Choosing a view to work in  ................................... 28
Changing the language setting  ................................ 30
Regional settings  .............................................. 31
Report Manager  ................................................. 32
  Managing the data in a document  ............................ 34
Navigating through reports  ..................................... 35
Structuring and formatting reports  ............................ 35
Managing reports within a document  .......................... 37
  Inserting a blank report  ...................................... 37
Copying a report  .............................................. 38
Displaying, renaming and deleting a report  .................... 39
Undoing actions  .............................................. 40
Finding text in your Desktop Intelligence report ................ 40
Contents

Creating Desktop Intelligence documents ........................................... 41
  Creating Desktop Intelligence documents from InfoView .................. 41
  Creating Desktop Intelligence reports when Desktop Intelligence is running .................................................. 42
Opening and viewing documents in Desktop Intelligence ....................... 42
  Opening documents in Desktop Intelligence 2-tier mode .................... 43
  Viewing Desktop Intelligence documents via InfoView ...................... 45
  Displaying Desktop Intelligence document information .................... 46
  Adding document properties to your open Desktop Intelligence documents .................................................. 48
Finding documents .............................................................................. 49
  Using the Find Documents command .............................................. 49
Chapter 2  Saving, Refreshing, Sharing and Printing Documents .............. 55
Overview ......................................................................................... 56
  Saving a document for all users ................................................... 57
  Options when saving a document .................................................. 58
  Adding summary information to Desktop Intelligence documents ..... 59
  Saving a document template ....................................................... 60
  Saving a document in text or rich text format ................................. 61
  Saving a document in PDF format .................................................. 61
  Saving a document in HTML format .............................................. 63
  Saving a document as an Excel file ................................................ 65
  Saving Desktop Intelligence Add-Ins .............................................. 67
  Refreshing Desktop Intelligence documents ................................... 67
  Before refreshing a document ..................................................... 68
  Manually refreshing a document .................................................. 70
  Refreshing a document with more than one data provider ................ 70
Send to Mail ....................................................................................... 72
Printing documents ............................................................................. 72
  Before you print .............................................................................. 73
  Using Print ....................................................................................... 73
  Using Page Setup ......................................................................... 75
Contents

Using Print Preview .................................................. 79
Printing multi-page reports ...................................... 80

Chapter 3 Exporting Data from Desktop Intelligence 83
Overview ............................................................... 84
What external formats are available? ......................... 84
Exporting data from Desktop Intelligence .................. 85
Copying and pasting from Desktop Intelligence to another application 89

Chapter 4 Templates and Standard Report Styles 93
Overview ............................................................... 94
Who should read this chapter ................................. 94
What are templates and standard report styles? ........... 94
What is a standard report? ....................................... 95
What is a template? ............................................... 96
Setting a default report layout ............................... 96
Customizing standard report styles ......................... 97
Editing standard report styles ................................. 98
Editing settings ................................................... 99
Editing settings and applying to an open report .......... 99
Applying standard report styles ............................. 103
Making sure everyone uses the same standard report styles . 104
Modifying the standard report styles template .......... 106
Using templates ................................................... 106
Creating a template ............................................... 107
Applying a template ............................................. 108
Replacing variables in a template with variables from a report . . 110

Chapter 5 Setting Up Master/Detail Reports 113
Overview ............................................................... 114
What are master/detail reports? ............................. 114
Structuring a master/detail report ......................... 115
From a table or crosstab ........................................ 116
From the Report Manager ..................................... 117
## Contents

Building a master/master/detail report .......................... 118
Re-organizing a master/detail report .......................... 119
Managing sections in a master/detail report .................. 120
Undoing a master/detail report .................................. 121

**Chapter 6** Setting Up Report Layout 125
Overview .............................................. 126
Multi-page reports ...................................... 126
  Setting what is to appear on each page ...................... 126
  Managing page breaks .................................. 127
  Running headers and footers in tables ....................... 129
Page setup ............................................ 132
  Setting margins ...................................... 132
  Using headers and footers ................................ 133
  Resizing headers, footers and margins ..................... 134
Using page numbers, times and dates ....................... 134
  Inserting numbers, time and date .......................... 134
  Changing how the date and time displays ................... 136
Inserting document information ................................ 137
Using outline view ...................................... 138

**Chapter 7** Formatting Page Layout 143
Overview .............................................. 144
Positioning report components .............................. 144
  Relative positioning ................................... 144
  Aligning blocks and cells ................................ 147
  Displaying delimiters .................................. 148
  Manually positioning components using the grid ........... 148
Using Report Manager to structure report layout .......... 149
  Organizing the report in Report Manager .................. 150
  Formatting components in Report Manager ................. 151
  Naming components in Report Manager ..................... 151
Hiding and displaying report components .................. 152

6 Desktop Intelligence User’s Guide Reporting Techniques and Formatting
Contents

Showing and hiding report components ........................................... 152
Setting a condition to hide a component ........................................... 154
Hiding an empty section in a report ................................................. 159
Working with the page background ................................................. 160

Chapter 8 Displaying Data in Tables .......................... 163
Overview .................................................................................. 164
What types of tables? .................................................................. 164
   Tables .............................................................................. 164
   Crosstab tables .................................................................. 165
Creating tables ........................................................................... 166
   Inserting a table from Report Manager .................................... 167
   Rotating tables .................................................................... 168
   Re-organizing data in tables ................................................... 168
   Adding more data to a table .................................................... 170
   Replacing data in a table .......................................................... 171
   Removing data from a table ..................................................... 171
   Inserting a crosstab ................................................................ 172
   Turning a crosstab to a table .................................................... 173
   Tips on dragging and dropping data ....................................... 173
Guided table insertion ................................................................. 174
Editing tables ............................................................................... 177
   Selecting tables, rows and cells ................................................. 177
   Inserting empty columns and rows .......................................... 180
   Naming or renaming a column or row ...................................... 180
   Resizing columns and rows ...................................................... 180
   Copying, pasting and deleting .................................................. 181
Free-standing cells ....................................................................... 182
   Inserting a free-standing cell ..................................................... 182
   Dragging a cell out of a table .................................................... 183
   Editing cells and cell content ................................................... 184
## Contents

### Chapter 9  Breaking Up Tables  187

- Overview ........................................ 188
- Working with breaks ............................ 188
  - What is a break? ............................... 188
  - Inserting and removing breaks .......... 189
    - Formatting breaks .......................... 190
  - Showing headers and footers ............. 192
  - Merging cells .................................. 193
  - Making a value-based break .............. 196
  - Organizing multiple breaks .............. 198
  - Managing breaks over multiple pages ... 200

### Chapter 10  Formatting Sections, Tables, and Cells  201

- Overview ........................................ 202
- Formatting sections ............................ 202
  - What are sections? ........................... 202
  - Formatting sections .......................... 203
- Formatting tables .............................. 206
  - Formatting blocks ............................ 206
  - Formatting Appearance ...................... 209
  - Resizing columns, rows and cells ....... 211
  - Showing headers and footers ............. 212
- Formatting cells ............................... 216
  - Using the Formatting toolbar ............ 217
  - Repeating cell formats .................... 217
  - Copying cell formats ....................... 218
  - Formatting text ............................... 218
  - Formatting numbers and dates .......... 219
  - Creating your own number and date formats .................................................................. 221
  - Using hyperlinks in Desktop Intelligence reports ...................................................... 223
  - Editing a hyperlink ........................... 225
  - Aligning cell contents ...................... 226
  - Wrapping cell contents ..................... 229
Contents

Row by Row Auto Fit .................................................. 229
Formatting cell borders ................................................. 230
Formatting cell backgrounds ......................................... 231

Chapter 11 Working with and Formatting Charts ........................................... 233
Overview ................................................................. 234
Chart types .............................................................. 234
Creating a chart ......................................................... 238
  Creating a chart using the New Chart Wizard .................. 238
  Turning a table or crosstab into a chart ....................... 240
  Turning a chart into a table or crosstab ....................... 241
  Switching between chart types ................................. 241
Organizing chart data .................................................. 243
  Matrix charts ......................................................... 243
  Reorganizing chart data .......................................... 246
Moving Data ............................................................. 247
Removing or hiding data ............................................. 247
Chart elements and how to format them .......................... 248
  Selecting chart elements ....................................... 249
Formatting the chart block ......................................... 249
  Choosing chart elements to display ........................... 249
Formatting the chart block ......................................... 250
Resizing the chart block ............................................. 252
  Formatting the plot area ....................................... 254
Formatting the data series ......................................... 255
Formatting each chart type ......................................... 256
  Column charts ....................................................... 256
  Area charts ......................................................... 257
  Three-dimensional charts ...................................... 258
Formatting chart axes and axis labels ............................ 260
  Axis labels .......................................................... 261
  Axis scale .......................................................... 263
Scaling charts in Master/Detail reports ........................... 264
Contents

Helping users to read your chart ................................. 265
  Chart title ...................................................... 266
  Chart legend .................................................. 267
  Data labels .................................................... 269
  Gridlines ...................................................... 270
Using different chart types on one chart ......................... 272
  Using groups on charts ..................................... 272
  Using a secondary Y-axis ................................... 274
Deleting charts .................................................. 278
Displaying a calculation on data in charts ....................... 279

Chapter 12  Including Graphics and Other Objects in Reports  281
Overview ......................................................... 282
Using data and pictures from other applications ............... 282
  Inserting data and pictures from other applications ........ 283
  Editing inserted OLE 2 objects ............................. 285
Using pictures in reports .................................... 287
  Inserting a picture in a cell ................................. 287
  Using prompts in reports .................................... 288

Appendix A  Business Objects Information Resources  289
Documentation and information services ........................ 290
Documentation .................................................... 290
  What's in the documentation set? ............................ 290
  Where is the documentation? .................................. 290
  Send us your feedback ........................................ 291
Customer support, consulting and training ......................... 291
  How can we support you? ..................................... 291
  Looking for the best deployment solution for your company? 292
  Looking for training options? ................................ 292
Useful addresses at a glance .................................... 293
Examples

Inserting a Special Field using keyboard shortcuts 27
Accessing options by right clicking on a table icon in the Report Manager 36
Accommodating international audiences with Page Setup 82
Copying and pasting from Desktop Intelligence to Microsoft Word 90
Always displaying your company’s logo in the header of your reports 96
Making a report with a year and a quarter section 119
How can I display page totals and recap amounts in a multi-page report? 130
How do I know when the data in my report was last updated? 135
Inserting a query prompt in a report 137
Why is relative positioning important? 145
Displaying different table formats for European and US currencies 155
Setting up a different page layout for odd and even pages 157
How can I show revenue subtotals for each resort in a table? 188
Centering the Resort value in a column 195
Using shading to distinguish between sections 202
Applying shading and borders to tables 208
Correctly formatting crosstab corners 208
Aligning a block position and creating a condition to hide a block 209
Displaying tables in a multi-column layout 213
Displaying duplicate rows in a table 214
Creating a number format with three decimal places 221
Adding a link to a web site in a report 224
Re-organizing data in two-dimensional charts 243
Showing multiple lines on a line chart 245
Re-organizing data on chart axes in three-dimensional charts 245
Adjusting the plot area to the chart size — before and after 253
Adjusting scaling in a master/detail report 265
Comparing revenue and quantity sold in a chart 275
Inserting an active-X ticker, in your Desktop Intelligence report 288
Report Basics and Report Manager
Overview

This chapter provides basic information so that you can work with Desktop Intelligence. The chapter headings include:

- “Starting Desktop Intelligence” on page 16
- “Desktop Intelligence workspace” on page 21
- “Customizing your workspace” on page 27
- “Report Manager” on page 32
- “Managing reports within a document” on page 37
- “Creating Desktop Intelligence documents” on page 41
- “Finding documents” on page 49

Starting Desktop Intelligence

The way you start Desktop Intelligence depends on how it has been set up in your company: as a 2-tier Desktop Intelligence deployment or a 3-tier Desktop Intelligence deployment. Your system administrator will give you all the necessary information on how you should start Desktop Intelligence. The Desktop Intelligence deployment determines how you log on.

What are 2-tier Desktop Intelligence and 3-tier Desktop Intelligence?

- A 2-tier Desktop Intelligence deployment has a specific client server configuration where the program files to run the report engine are on the same machine — your local machine — as the middleware used to connect to your data. Technically, you have all the necessary files to connect to your corporate or local repository on your machine.

- Desktop Intelligence in 3-tier mode, is the lighter version of the Desktop Intelligence in 2-tier mode. It has a specific configuration where a light client version of the Desktop Intelligence report engine connects to the web server for all the middleware used for data connections. Users access Desktop Intelligence in 3-tier mode via InfoView or from the Start menu if they have a connection to a Business Objects server.
Logging on to Desktop Intelligence via the Windows Start menu

You always log on to Desktop Intelligence in 2-tier mode from the Windows Start menu. You can also logon to Desktop Intelligence in 3-tier mode from the Windows Start menu if you have a connection to a Business Objects server.

You may have to enter a user name and password, and you may have to choose a security domain. If this is the case, the user name, password, and security domain are assigned by your Business Objects supervisor or system administrator.

To start Desktop Intelligence:

1. Click the **Desktop Intelligence** program icon in the **Desktop Intelligence XI Release 2** group in the **Programs** menu.
2. Enter your system name in the **System** box.
3. Enter your user name and password.
4. Choose your authentication mode in the **Authentication** list.
5. Click **OK**.

*Note:* See your Business Objects supervisor for information about the mode that you are working in.

Using offline mode

If your Business Objects supervisor has given you rights, you can start Desktop Intelligence in offline mode by clicking the **Use in Offline Mode** check box in the User Identification dialog box.

Using Desktop Intelligence in offline mode means that you are not connected to a repository, which in turn means that whatever your connection type, you can only retrieve and send documents with email. You cannot interact with the repository at all while working offline.

*Note:* You must log on at least once in online mode before you can log on in offline mode. If you try to log on in offline mode, without having already logged on in online mode, you receive an error message.
Why use offline mode?

You may not have a remote connection, for example, while traveling on an airplane, but you want to continue to work on your Desktop Intelligence documents. What you can do once you have opened Desktop Intelligence in offline mode depends on the type of connection you chose to use in offline mode.

If Desktop Intelligence cannot establish the connection you requested with the Desktop Intelligence server, you may receive a message asking you if you want to start Desktop Intelligence in offline mode.

Running Desktop Intelligence in 2-tier mode offline

If you are using Desktop Intelligence in 2-tier mode offline and not connected to a repository, you can:

• work with documents and universes stored locally on your computer
• create and refresh documents if you have a connection to the database, and the database connection and security information is stored on your computer

Running Desktop Intelligence in 3-tier mode offline

When you launch Desktop Intelligence from the Start menu and select a 3-tier web connection, you may have the choice to log in offline.

Since all the database and connection information is stored on the Business Objects server, if you are using Desktop Intelligence in 3-tier mode offline, you cannot:

• import documents from, or Export documents to folders on the Desktop Intelligence server
• retrieve documents from, and send documents to users in the repository
• create queries or refresh documents

If you are using Desktop Intelligence in 3-tier mode offline, you can:

• continue to work on documents stored locally
• work on the formatting of your reports
• analyze data in existing reports and work with the data contained in the document to build new reports

Note: If you do not see the option to work offline, your Business Objects supervisor or system administrator has not given you this option. You can request that they change your user profile to be able to work offline.
Logging into Desktop Intelligence via InfoView

If your company uses InfoView, and has 3-tier deployment of Desktop Intelligence, you can log in to Desktop Intelligence via InfoView on the web. Before you can start Desktop Intelligence, you first need to log into InfoView via the web. For more information on getting up and running in InfoView, please see the InfoView User’s Guide.

With a 3-tier deployment of Desktop Intelligence, most of the software you need to run Desktop Intelligence and connect to your data sources is installed on a remote server.

The following section explains how to define your options and start Desktop Intelligence once you are logged into InfoView.

Defining your options

1. Click Options in the InfoView Home page in your browser window. The Options page appears.
2. Click the View tab.
3. Click Desktop Intelligence as the view format under the Desktop Intelligence Documents section.
4. Click **Apply**.
   A message appears confirming that your options have been saved.

5. Click the **Create/Edit** tab.

6. Click **Desktop Intelligence** as the document type.

7. Click **OK**.
   A message appears confirming that your options have been saved.

   **Note:** You do not have to set these options each time you log into InfoView. Your options apply until you change them.

Now that you have defined your InfoView options, you can start **Desktop Intelligence** by either creating a new document or viewing an existing **Desktop Intelligence** document.

**Creating a new document in Desktop Intelligence**

To create a new document from InfoView, see “Creating Desktop Intelligence documents from InfoView” on page 41.
Viewing an existing Desktop Intelligence document

To open an existing document from InfoView, see “Viewing Desktop Intelligence documents via InfoView” on page 45.

Installing Desktop Intelligence

You can only install Desktop Intelligence using the Business Objects install Disk for Desktop Intelligence.

The Desktop Intelligence Instillation Wizard will take you through all the necessary steps.

Desktop Intelligence workspace

The Desktop Intelligence workspace is illustrated below. Desktop Intelligence has three main parts:

• the menus and toolbars
• the Report Manager window
Menus and toolbars

The menus contain all the commands for the tasks you need to carry out in Desktop Intelligence. Many of these commands also have buttons on one of the Desktop Intelligence toolbars.

Toolbars

You can hide and display the toolbars as needed:

1. From the View menu, click Toolbars.
The Toolbars dialog box displays as shown below:

2. Click the toolbars you want to display and clear the ones you want to hide.

3. Click Close to close the toolbar window.

Tip: You can also display and hide toolbars by right-clicking on any toolbar that is docked and clicking its name on the shortcut menu. If you click the Toolbars command on the context-sensitive menu, the Toolbars dialog box displays, as shown above.

**Displaying tooltips and keyboard shortcuts**

To activate the display of tooltips and keyboard shortcuts:

1. There are two ways to display the Toolbars dialog box.
   - Click Toolbars from the View menu, or,
   - Right click a docked toolbar and click the Toolbars command.
The list of toolbars displays as shown below:

2. Click the Show Tooltips check box to display just the short description or name of the button in the toolbars.
3. Click Show Shortcut Keys in Tooltips to display the available keyboard shortcuts for the toolbars.
4. Click Close to close the Toolbars dialog box.

Displaying large toolbar buttons

To display large toolbar buttons.

1. Display the Toolbars dialog box.
   • Either, click Toolbars from the View menu, or,
   • Right click a docked toolbar and click the Toolbars command.
2. Click the Large Buttons check box.
   The buttons in the Toolbars display in a larger format.
3. Click Close to close the Toolbars dialog box.

Note:
You can also set your Windows options to display large fonts. See “Setting the display size” on page 28.

Menus

All menu commands are also accessible via keyboard shortcuts. To navigate within Desktop Intelligence using your mouse, click the menu and select a command from the menu.
Accessing Help

As described in the Preface, Desktop Intelligence offers several ways to learn about our products.

While you are working with Desktop Intelligence, you can get context sensitive online help.

Once a dialog box or query panel displays, access the context sensitive help in any of the following ways:
- click the Help button on the dialog box
- click F1 on your keyboard

Report Manager pane

The Report Manager pane is docked next to the report pane by default. As with other Windows products, you can change the size or float the pane to change its position.

To float the Report Manager pane

1. Grab the Report Manager pane and drag it outside the report pane or the Desktop Intelligence window.
   The single black line changes to a gray hatched border indicating that the pane is floating and no longer in the docked position.
2. Release the mouse to display the floating Report Manager pane.

To dock the Report Manager pane

1. Grab the Report Manager pane and drag it outside the report pane or the Desktop Intelligence window.
   The gray hatched border changes to a single black line indicating that the pane is back in the docked position.
2. Release the mouse to display the floating Report Manager pane.

![Figure 1-1: Grab and drag the Report Manager. Release the mouse to float the Report Manager pane.](image)

### Status bar

The status bar, at the bottom of the Desktop Intelligence window, displays status and help messages.

The status messages provide information such as:
- the time the data in the report was last updated
- information on what Desktop Intelligence is currently doing, connecting to the database, for example, or loading a document

The help messages provide information such as:
- a brief description of menu commands as you highlight them with your mouse
- instructions when you are carrying out certain actions to remind you of the options you have available
Right-click menus

A quick and convenient way to access commonly used options is through context-sensitive menus. Right-click on the area that you want to work to display the context-sensitive menu. The options in the menu only apply to the area you clicked.

Keyboard shortcuts

You can use the keyboard shortcuts to access the various commands on the menus and dialog boxes and some tooltips. You can use the shortcuts by pressing Alt and the underlined letter that appears on the menu command. Watch the status bar for reminders on these shortcuts.

**Example:** Inserting a Special Field using keyboard shortcuts

You want to quickly insert the last refresh date in a report.

1. Press **Alt + I (i)** to access the Insert menu.
2. Press **F** to select the Special Field command.
3. Press **Enter** to display the secondary menu.
4. Press **D** to select the Date and Time command.
5. Press **R** to select Last Refresh Date command.

The date displays in your report.

Customizing your workspace

This section describes the options you can set to customize the look of your Desktop Intelligence workspace.
1 Report Basics and Report Manager

Customizing your workspace

Setting the display size

You can magnify the display to see it close up, or reduce it to see more of your report in the report window.

To change the size of the display, either:

• click the drop-down arrow in the zoom control box on the Standard toolbar and select a value from the list or
• type a value directly into the zoom control box, between 10% and 400%

Setting Windows display properties

Business Objects advises you to avoid working with the large fonts that you can set in the Windows Display properties. If you use this setting, certain menu and dialog box labels may be truncated. Business Objects also recommends that, on the Appearance tab of the Display properties, you set the Scheme to Windows Standard.

Note: You can also increase the size of the Toolbar buttons, see “Displaying large toolbar buttons” on page 24.

Choosing a view to work in

You can view your reports on screen in different ways.

Structure

Structure view displays only the names of the variables, or the formulas you have in your report and not the associated data.

A crosstab shown in Structure view

To switch Structure view on and off:

• From the View menu, click Structure.

Tip: Structure view is useful when working with very large documents with thousands of rows of data or hundreds of pages. Your document displays more quickly because data does not display and reports contain fewer pages.
Page layout

The page layout view allows you to see how elements are positioned on the printed page. You can also see the headers, footers and margins of your report. Some settings, such as page break settings, and the correct result of certain page functions can only be seen in Page Layout view.

The view you select before you close the current document will appear when you next open the document.

To select or deselect Page Layout view:

• From the View menu, click Page Layout.

The Page Layout menu icon is depressed when you select Page Layout view.

Outline view

The outline view allows you to hide or display sections of your document. You can then save and send the document to different users and show only the data that concerns them.

To view a document in outline view:

1. Click Outline from the View menu.

   Each section is indicated by a small, white arrow on the left side of the pane.

2. Click the down-facing triangle to fold up the section.

3. Click again to display the section.
Report Basics and Report Manager

Customizing your workspace

To return to the normal view:

- Click Outline again from the View menu.

Note: If you fold up sections with the outline view and then send the document to other users, keep in mind that they will be able to unfold the hidden data.

Changing the language setting

Desktop Intelligence in 2-tier mode, allows you to dynamically change the interface language. With previous versions, you had to quit and restart Desktop Intelligence for the language setting to take effect. In addition to the application interface, all documentation and online help appear in the selected language.

Tip: You are prompted to save your current document before you change the language setting. Your document closes before the selected interface language appears.

To change your language setting:

1. Click Options from the Tools menu.
2. Click the General tab.
3. Click one of the available languages from the Language list and click **OK**.

![Figure 1-2: The Language drop-down list contains your available interface languages](image)

**Note:** If only one language appears in the Language list, this means that you have not installed additional languages. See your administrator, or run the Setup utility from the Desktop Intelligence CD. You may also be able to run the Setup utility by clicking Add/Remove Programs from the Windows Control Panel. Click Change once you highlight Desktop Intelligence 6.1. Follow the prompts until you see the possibility to install additional languages.

**Note:** You cannot change the language if you are working in 3-tier Desktop Intelligence. Because of potential conflicts with other users who are connected to the same web server, the drop-down combo box is always disabled when you are running Desktop Intelligence in 3-tier mode.

### Regional settings

Desktop Intelligence supports international settings. This means that the regional settings in the Windows Control Panel affect how Desktop Intelligence displays and sorts numbers, currency, times and months in reports. Make sure these settings are correctly set.

To do this:

1. From the **Start** menu, click **Settings** and then **Control Panel**.
2. Double-click **Regional Settings** to open the Regional Settings Properties dialog box.
3. Select the settings you require in each tab of the Regional Settings Properties.
4. Click **OK**, to save your settings.

![Image of Regional Settings Properties dialog box]

The date has a four-digit format which ensures that century information will not be lost.

Figure 1-3: In the above illustration, the regional settings have been set to United States English. This means Desktop Intelligence will use US conventions for numbers, dates and times and will use the dollar sign as the default currency sign.

**Date settings and the 21st Century**

Business Objects advises you to set a four-digit year style on the Date tab of the Regional Settings Properties dialog box. This ensures that you save the century as well as the year when exporting data from Desktop Intelligence to a text file.

**Report Manager**

The Report Manager is a key part of the Desktop Intelligence workspace from which you can manage many different aspects of your work.
Displaying the Report Manager

You can show or hide the Report Manager window by clicking Report Manager on the Standard toolbar.

- In the Standard toolbar, click **Report Manager** to display or hide the Report Manager window.

The Report Manager has two tabs. Each tab is used to manage a different aspect of your work in Desktop Intelligence.

- The **Data** tab allows you to manage the variables and formulas contained in a Desktop Intelligence document.
- The **Map** tab allows you to navigate through reports and to work on the structure and organization of reports and report components.

**Tip:** When the Report Manager window opens, it is docked on the left-hand side of your report window. You can unlock the Report Manager window and drag it to any other convenient location on your screen. Press Ctrl and move the Report Manager window to prevent it from docking.
Managing the data in a document

The Report Manager Data tab contains a list of all the variables and formulas in the document.

You can view the data list in two different ways:

• In alphabetical order
  The data in the document is listed in alphabetical order with the variables in the Variables folder and the formulas in the Formulas folder.

• By data provider
  The variables are grouped into the data providers from which they were returned.

Drag variables from this list and drop them into the report window to construct tables and other components in your report.

If you right-click on a variable in the list, a menu displays which allows you to:

• edit the data provider to bring in other data
• create a new data provider
• view the data
• open the Variables dialog box to create a new variable
• edit local variables
Navigating through reports

The Report Manager Map tab allows you to manage the structure of your document. It has two views.

In navigation view, a list of all the reports in your document is displayed. For the report currently displayed on your screen, section names are also displayed.

If you click on an item in the list in the Report Manager, the corresponding report or section is displayed in the report window.

If you right-click on a report in the list, a menu is displayed which allows you to:

- rename, duplicate or delete the selected report
- apply a template or standard styles to the selected report
- insert a new report

Structuring and formatting reports

In structure view, the Map tab displays a list of all the reports in the document and a list of all the components in the selected report.
Each report component (header, section, cell, table, chart etc.) is represented by an icon and a name. The names of components hidden in the report are displayed in italics.

When you click on an icon in the Report Manager window, the corresponding section or component displays in the main report window.

If you right-click on an icon, a context-sensitive menu displays.

**Example:** Accessing options by right clicking on a table icon in the Report Manager

Here are the options available from the context menu for table.

- format the table
- turn the table to a chart
- format any breaks, sorts or filters applied to the selected table
- apply the standard report style
- copy, cut or delete the table
Managing reports within a document

This section describes how to manage reports inside a Desktop Intelligence document.

Inserting a blank report

Before you display any data, you begin with a blank report that you design. For example, you create the report’s title or apply a page background first, then build a query or other data providers to display data in the report.

To insert a blank report inside an existing document

• Click Report from the Insert menu. A new, blank report appears inside the document.

To insert a blank report inside a new document by default

If you set Desktop Intelligence to create a blank report inside a new document, a new report appears when you:

• click New in the File menu
• click New in Standard toolbar

To set Desktop Intelligence to always insert a blank report inside a new document:

1. Click Options from the Tools menu. The Options dialog box opens.
2. Click New Document tab.
3. Click **Systematically Create a Blank Document**.

4. Click **OK**.

**Copying a report**

To make a copy of an existing report inside the document:

1. Right-click on the tab of the report you want to copy.
2. Click **Duplicate Report**.

A copy of the active report appears in a new tab inside the document. The name that appears in the tab is \(<<\text{Report Name} + (1)>>\). For example, if the report you copied is named Sales, the new report is named Sales (1).

**Tip:** You can also click Duplicate Report from the Edit menu.

**Note:** When you copy a report, you do not copy the data in the query. Therefore, if you make changes to the query, the changes apply to all the reports you copied. If you want to create a new query, you need insert a new report, then insert a table, crosstab or chart.
Displaying, renaming and deleting a report

One document can contain many reports. Each report has a tab, which appears at the bottom of the document window:

To switch from one report to another

- Click the tab of the report you want to display.

Tip: You can select several reports by pressing Control and clicking the reports. You can then Print only these reports. For more information see, “Printing documents” on page 72.

To rename a report

1. Right-click the report tab.
2. Click Rename Report.
3. Type the name for the report, up to 277 characters, in the text box.
4. Click OK.

The name you typed appears in the report tab.

Note: The Rename Report command is also available on the Format menu.

To delete a report

You can delete a report from a document if the document contains more than one report.

1. Right-click the report tab.
2. Click Delete Report.

A dialog box appears.
3. Click Delete in the Delete a report dialog box to confirm your decision.

To delete more than one report

1. Press Shift + click the tab of each report you want to delete.
   The text of the selected report tabs change to bold.
2. With your mouse on one of the report tabs, right-click and click Delete Report from the menu.

Note: The Delete Report command is also available on the Edit menu. You cannot undo once you have deleted a report.
Undoing actions

If you make a mistake or want to undo something, you can use Undo on the Standard toolbar.

- Undo lets you undo up to ten successive actions.
- Redo lets you redo up to ten previously undone actions.

Note: To undo actions, you can also use the keyboard shortcut Ctrl + Z.

Finding text in your Desktop Intelligence report

Desktop Intelligence has a time-saving feature that allows you to find information in your reports. Like many users, you depend on Desktop Intelligence to help manage your increasing amount of data. If you are accustomed to working with large reports, you might appreciate the new Find in Report tool.

To use the tool:
1. Open your report.
2. Click Find in Report from the Standard toolbar. The Find dialog box appears.
3. Enter the character string you want to search in the Find What combo box.
4. Select from the options described in the table below:

<table>
<thead>
<tr>
<th>This</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Match Whole Word Only check box</td>
<td>finds the whole word followed by a space</td>
</tr>
<tr>
<td>Match Case check box</td>
<td>finds the string exactly as you enter it</td>
</tr>
<tr>
<td>Direction Up</td>
<td>searches above the current position in the report</td>
</tr>
<tr>
<td>Direction Down</td>
<td>searches below the current position in the report</td>
</tr>
</tbody>
</table>
5. Click **Find Next** to find character string.
6. Click **Find Next** to find the next occurrence of the character string.
7. Click **Cancel** to close the Find dialog box.

**Note:** You can search for the last text you entered after you close the Find dialog by clicking Find Again on the Standard toolbar.

**Creating Desktop Intelligence documents**

This section provides basic information for how to create Desktop Intelligence documents via InfoView and via the Windows Start menu. For complete information on how to create documents in Desktop Intelligence using universes and other data providers, see *Desktop Intelligence User’s Guide: Accessing Data and Data Analysis*.

**Creating Desktop Intelligence documents from InfoView**

When you are logged into InfoView, and before you start Desktop Intelligence, you click a link in the web browser to create a new document. You can create Desktop Intelligence documents from the list of available universes only if you have saved your InfoView options as indicated in “Defining your options” on page 19.

To create a new document:

1. Click the **Desktop Intelligence** link in the **New Document** section.
Desktop Intelligence starts and the New Report Wizard appears in a new window.

2. Follow the prompts in the New Report Wizard to create a new report.

Creating Desktop Intelligence reports when Desktop Intelligence is running

Once you are running Desktop Intelligence, you can:

• create a new report inside a Desktop Intelligence document by clicking New Report Wizard in the Standard toolbar.
• create a new report inside a document by clicking New in the Standard toolbar. See “Inserting a blank report” on page 37.

For more information on:

• Using templates or standard reports, see “Templates and Standard Report Styles” on page 93.
• How to access your data, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Part II: Accessing Data.
• Managing your reports, see “Managing reports within a document” on page 37.

Opening and viewing documents in Desktop Intelligence

This section details procedures for opening documents in Desktop Intelligence 2-tier client/server mode and in Desktop Intelligence 3-tier mode via InfoView.

Note: This section only applies if you are working with Desktop Intelligence online, that is, you have not clicked the Use in Offline mode check box.

Once your document is open, you can perform most of the same reporting and formatting techniques. The following table shows some of the reporting and formatting techniques you can use in 2-tier or 3-tier deployments of Desktop Intelligence.

<table>
<thead>
<tr>
<th>If you want to</th>
<th>possible in 2-tier deployment</th>
<th>possible in 3-tier deployment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Format a table with custom formats</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Apply a template</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>
Opening and viewing documents in Desktop Intelligence

### If you want to

<table>
<thead>
<tr>
<th>Action</th>
<th>Possible in 2-tier deployment</th>
<th>Possible in 3-tier deployment</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create complex calculation</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Create user objects and variables</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Use VBA macros and Add-ins in Desktop Intelligence documents</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Access data using free-hand SQL</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Add a different data provider</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Use XML data</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Send a document to users via email</td>
<td>yes</td>
<td>yes</td>
</tr>
</tbody>
</table>

### Opening documents in Desktop Intelligence 2-tier mode

You are running Desktop Intelligence in 2-tier mode if you start Desktop Intelligence from the Windows Start menu and select a 2-tier client/server connection security domain.

Desktop Intelligence is compatible with:

- All documents created in BusinessObjects 5.1 or later

### Opening a document

If the document is stored locally on your computer:

1. Click **Open** on the **Standard** toolbar.
   
   The Open dialog box appears.

2. Click the type of document you want to open from the **Files of type** list.

3. Browse to locate the document you want to open and click **OK**.

**Tip:** Desktop Intelligence keeps track of the last documents opened. Click one of the recently opened files named on the list at the bottom of the File menu.
Finding documents using shortcut buttons

The latest version of Desktop Intelligence makes it easier to find documents. Several shortcuts to common document types and categories appear in the Open dialog box.

### Desktop Intelligence shortcut buttons

Using the shortcut buttons allows you to save Desktop Intelligence documents to the default locations on your hard drive. The default location root directory is: `C:\Documents and Settings\[user name]\My Documents\My BusinessObjects Documents`

Three sub-folders exist for different types of Desktop Intelligence documents and files.

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Shortcut name</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="User Documents" /></td>
<td>User Documents</td>
<td>UserDocs for Desktop Intelligence reports with the .rep extension</td>
</tr>
<tr>
<td><img src="image" alt="VBA Add-Ins" /></td>
<td>VBA Add-Ins</td>
<td>MyScripts for Desktop Intelligence Add-in files with the .rea extension</td>
</tr>
</tbody>
</table>

### My Folders Shortcut

The My Folders shortcut buttons bring you to:

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Displays</th>
</tr>
</thead>
<tbody>
<tr>
<td>My Documents</td>
<td>all the sub-folders under My Documents folder on the desktop</td>
</tr>
</tbody>
</table>
Opening several documents at once

Opening several documents at once is useful if you have complex documents that take a long time to open. You can select all the documents you want to use and then perform another task while you are waiting for them to open.

To do this:
1. In the Standard toolbar, click **Open**.
   The Open dialog box appears.
2. Click the type of document you want to open from the **Files of type** list.
3. Select the documents you want to open:
   - Press **Shift** and select adjacent documents
   - Press **Ctrl** and select non-adjacent documents
4. Click **OK**.

Viewing Desktop Intelligence documents via InfoView

When you log in to InfoView, you can bypass the application menus to launch Desktop Intelligence and open a Desktop Intelligence document. You simply click the links on the InfoView portal.

To view a Desktop Intelligence document via InfoView:
- Log in to InfoView. Please see the **InfoView User’s Guide** for information on how to log in.
- Verify that your InfoView options are set to open Desktop Intelligence documents, see "Defining your options" on page 19. Your default viewing choice is determined by the options you set.

When you log in to InfoView, the Home page is the first page that opens by default. You can change your default page to one of your choice, as explained in the **InfoView User’s Guide**.

The Home page gives you direct access to the main areas of the InfoView portal. It provides links to the different document lists.

You can view these document lists from the InfoView Home page:
What type of document do you want to view?

1. Click a link to the category list or document list on the InfoView Home page.

2. Click a document link.

   Desktop Intelligence starts and your document displays in a separate window.

   **Note:** The first time you start Desktop Intelligence, a minimum check is performed to detect if the necessary files are installed on your machine. For more information on viewing, searching, creating documents via InfoView, see the *InfoView User’s Guide*.

### Displaying Desktop Intelligence document information

When you open a Desktop Intelligence document, you can obtain information that is embedded with the document. You can also add document information in the editable fields.

To display the summary information:

1. Click **Properties** from the **File** menu.
The Summary Info dialog box displays. It contains the following information:

![Summary Info dialog box](image)

**Figure 1-4: The Summary Info dialog box displays useful document information**

The following summary information is embedded within the document:

<table>
<thead>
<tr>
<th>Information</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Folder</td>
<td>Displays the file path to the folder where you saved the document.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You can select this non-editable field to display the entire path.</td>
</tr>
<tr>
<td>Creation Date</td>
<td>Displays the date that the document was first saved.</td>
</tr>
<tr>
<td>Modification Date</td>
<td>Displays the date the document was last modified.</td>
</tr>
<tr>
<td>Last Print Date</td>
<td>Displays the date the document was last printed.</td>
</tr>
<tr>
<td>Language</td>
<td>Displays the language and its abbreviation in which the document was created. For example, English (en).</td>
</tr>
</tbody>
</table>

Some of this information is also available before you open the document when you display the Import from Repository. For information on viewing Corporate document properties, see "Getting information about the documents you found" on page 51.
Adding document properties to your open Desktop Intelligence documents

You can retrieve and add information about your report. The Summary Info dialog box helps summarize the unique characteristics of the document. Other users can enter this information to find your document via the Find documents command in the File menu.

Document name
- Folder location of the document
- Original creation date
- Last modification date
- Last date printed
- Language of the product that was used to create the document

Here is a list of criteria that can be added to and saved with the open document:

- Title
- Subject
- Author
- Keywords
- Comments

Users can search for documents in the repository using all of these criteria (except author).

**How to add summary information**

To add document summary information to your Desktop Intelligence document:

1. Open your document.
2. Click **Properties** from the **File** menu.
3. Enter the information in the text boxes provided in the Summary Info dialog box.
4. Click **OK** to close the dialog box.
5. Click **Save** on the Standard toolbar to save the document properties.

**Finding documents**

Some corporate repositories contain hundreds of Desktop Intelligence documents. Finding the one you are looking for can be a challenge. The Find Documents command on the File menu allows you to search for documents in many ways.

There are several ways you can organize your documents to make it easier to manage multiple versions or types to help you take full advantage of the refined search methods.

This section explains how to find your Desktop Intelligence documents using the Find Documents command and how to refine your search. An example shows how to put these methods into practice and help you to easily find and retrieve a document.

For information on searching for documents via InfoView, see the *InfoView User’s Guide*.

**Using the Find Documents command**

The Find Documents box allows you to refine your search for documents by setting attributes and conditions on the search.
The Where list box contains these options:

<table>
<thead>
<tr>
<th>Select this property</th>
<th>To find documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Categories</td>
<td>• that either belong or do not belong to categories that you select</td>
</tr>
</tbody>
</table>
| Comments             | • whose comments include a character string that you specify  
                       | • comments are properties that you set by clicking Properties from the File menu |
| Keywords             | • whose keywords include a character string that you specify  
                       | • keywords are properties that you set by clicking Properties in the File menu |
| Name                 | • whose name contains a character string that you specify, for example, Revenue.rep |
| Subject              | • whose subject includes a character string that you specify  
                       | • the subject of a document is an attribute that you set by clicking Properties from the File menu |

1. Click the property on which you want to search and specify the appropriate values.
2. Click Find.

To find all the of documents in the repository:
1. From the File menu, click Import from Repository,
2. Click Find Documents.
   The Find documents dialog box appears.
3. Click the drop-down arrow in the Where list box, then select the conditional property and complete any other conditions in the space provided.
4. Click Find.
   After searching, the documents appear in the results pane.

**Understanding the Find documents dialog box columns**

Information about the documents that you can retrieve is displayed in the columns described below:

1. Click the top of each column to sort in descending order.
2. Click the **Open on Retrieval** check box if you want to open the document at the same time you download it to your machine.

**Getting information about the documents you found**

Now that you found some documents, you can get additional information on them.

1. Click one document in the list then click **Properties** to display the Document Properties dialog box.

   Additional information on the selected document appears.

![Figure 1-5: Data provider properties for the document named Regional sales.](image)

2. Click the **Document** tab to view Document Properties such as title, subject keywords, comments.

3. Click **OK** to close the Document Properties dialog box.

4. Click the CTRL key to select more than one document.

5. Click **Retrieve** to download the document(s) to your machine.

**How to add document properties**

You can enter properties for the open document by clicking **Properties** on the **File** menu.
1. Right-click the selected documents.

2. Click Retrieve Into from the menu.

   The Retrieve to dialog box appears.

3. Enter the directory or click Browse to search for the directory to which you want to download.

4. Click OK.
chapter

Saving, Refreshing, Sharing and Printing Documents
This chapter covers all that you need to know to save, refresh, send, print and distribute your Desktop Intelligence documents.

Desktop Intelligence reports appear inside Desktop Intelligence documents. You save your document in different formats so that you can use the data in other applications or share the data with other users. This section describes how to do this. The save as dialog box

Desktop Intelligence uses the Save As dialog box that contains shortcuts to common Desktop Intelligence file folders. You can quickly save your documents to different locations on your machine by clicking one of the available shortcut buttons.

You can also access other folders on your machine by clicking My Folders bar and navigating to other locations.

You can also access other folders on your machine by clicking My Folders bar and navigating to other locations.
Saving a document

To save your document:

1. Click **Save** on the Standard toolbar.
   
   The first time you save, the Save As dialog box appears. By default, the UserDocs folder is active and the file name is Untitled. The default file extension for Desktop Intelligence documents is .rep.

   **Note:** When you click Save for subsequent saves of the same document, the Save As dialog box does not appear. Your document saves in the background.

2. Enter the file name in the **File name** box.
   
   The name of the file appears in the File Name box. The name you give the document appears in the title bar of the application window.

3. Click **Save**.
   
   The Save As dialog box closes.

   **Tip:** You can also click Save on the File menu, or press Control + S from the keyboard to save your document.

Changing a document’s name and/or folder

To save a Desktop Intelligence document with a different name or in a different location:

1. From the **File** menu, click **Save As**.
   
   The Save As dialog box appears.

2. Type a new name in the **File name** box.

3. Use the shortcut to **User Documents** or navigate to the folder in which you want to save the document.

4. Click **Save**.

Saving a document for all users

If you want to make a document accessible to another user working without a repository, then click the Save for all users check box in the Save As dialog box.

If you do not do this, users working without a repository receive an error message: **You are not authorized to use this document**, when they try to open your document. This is important especially if you are sharing documents with other users via email.
Options when saving a document

When you save a Desktop Intelligence document you can define several options such as:

- automatic save
- password protection
- refreshing document upon opening

Note: The options under Application Options apply to how the application handles future documents when you save. The options under Options for Current Document apply to the current document only.

<table>
<thead>
<tr>
<th>Saves</th>
<th>This option</th>
<th>Does this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application settings</td>
<td>Prompt for Document Properties</td>
<td>Allows you to view and/or enter information on the document when you save it.</td>
</tr>
<tr>
<td></td>
<td>Automatic Save Every n minutes</td>
<td>Saves the document automatically at the frequency you specify. This overwrites your current version.</td>
</tr>
</tbody>
</table>
Adding summary information to Desktop Intelligence documents

When you save your Desktop Intelligence document, you can add to the information that is already embedded with your document. The list below details the type of information that is embedded with your document.

- Folder, where your document is located
- Creation Date
- Modification Date
- Last Print Date
- Locale, the language of the application that created your document

You can add to the information by entering properties for the:

- Name
- Subject
- Categories
- Keywords
- Comments

You can display and edit this information via the Summary Info dialog box.

To access the Summary Info dialog box:

1. Open your document.
2. Click **Properties** from the **File** menu while your document is open.
3. Enter the properties in the available text boxes.
4. Click OK.
5. Click Save on the Standard toolbar to save the properties with your document.

**Saving a document template**

You can save any Desktop Intelligence document as a template. Unless you purge the data source, the data from the document is saved in the template. For more information on creating and using templates, see Chapter 4: Templates and Standard Report Styles.

To save a document as a template:
1. Open the document you want to save as a template.
2. Click Save As from the File menu.
3. Click the Templates shortcut in the Save As dialog box.
4. Click Desktop Intelligence Templates (.ret) from the Save type as list box.
5. Enter a name in the File name text box.
6. Click Save.

Desktop Intelligence makes a copy of the document and saves it as a template in the default templates folder found in `My Documents\My Business Objects Documents\templates\[language].`

**Considering language when you save a template**

If your template contains language specific references, such as a country-specific title or a specific currency, Business Objects recommends that you save the template in the corresponding language directory.

When you install Desktop Intelligence, an abbreviated language folder is created for each language you install, such as `en` for English, `fr` for French.

The directories appear in two places:
- `Program Files\Business Objects\BusinessObjects Enterprise 11.5\templates` directory
- `My Documents\My Business Objects Documents\templates` folder

The first is the installation location, the second is your default working directory.
Saving a document in text or rich text format

When you save a Desktop Intelligence document in text (.txt) or rich text format (.rtf), only the currently selected report is saved. Graphics are not saved in rich text format and text documents. To save a document in text or .rtf format:

1. From the File menu, click Save As. The Save As dialog box appears.
   In the Save as type list box, click one of the following:
   • Text file (*.txt),
   • Rich text format (*.rtf).
2. Click Save. Desktop Intelligence makes a copy of the document and saves it in the specified format. The original document remains on your screen.

Saving a document in PDF format

You can save Desktop Intelligence documents in Adobe Portable Document Format (PDF). Once you install the free Adobe Acrobat Reader, you can view and print PDF documents. When you open a Desktop Intelligence document saved in PDF format, you can view and navigate through different reports and obtain high quality printed copies. You cannot edit or analyze the data. To save a Desktop Intelligence document in PDF format:

1. Click Save As from the File menu. The Save As dialog box appears.
2. In the Save as type list box, click Portable Document Format (*.pdf) and specify the location of the PDF file.
3. Click Save.
Desktop Intelligence creates a copy of the document and saves it in PDF format. The original document remains on your screen. The illustrations below show the same document in its original Desktop Intelligence format and after saving in PDF format.
Saving a document in HTML format

You can save a Desktop Intelligence document in HTML format. This makes it easy for InfoView users to view your document.

To do this:

1. From the File menu, click **Save As HTML**.
2. The **Save As** dialog box opens.
3. Navigate to the location where you want to save the file and click **Save**.

**Figure 2-2** : The outline is retained in the PDF document, making it easy to navigate quickly through reports and report sections.

**Note:** The fonts used to generate the PDF document are found in the following folder in your local hard drive:

```
Program Files\Business Objects\BusinessObjects Enterprise 11.5\bin\language
```

If the fonts used in your Desktop Intelligence documents do not have an equivalent Adobe Font Metrics (AFM) font in this directory, a substitute font is used.
The HTML Options dialog box opens.

4. Specify how you want to save your HTML document.

Selecting HTML Options

The available HTML Save options are detailed below.

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Report</td>
<td>save only the current report</td>
</tr>
<tr>
<td>All Reports in Document</td>
<td>save all the reports in the document</td>
</tr>
<tr>
<td>Select Reports</td>
<td>save the report(s) you select in the report list</td>
</tr>
<tr>
<td>Desktop Intelligence</td>
<td>save the report in Desktop Intelligence and HTML format</td>
</tr>
<tr>
<td>Document</td>
<td>• This means that the HTML version of the file contains a link to download the Desktop Intelligence document.</td>
</tr>
</tbody>
</table>

The first three options are option buttons and the last option is a check box.
The available HTML Format options under Format are:

<table>
<thead>
<tr>
<th>This check box</th>
<th>Enables you to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Charts and Pictures</td>
<td>display the charts and pictures in the HTML file</td>
</tr>
<tr>
<td>Use Frame</td>
<td>use the frame structure</td>
</tr>
<tr>
<td>Borders</td>
<td>include borders (See note below)</td>
</tr>
<tr>
<td>Background Colors</td>
<td>include colors</td>
</tr>
<tr>
<td>Text Colors</td>
<td>include text colors</td>
</tr>
<tr>
<td>Fonts</td>
<td>include the fonts used in the Desktop Intelligence</td>
</tr>
<tr>
<td>Free-form Layout</td>
<td>use table structure, without frames</td>
</tr>
<tr>
<td>Automatic Reload Every “x” minutes</td>
<td>reloads the HTML report every period of minutes</td>
</tr>
<tr>
<td></td>
<td>you set</td>
</tr>
</tbody>
</table>

The options for generating the HTML under Generate HTML are:

<table>
<thead>
<tr>
<th>This option</th>
<th>Enables you to</th>
</tr>
</thead>
<tbody>
<tr>
<td>All in one page</td>
<td>Print or search the entire document</td>
</tr>
<tr>
<td>Section by section</td>
<td>Jump from section to section via hyperlinks</td>
</tr>
<tr>
<td>Both</td>
<td>Switch between the one page view and the per section view.</td>
</tr>
</tbody>
</table>

**Note:** If your Desktop Intelligence document contains prompts, and you save it in HTML format, InfoView users will be able to use the prompts. Thus, prompts are supported in documents saved as HTML and opened from InfoView.

**Saving a document as an Excel file**

Perhaps not all the people who need to receive your Desktop Intelligence reports have access to Desktop Intelligence or to InfoView, or perhaps some people need to perform further calculations to data that is not included in Desktop Intelligence. Desktop Intelligence now enables you to save documents as Microsoft Excel files.
What exactly saves in Excel

When you save a Desktop Intelligence document as a Microsoft Excel file, all the reports maintain their appearance; that is, each report appears as a separate tab in an Excel file. Tables and graphs appear as they do in Desktop Intelligence. Numbers and text maintain their numeric and text format.

This table describes the behavior of a Desktop Intelligence document when you save as a Microsoft Excel file.

<table>
<thead>
<tr>
<th>If you see this in Desktop Intelligence</th>
<th>You see this in Microsoft Excel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Free form cell containing text</td>
<td>Single cell containing text</td>
</tr>
<tr>
<td>Free form cell containing a formula</td>
<td>Single cell containing a static number</td>
</tr>
<tr>
<td>Free form cells and section headers that contain more space than one standard cell</td>
<td>Text merges in more than one cell to avoid large columns</td>
</tr>
<tr>
<td>Charts two-dimensional</td>
<td>Data is exported and the chart appears in the same format. See Note below.</td>
</tr>
<tr>
<td>Charts three-dimensional</td>
<td></td>
</tr>
<tr>
<td>Structured table</td>
<td>Each cell, both heading and data are exported in a separate cell.</td>
</tr>
<tr>
<td>Non-structured tables (tables that do not have the same size columns)</td>
<td>Cells may merge and layout may be affected.</td>
</tr>
</tbody>
</table>

These elements are **not** saved in Excel:

- Formulas — formula results appear as numbers
- Free form cells containing bitmaps
- Free form cells containing hyperlinks
- OLE objects
- Charts containing several data series or groups are not always exported correctly

**Note:** When you save your report as Excel and it contains three-dimensional charts with several data series and groups, especially the double Y axis, they may not display or print in Excel as they do in Desktop Intelligence. You avoid this issue if you change the chart format to two dimensions.

How to save your document as an Excel file

To save a Desktop Intelligence document in Excel format:

1. Open the Desktop Intelligence document.
2. Click **Save As** from the **File** menu.

3. Enter a name for the file and click the drop-down arrow to select **Microsoft Excel Worksheet (.xls)** from the Save as type list.

4. Click the **User Documents** shortcut on the left pane of the Save As dialog box to save the Excel file in your My Documents\BusinessObjects Documents\UserDocs folder.

5. Click **Save**.
   
The file saves with the .xls file extension in the folder you specified.

**Saving Desktop Intelligence Add-Ins**

You can save Desktop Intelligence documents that contain macros as Desktop Intelligence Add-Ins (*.rea) files. You can have several macros in an Add-In document. Add-Ins provide the Visual Basic interface to the Desktop Intelligence reporting tool.

For more information on running add-ins, see Appendix 2 in the *Desktop Intelligence User’s Guide: Accessing Data and Data Analysis*.

**Refreshing Desktop Intelligence documents**

A document generated at a given point in time reflects the data as it existed at that time, but it may be inaccurate now. In Desktop Intelligence, you can update the data in a document while keeping the same presentation and
formatting. When you update a document, Desktop Intelligence reconnects to the database or file, and retrieves the updated data. This is called refreshing a document.

Refreshing a document ensures that the data is kept up-to-date with changes in the database or personal data file.

You can update the data displayed in a Desktop Intelligence document if you have a connection to the data source.

Tip: If your document contains data retrieved using a web connection as well as data retrieved using a client/server connection you will not be able to refresh both data providers at the same time. You will have to connect to the web connection to refresh one set of data and then connect to the client/server connection to refresh the other set of data.

Different ways of refreshing documents

Desktop Intelligence allows you to refresh documents in the following ways:

- manually
- automatically at specific times or intervals
- every time you open a document

Before refreshing a document

When you refresh a document, you refresh the data provider(s) contained in the document. The data provider is the data source; this can be a database query or a personal data file, for example. The user who created a document can specify if the document can be refreshed. Before trying to refresh a document’s data provider(s), verify that Refreshable check box is set.

To do this:

1. From the Data menu, click View Data.
The Data Manager dialog box opens.

2. Click the Definition tab.
3. In the Data Providers box, click the data provider you want to verify.
4. Click the Refreshable check box.
5. Click OK.

Note: If this option is not checked, you cannot refresh the selected data provider. Only the creator of the document or the Desktop Intelligence supervisor can change this setting.

Before refreshing data providers, you should also check that:
• you need the most up-to-date data
• you will not block the server (database) by refreshing the data provider
• you will not block your computer by refreshing the data provider

Some databases support asynchronous mode, which enables you to refresh a data provider without blocking your computer. If the database at your site does not support asynchronous mode, you can avoid blocking your computer by specifying off-peak times for refreshing data providers.

Your IS department, the universe designer and/or the supervisor should be able to advise you on these points.

For more information on the various types of data provider, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis.
Manually refreshing a document

To update the data in a document:

- In the Standard toolbar, click **Refresh**.
  
  Desktop Intelligence refreshes all the data providers in your document.

Refreshing a document with more than one data provider

If your document contains more than one data provider, you can choose which data provider you want to refresh. To do this:

1. From the **Data** menu, click **View Data**.
   
   The Data Manager dialog box opens.
2. Click the **Results** tab.
3. Click the data provider you want to refresh in the Data Providers list.
4. Click **Refresh**.
5. Click **OK**.
6. In Data Providers box, click the data provider on which you want to work.
7. Check **Automatic Refresh** then **Once**.
8. Click an item from the list box:
• On date, at time.
  Use this option to refresh the data provider at a given time on a given
day.
• On date, from time.
  Use this option to refresh the data provider after a given time on a set
day.

9. Enter a date and a time from the respective list boxes, then click **OK**.
10. Click the **Definition** tab.

11. In Data Providers box, click the data provider on which you want to work.
12. Select **Automatic Refresh** check box, then **Every** option button.
13. Set the intervals at which you want to refresh the data provider by
entering a value in the box, and selecting Hour(s) or Minute(s) from the
list box.
14. Enter the start date and time in the **From Date** and **Time** boxes.
15. Click **OK**.

• If you have Infoview installed on you can schedule Desktop
Intelligence documents to be refreshed and sent to the recipients you
have defined through a InfoView.

  **Note:** Refer to the *InfoView User’s Guide* for more information on
InfoView.
16. Click any of the following option buttons to:
   • Add an open document
   • Scheduling documents.
   • Browse for another unopened document
   • Remove the selected document
   • HTML Options to create an HTML version of the document with specific options
   • Clear the existing categories or those you assigned.

Send to Mail

If you have email facilities on your machine (such as, Microsoft Outlook) you can send your Desktop Intelligence document to other users who are not registered in the repository via email. To do this:

1. Click Send To Mail from the File menu.
   Your default email application opens a new email message and adds the Desktop Intelligence document as an attachment.
2. Enter the email address for the recipient(s) and enter your message.
3. Send the email message.

Printing documents

This section takes you through the basic techniques to get the best results possible on paper. You will also learn some tips to extend the printing possibilities of your reports.

You can print your report in several ways:
   • Click Print from the File menu.
   • Click Print Setup from the File menu then Print
   • Click Print Preview from the File menu then Print
   • Click the Print button on the Standard toolbar
   • Press Control + P on your keyboard to display the Print dialog box.
Before you print

Before deciding how to print, first select the reports you want to print.

If your document contains more than one report

1. Open your document.
2. Press the Control key while you select and highlight the report tabs of the reports you want to print.

Tip: It is important to consider the order in which you select the reports for printing. Although each report maintains its Page Setup options, the reports print to the printer specified in the first report you select. That is, all the reports print to the same printer even if other reports show a different printer selection.

Using Print

You can print using any of the methods detailed on page 72.
If you want to setup or preview your report pages before printing, see:
• “Using Page Setup” on page 75
• “Using Print Preview” on page 79
The most direct method to access the Print dialog box is to click **Print** from the **File** menu.

Note: If you click the Print button on the Standard toolbar, the Print dialog box does not appear. A message box briefly appears displaying the name of the printer that is printing the currently selected report(s). This is the fastest way to print all the pages in the report without verifying or changing the Page Setup options.

To print your report without changing the current Page Setup options:

1. Select from the following options in the Print dialog box:

<table>
<thead>
<tr>
<th>Dialog section</th>
<th>Option name</th>
<th>Does what</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printer</td>
<td>Name</td>
<td>Displays the available printers in a drop down list. The printer properties display under the name.</td>
</tr>
<tr>
<td></td>
<td>Properties</td>
<td>Displays the advanced document properties and options for the printer you select.</td>
</tr>
<tr>
<td>Print Range</td>
<td>All [total pages] pages</td>
<td>Prints all the pages in the currently selected report(s).</td>
</tr>
<tr>
<td></td>
<td>Pages: From [begin page number] to [end page number]</td>
<td>Prints only the range of pages you enter for the selected report(s).</td>
</tr>
<tr>
<td></td>
<td>Current Page</td>
<td>Prints only the currently displayed page.</td>
</tr>
</tbody>
</table>
Using Page Setup

The options you set in the Page Setup dialog boxes are saved with your report. You can change the page setup options for each report in your document.

To specify how you want the printed page to be set up:

1. Click **Page Setup** from the Print Preview window.

<table>
<thead>
<tr>
<th>Dialog section</th>
<th>Option name</th>
<th>Does what</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copies</td>
<td>Number of copies</td>
<td>Allows you to specify the number of copies. Use the up or down arrow to increase or decrease the number or enter a number in the text box. The default value is 1.</td>
</tr>
<tr>
<td></td>
<td>Collate</td>
<td>Allows you to print the same pages together to collate multi-copy print jobs.</td>
</tr>
<tr>
<td>Print What</td>
<td>Selected reports</td>
<td>Allows you to print only the currently selected reports.</td>
</tr>
<tr>
<td></td>
<td>All reports</td>
<td>Allows you to print all the reports in the document using the Page Setup options of the report you selected.</td>
</tr>
<tr>
<td>Page Number</td>
<td>Number across selected reports</td>
<td>Adjusts the page numbers to consider the current print job (if your reports contains the Page # variable)</td>
</tr>
</tbody>
</table>

2. Click **OK** or **Cancel**.
   - **OK** prints the selected report(s) to the printer specified.
   - **Cancel** closes the Print dialog box without printing your report(s).
2. Enter the options you require for:
   • paper Orientation - Portrait or Landscape
   • paper Size and Source
   • print size scaling under Fit to Print

   Tip: The scaling option reduces or enlarges the printed size of your report. To change the scale of your printed report, use this option only rather than the scaling option found in the advanced printer options.

3. Click **Margins** to set the margin sizes.

4. Enter the margin size for all sides of the printed area.
Tip: If you want to set your margins to the minimum values by entering zeros, Business Objects recommends that you verify the minimum margin accepted by your printer driver. Some drivers automatically redefine the margin size you entered to the minimum accepted margin but others do not. You risk losing information if the border of the printed document is cut.

5. Click OK or Cancel.
   • OK saves your changes and closes the dialog box.
   • Cancel discards your changes and closes the dialog box.

6. Click Page Number to access the page numbering Page Setup dialog box.

7. Enter the page number in the First page number text box under Page Number for the first page of the report.
   This page number appears on the first page of the report if you insert page numbers.
   Note: If you select to print Page # / Total Pages and you entered 5 in the First page number text box, the total page numbers take into consideration the total number of pages in that report. For example, if your report is five pages long, the first page indicates Page 5/5, then Page 6/5, Page 7/5 and so on.

8. Select one of the Page order options, if your report is several pages wide and several pages long:
   • Click the Over, then down option to print the horizontal pages then the next vertical page.
   • Click the Down, then over option to print vertically before horizontally.

9. Click OK or Cancel.
   • OK saves your changes and closes the dialog box.
   • Cancel discards your changes and closes the dialog box.
10. Click **Printer** to select the printer source from the Page Setup dialog box.

11. Click the **Network** button to connect to another printer on your network.

12. Specify the name of the printer to use in the **Printer** text box by typing the full printer name or by browsing for the printer after expanding the network list.

13. Click **OK** or **Cancel**.
   - **OK** saves your changes and closes the dialog box.
   - **Cancel** discards your changes and closes the dialog box.

14. Click **OK** again in the Page Setup dialog box to save these options for the current report.

**Note:** If you click **Printer Properties** and **Advanced** and change the settings, these settings only apply to the current print job for the current printer selection. If you change the printer and print again, the advanced settings are reset to the defaults for the current printer.
Using Print Preview

Print preview allows you to view the reports before you print. You can access Print Preview in two ways:

- Click the **Print Preview** button from the Print Setup dialog box.
- Click **Print Preview** from the **File** menu.

Advanced printer options apply for the current print job. Whenever possible, avoid relying on the advanced options unless you are certain that the document will always print to the same printer.
You can then print the report(s) by clicking the Print button directly from the Print Preview window.

**Note:** Desktop Intelligence optimizes chart printing if the printer driver does not detect the same color used in your chart. Desktop Intelligence replaces the true color with the closest color to the one you selected so the other colors may be distinguished on a monochrome or color printer.

**Printing multi-page reports**

Printing Desktop Intelligence reports, whether large or small, can be an involved process because your screen display may not always give you the results you expect on the printer.

Also, depending on the type of printer and the format of your reports, graphics and tables may appear slightly different on the printed page.

Printing multi-page reports can be more challenging than single page reports. Because data may run over several pages, you need to decide how it should appear once printed. Additional information on setting up your report to display data over several pages is available in the chapter on “Formatting Sections, Tables, and Cells” on page 201.
How do you want the data to display?

If you have a multi-page report, that is, data spreads over several pages, you can decide in what order you want the data to appear in your printed pages.

1. Click Print Preview
2. Click Page Setup in the print preview screen.
3. Click Page Number from the Page Setup.
   Another Page Setup dialog box appears.
4. Enter the number you want to appear on the first page in the First page number box under Page Number.
5. Click Over, then down, if you want to print the data in your reports from left to right and top to bottom.
6. Click Down, then over, if you want to print the data in your reports from top to bottom left to top to bottom right.
7. Click OK.

The dialog box closes and you return to the first Page Setup dialog box.
Example: Accommodating international audiences with Page Setup

If you are working in the United States and sending your document to users in France, select the A4 size paper in the Page Setup dialog box so that the European page size standard is saved with your document.

Tip: If your report uses the Euro character (€), some printers may not print it correctly. To ensure that the Euro prints, select **Download as Softfont** for the True Type Font setting under Graphic in the Advanced Options.

If your report displays the Euro (€) currency symbol on screen but does not print it, you may not have a compatible printer driver. Known printers that require changing the setting as shown above are:

- HP LaserJet 4/4M Plus + postscript driver
- HP LaserJet5si + post script driver

Note: When you set advanced printer options then save your document, these advanced settings only apply if you print to the same printer. Due to the complexity of the various printers, Business Objects cannot test, therefore support all the advanced printer options.
Exporting Data from Desktop Intelligence
Overview

You can export data from Desktop Intelligence to use in other applications. This chapter describes:

• how to save the result of a data provider in a format that is recognized by the application you want to use
• what external formats are available
• how to export data from Desktop Intelligence.

What external formats are available?

You can export data from Desktop Intelligence to the following local file formats:

• **Text Files**
  You can open the text file in many different applications, and on platforms other than Windows (Macintosh, OS/2 or UNIX, for example).

• **dBASE Files**
  You can create a separate .dbf file that can be distributed and shared with other databases.

• **Spreadsheet format (Microsoft Excel 97 and Microsoft Excel)**
  When you view the exported data in the spreadsheet application, each value appears in a separate cell.

  **Tip:** You can now save your Desktop Intelligence document containing multiple reports and graphs directly as Microsoft Excel files. For more information, see “Saving a document as an Excel file” on page 65.

• **XML Files**
You can export the data from your data provider to the XML format so it can be read by other applications. XML files may also be used as data providers, see the Desktop Intelligence User's Guide:Accessing Data and Data Analysis for more information.

Exporting data from Desktop Intelligence

This section explains how to export data from Desktop Intelligence to the format you need. Here's how to do it:

1. Open the report containing the data you want to export.
2. Click View Data on the Data menu.
   The Data Manager appears.
3. In Data Providers box, click the icon of the data provider containing the data you want to export:

![Data Manager](image)

4. Click Export. The Export to External Format dialog box appears:

![Export to External Format](image)

5. Click the option under Format for your data export. You can choose to:
   - Export to a Local File Format, including: text, Microsoft Excel, dBASE and XML files
   - Export to RDBMS
• **Copy to DDE**

6. Use the table below as a guideline to select how you want to export the data.

**Note:** Exporting to RDBMS is disabled while you are working with Desktop Intelligence in 3-tier mode. For security reasons, it is not possible to create personal connections to the database. You can only create secure connections for Desktop Intelligence in 2-tier mode with Designer or via the free-hand SQL data provider. For more information on creating personal and secure connections, see *Desktop Intelligence User’s Guide: Accessing Data and Data Analysis*, Chapter 4, Building Queries with Other Types of Data Providers, or see your Desktop Intelligence administrator.

The following table describes the options available and the actions required:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Actions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Export to Local File Format</strong></td>
<td>exports the data to one of these formats:</td>
<td>a. Select the file type in the Format list box.</td>
</tr>
<tr>
<td></td>
<td>• text file (.txt)</td>
<td>b. Click <strong>Browse</strong> to specify the file name and location.</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Excel file (.xls)</td>
<td>c. If you are exporting the data to a text file, you can:</td>
</tr>
<tr>
<td></td>
<td>• dBASE file (.dbf)</td>
<td>• Change the delimiter by typing a different character in the Delimiter box</td>
</tr>
<tr>
<td></td>
<td>• eXtensible Markup Language file (.xml)</td>
<td>• Click the <strong>DOS Format</strong> check box.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>d. Click <strong>OK</strong>.</td>
</tr>
</tbody>
</table>
3 Exporting Data from Desktop Intelligence

Exporting data from Desktop Intelligence

Tip: Click the Delete Spaces option to remove blanks from the data you export.

7. Click OK to export the data.

You can now use the data from Desktop Intelligence in the applications that support the external format you selected.

Date settings for the 21st century

Business Objects strongly advises you to set a four-digit year style on the Date tab of the Windows Regional Settings Properties dialog box before exporting. This ensures that you will not lose century information if you are exporting data from Desktop Intelligence to text files.
Displaying text files with earlier versions of Desktop Intelligence

When you export data to text (*.txt) files in versions prior to Desktop Intelligence 4.1, character strings are surrounded by double quotes in addition to being set off by your selected delimiter. Desktop Intelligence 4.1 and later, does not add double quotes to the character strings.

For example, in Desktop Intelligence 4.1, and later, a character string such as “jean” y “55” becomes jean y 55.

Exporting text files changes the numeric format

When you export data to text (*.txt) files, integers are changed to decimals. Two decimal places are added to integers. For example, if a number in the Desktop Intelligence report displays an integer such as $435, the text file you export displays $435.00.

Copying and pasting from Desktop Intelligence to another application

You can copy objects such as tables and charts in Desktop Intelligence, or copy the whole report contents, and then paste them into a Microsoft Office applications, such as Word.

To copy and paste an object:

1. Press Alt and click the table you want to copy.
2. Press Ctrl + C.
3. Move to the target application.
4. Press Ctrl + V.

Copying and pasting a whole report

You can also copy a whole report and then paste the report data either as images, for presentation purposes, or as text. The table below summarizes how you can copy and paste different types of report components:

<table>
<thead>
<tr>
<th>If you copy a report with</th>
<th>You can</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables, crosstabs and cells</td>
<td>Paste the data in them as an image or as text</td>
</tr>
<tr>
<td>Charts and images</td>
<td>Paste them as images</td>
</tr>
</tbody>
</table>
Example: Copying and pasting from Desktop Intelligence to Microsoft Word

The following example shows how to copy data from Desktop Intelligence to Microsoft Word:

1. From the Edit menu, click **Copy All**.
   Desktop Intelligence copies the contents of the currently active report to the clipboard.

2. Open the Microsoft Word document in which you want to paste your data.

3. From the Edit menu, click **Paste Special**.

4. Select the data format from the list. The choices appear below.

<table>
<thead>
<tr>
<th>Select</th>
<th>To copy the clipboard contents as</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Data that you can then work on in Excel.</td>
</tr>
<tr>
<td>Picture</td>
<td>A Picture image. For example, a Desktop Intelligence table is copied as an image and you will not be able to work on the data. This is the recommended format for pasting images.</td>
</tr>
<tr>
<td>Bitmap</td>
<td>A Bitmap image. If you select to paste a Bitmap image, bear in mind that this format can use a lot of memory and disk space.</td>
</tr>
</tbody>
</table>

The clipboard contents are pasted into the Word document.
Report Set Up and Creation
Templates and Standard Report Styles
Overview

This chapter describes how to set up templates and how to customize the standard report styles used to create standard reports.

Using templates saves you time if you regularly use the same structure and formatting for your reports. You make the settings once and then re-use them in all your reports.

Customizing standard report styles allows you to change the default shading, fonts, and other formatting that Desktop Intelligence uses by default each time you create a standard report or insert a new table, cell, break or other component in an existing report.

Who should read this chapter

Most of the information in this chapter concerns those users in your company who are designing templates and styles. If you are not designing templates and styles, all you need to know is how to:

• apply a template to your report
• use a template when you create a new document
• apply standard report styles to a report

What are templates and standard report styles?

When you create a new document in Desktop Intelligence, you choose in what type of report layout your data will be displayed. You can either generate a standard report or generate a report from a set of templates.
What is a standard report?

When you install Desktop Intelligence and create your first standard report, your data is displayed in a table with a report title and has the default application formatting as illustrated below.

<table>
<thead>
<tr>
<th></th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q1</td>
<td>$5,528,772</td>
</tr>
<tr>
<td>Q2</td>
<td>$2,940,561</td>
</tr>
<tr>
<td>Q3</td>
<td>$2,079,303</td>
</tr>
<tr>
<td>Q4</td>
<td>$4,185,120</td>
</tr>
<tr>
<td>Sum:</td>
<td>$13,233,666</td>
</tr>
</tbody>
</table>

Table 4-1: Here is a sample of the standard report style

The table header is dark blue, the body cells are white with text and numbers in Arial size 10 font and black borders. The table footer has a white background and free-standing cells have a black border and are center aligned.

Whenever you insert a new table, crosstab or free-standing cell in a report, the default formatting is used.

Using the Standard Report Styles editor, you can customize and save custom formatting attributes. Once you save custom colors, fonts, number styles in the Standard Report Styles, the format applies when you create a new report or when you insert a new component in a report such as a break or a crosstab.

The settings that define the styles used to create a standard report are contained in a file called default.ret. This file is stored in the Desktop Intelligence demo\templates folder.

Since the settings used to create a standard report are contained in one file, you can customize these settings once and then distribute this file to all users in the company. Every time a user creates a standard report, the corporate formatting will be used.

Note:

A standard report does not contain information on page setup such as margin sizes and page orientation. If you want to include this information when you create a new report, use a template. See “Modifying the standard report styles template” on page 106 for more information.
4 Templates and Standard Report Styles

What are templates and standard report styles?

What is a template?

A template is a special Desktop Intelligence document that contains pre-defined styles and a structure that you use as a foundation to create reports. Desktop Intelligence installs several templates for you to use and you can also create your own.

A standard report does not contain information on page setup or include custom elements such as graphics. A Desktop Intelligence template allows you to do this.

Example: Always displaying your company’s logo in the header of your reports

When you create and use your own templates, you apply customized styles and structure to your reports. You can place the logo in the header of a template, then use the template when creating or formatting reports.

Templates contain a report structure and styles. You can either use a template when you create a report or you can apply a template to an existing report.

Structure

The structure of a report defines how the data is presented. Your data can be presented in a crosstab, a column chart, or it can have a master/detail structure. When you use a template, the data displays in the structure and uses the formatting that is defined in the template.

Styles

The styles contained in a template define the report page background and the style of the headers and footers.

Setting a default report layout

You can set default options for the layout you want to use when you create new reports with the New Report wizard. This allows you to always use the same template or to always create a standard report.

To do this:

1. From the Tools menu, click Options.
   
   The Options dialog box opens.

2. Click the New Document tab.
3. Set the required options under Report Layout.

![Diagram of Customizing Standard Report Styles dialog box]

- Prompts you to select the type of report layout you want to create.
- Displays a screen that allows you to select a template. Always uses the template you to select in this list box.
- Always creates a standard report.

**Tip:**

If you have set a default universe and template, you can create documents without using the New Report Wizard. When you click New or click New from the File menu, the Query Panel appears. The Classes and Objects list presents the classes and objects of the default universe. When you build the query, the data appears in the layout provided by the default template you set.

### Customizing Standard Report Styles

You customize standard report styles in the Standard Report Styles dialog box. You can open the Standard Report Styles dialog box with or without a Desktop Intelligence document open.

To open the Standard Report Styles dialog box:
Templates and Standard Report Styles

Customizing standard report styles

- From the Tools menu, click **Standard Report Styles**.

The Standard Report Styles dialog box has two parts:

- **Report Components**
  
  Displays a list of the components that make up a report on the left-hand side of the dialog box. This includes tables, crosstabs and cells as well as breaks, sections, and page. Each component in the list is identified by an icon.

- **Settings tabs**
  
  Displays the formatting options that can be set for the selected component. When you click on an icon in the list, the tabs on the right-hand side of the dialog box change according to the options. These are the same tabs used on the format dialog boxes, such as General, Page Layout, Border and Shading. You can expand the list by clicking on the icons that have a plus sign next to them.

**Editing standard report styles**

What you can change depends on the type of report component.

The following buttons are available on the **Standard Report Styles** dialog:

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Add a break or section level.</td>
</tr>
<tr>
<td>Delete</td>
<td>Remove a break or section level from the list.</td>
</tr>
</tbody>
</table>
Customizing standard report styles

Editing settings

To edit settings in the Standard Report Styles window:

1. Select the item you want to modify in the Report Component list.
   The tabs display the formatting options available for the selected item.
2. Make the required settings on the tabs.
3. Click OK to save the changes and close the dialog box.

Note:
You cannot set the name of table or crosstabs in the Standard Report Styles dialog box. This option is available when you select a table or cross tab from a report and right-click to format it individually.

Editing settings and applying to an open report

If you have a document open and want to apply the changes you have made in the Standard Report Styles to the active report:

• After making the required changes, click Apply, then OK.

Click | To
---|---
OK | Save the changes you have made and close the dialog box. The changes are saved in the default.ret file.
Cancel | Close the dialog box without saving any changes you have made.
Apply | Apply the changes you have made to the active report. This button does not display if your document is not open.
Help | Open the online help for help on applying these options.

Note:
You cannot set chart attributes in the Standard Report Styles dialog box.
Templates and Standard Report Styles

Customizing standard report styles

Tables

You can edit the default formatting and page layout options for tables.

To edit general settings for tables, select the table icon in the list. General settings include whether to display headers and footers, table orientation and how page breaks are handled.

To edit the settings for the different elements that make up a table, click on the plus sign next to the table icon.

You can set different formatting for header, body and footer columns and rows.

For more information on the formatting options for tables, see “Formatting tables” on page 206.

Crosstabs

You can edit the default formatting and page layout options for crosstabs.

Select the crosstab icon to edit general settings for crosstabs. General settings include whether to display headers and footers and how page breaks are handled.

To edit the settings for the different elements that make up a crosstab, click on the plus sign next to the crosstab icon.

You can set styles for headers and footers, for the body cells of the crosstab and for the four corners of a crosstab.
Breaks

You can edit the settings for breaks you insert in tables and crosstabs. You can define up to nine different break levels with different attributes set for each level.

Click on the Breaks icon to edit settings that will apply to all breaks in the report.

Click on the Level n icon to edit settings that will apply to all level n breaks in the report.

Open the Level n folder and click on Down or Across to edit settings that apply only to the selected item.

For more information on formatting breaks see “Formatting breaks” on page 190.

Adding and deleting break levels

When you add a new break level, Desktop Intelligence inserts the new level below the level selected when you click Add. The newly inserted break level has the same style settings as the break level under which it is inserted.

To add a break level:
1. Select the Break level under which you want to add a break.
2. Click Add.
   A new break level is added to the list.

To delete a break level:
1. Select the break level you want to delete in the list.
2. Click Delete.

Sections

You can set different attributes for up to nine different sections in a report.
You can set attributes for the cells that are displayed at the top of each section and that contain the master value and for the background shading of the section.

Click on the Section icon to edit settings that apply to all the section levels in your report.

To edit settings for a particular section, click on the Level n icon and make the required changes.

To edit the settings for the different elements that make up a section, click on the plus sign next to the Level n icon to open up the section list.

Click on Master Cell to edit settings for the master cell.

Click on Section Area to edit the background shading for the selected section.

For more information on formatting sections, see “Formatting sections” on page 202.

Adding and deleting sections

When you add a new section level, Desktop Intelligence inserts the new level below the level selected when you click Add. The newly inserted section level has the same style settings as the section level under which it is inserted.

To add a section:
1. Select the Section level under which you want to add a section.
2. Click Add.
   A new section is added to the list.

To delete a section:
1. Select the section you want to delete in the list.
2. Click Delete.
Pages

You can edit the background shading for the report page. You can either set the same shading for the whole page or set the shading for the page header, page body and page footer separately.

Select the Page icon to set the same shading for all three page elements.

To edit the settings for the different elements that make up a page, click on the plus sign next to the page icon.

You can set different shading for the page header, the main section (the page body) and the page footer.

Free-standing cells

Click on the cell icon to edit settings for free-standing cells. For more information on formatting cells, see “Formatting cells” on page 216.

Applying standard report styles

You can create a new standard report using your custom standard report style settings or you can apply your custom styles to existing reports.

You can apply your custom standard report styles to the whole report or to a selected item.

Applying standard report styles to the report

• From the Format menu, click Report and then Apply Standard Style.
Applying standard report styles to a selected component

You may want to only apply a standard report style to a selected table, crosstab or cell, for example. When you apply a standard report style to a selected component, only the formatting attributes are applied. The pagination and break settings are ignored so that your report layout is not disorganized.

1. Open the Report Manager window.
2. Click the Map tab.
3. Click Structure.
4. The list of report components displays.
5. Right-click the component on which you want to apply the standard report style.
6. Click Apply Standard Style from the menu.

Tip:
For a section or cell, you can right-click on the component you want to apply the standard report style to and click Apply Standard Style from the menu.

Making sure everyone uses the same standard report styles

Any changes you make to the standard report style settings are saved in the default.ret file. This allows you to customize the standard report styles once using your corporate formatting and then distribute the default.ret file to all users in a company via the repository. To do this:

1. Edit and save the standard report styles on your computer.
2. Distribute the default.ret file to all users in a company via the repository. See page 71.
3. Make sure all users in the company are using the same default.ret file.

There are several ways to make sure everyone uses the same report styles

- Send the default.ret file to all users and have them copy it into their template folder under My Desktop Intelligence Documents.
- Change the template folder location to point to the folder containing the customized default.ret file; you can also do this during installation.
What if you cannot locate the default.ret file?

If Desktop Intelligence cannot find the default.ret file, it will re-create one using the default application settings. The standard report created will not reflect any changes you have made.

Follow these steps to regenerate your default.ret if it has become corrupted.

1. **Delete** or move the default.ret to a different location with Windows Explorer.
2. Start Desktop Intelligence and generate a standard report.
3. Create your template style again.
4. Save it as the default.ret as explained on page 107.

**Note:**

When you first install Desktop Intelligence the default.ret is placed in the Program Files\BusinessObjects Enterprise 11.5\templates\[language] folder. A sub-directory for each language you install is created. The first time you launch Desktop Intelligence these template files are copied to your Documents and Settings\[username]\My Documents\My BusinessObjects Documents\templates\[language] folder. This becomes the default location for your templates. If you have changed the default location of your User Templates in your Desktop Intelligence options, make sure the default.ret file is in this folder.

Changing the location of the template folder

To change the location of your template folder:

1. Click **Options** from the **Tools** menu.
   
   The Options dialog box appears.
2. Click the **File Locations** tab.
3. Click **User Templates** from the File Types list.
4. Click **Change**.
5. Browse to the new location of the template folder.
6. Click **OK**.

**Note:**

Do not click the language subdirectory for your template folder when you change the default location. The default location takes into consideration your default language. This allows you to change languages dynamically and get access to the appropriate language templates without having to change the default location.
Modifying the standard report styles template

To make sure that the standard styles you want to use are saved in a template, apply the styles to a report before saving it as a template:

1. Click **Standard Report Styles** in the **Tools** menu.
2. Make all the formatting settings in the Standard Report Styles window and click **OK** to save your changes.
3. You can create a new Standard report using these settings or apply the new standard styles to an existing report.
4. Set up the report page layout, margins, and add any other elements you want to include in the template.
5. Click **Save As** and select **Desktop Intelligence Templates (.ret)** from the drop-down list.
6. Browse to the folder where your Desktop Intelligence templates are located.
7. Enter a **File name** for the template and click **Save**.
8. To apply the formats from this template the next time you create a new report, click **Select a template** in the New Report Wizard dialog box.
9. Click **Begin** and click your template from the list of **Available Templates**.

**Note:**
The standard report styles saved with this template are the ones set at the time of creating the template. This means that if, at a later date, you change settings in the Standard Report Styles window, the styles saved in the template will not be the same.

Using templates

You can use a template in the following situations:

- **When creating a report.**
  The New Report Wizard includes a dialog box that enables you to view and select the template you want to use. The styles and structure of the template are applied to the new report.

- **When formatting an existing report.**
  When you apply a template you can click to apply the template styles only, or to apply the styles and the structure.

If you click to apply the styles and the structure, you can also manually replace certain variables in the template with certain variables from the report.
Using templates

Creating a template

To create a template you first need to create a report that can serve as the model for the template.

1. Open the document you want to save as a template.
2. Edit all the required formatting, page settings and include your corporate logo or other graphics.
3. Click Save As from the File menu.
   The Save Document As dialog box appears.
4. Click the Save as type box, then click Desktop Intelligence Templates (*.ret).
5. Select the folder in which you want to save the template.
   The default location for templates is My Documents\My BusinessObjects Documents\Templates folder in the desktop. Saving it here will make them available when you use the New Report Wizard. To change the default template location, see below.
6. Type the name of the template in the File Name box, then click OK.
   The template saves with the .ret file extension.

Changing the default template folder

To set a default folder other than Template in which to save your templates

1. From the Tools menu click Options.
2. Click on the File Location tab.
3. Click User Templates.
4. Click Browse to select the folder you want to use.

Note:

For international or multi-language deployments, you may need to save or access templates created for users in different languages. Business Objects recommends that you save specific language template files in their relevant sub-directory. The templates supplied with Desktop Intelligence are localized.
for each language deployment. Therefore, when you install Desktop Intelligence, sub-directories for each language you select are automatically created.

**Applying a template**

You can quickly format an existing report by applying a template.

1. Open the report you want to format.
2. From the **Format** menu, click **Report** then **Apply Template**. The **Apply a Template** dialog box appears:

![Apply a Template dialog box](image)

3. Select a template from the Available Templates list.

   **Note:**  
   If the template you want to use is located in a folder other than the one set in the File Locations tab on the dialog box, click **Browse**. A dialog box appears, and enables you to select the folder where the template is located.

   1. The next step depends on what you want to do:

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Click</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>apply the template styles and structure to the report</td>
<td><strong>OK</strong></td>
<td>Desktop Intelligence applies the template to the report</td>
</tr>
<tr>
<td>choose what to apply from the template to the report</td>
<td><strong>Options</strong></td>
<td>the Template Options dialog box opens</td>
</tr>
</tbody>
</table>
2. In the Template Options dialog box, click **Apply Standard Style** if you want to apply the page background and header/footer contained in the Standard template.

Only the options in the Page Options section are available:

3. If you do not want to apply the background or header/footer, deselect **Apply Template Background** and **Apply Template Header and Footer**, respectively.

4. Click **Apply Structure and Style** if you want to apply the template’s style and its structure (blocks, sections) to the report.

   This option:
   - activates the options in the Structure box
   - enables you to replace variables in the template with variables from the report

   **Note:**

   For information on how to do this, refer to “Replacing variables in a template with variables from a report” on page 110.

1. Click **OK**, then click **Apply** or **OK** in the Apply a Template dialog box.

   **Note:**

   You cannot apply templates created using Desktop Intelligence version 4.1 to reports created using Desktop Intelligence version 6.1 and vice versa. You can however, use templates created with Desktop Intelligence 5.x in Desktop Intelligence 6.x and vice versa.
Using templates

Replacing variables in a template with variables from a report

When you apply a template, by default Desktop Intelligence chooses how to place the variables in the report into the template structure. You can also choose manually how you want to map variables in the report to variables in the template structure. To do so:

1. From an open a report, click **Apply Template** from the Format menu. The **Apply a Template** dialog box appears.
2. Click **Options**. The Template Options dialog box appears.
3. Click **Apply Structure and Style**. The options in the Structure box become active.
4. Clear **Replace Variables Automatically**, then click **Define**. The **Replace Variables** dialog box appears.
5. In the Report Variables box, click the report variable you want to map to the template variable.
6. In the Template Variables box, click the template variable that you want to be replaced by the report variable, then click **Replace**. The variable from the report appears in the Template Variables box:

   ![Replace Variables dialog box](image)

   Here, the user has replaced Customer with Region. Region will appear in the report where Customer appears in the template.

7. Repeat Step 6, to replace other variables, then click **OK**.
8. To undo a replacement, click the variable in the Template Variables box, then click Remove.

9. In the Template Options dialog box, click OK.
   The Template Options dialog box closes and the Apply a Template dialog box becomes active.

10. Click OK.
    Desktop Intelligence applies the template to the report and closes the dialog box.
Templates and Standard Report Styles

Using templates
Setting Up Master/Detail Reports
Overview

This chapter describes how to structure your data and create a master/detail report. These chapter headings direct you to information on:

- “What are master/detail reports?” on page 114
- “Structuring a master/detail report” on page 115
- “Re-organizing a master/detail report” on page 119
- “Managing sections in a master/detail report” on page 120
- “Undoing a master/detail report” on page 121

What are master/detail reports?

Master/detail reports enable you to split large blocks of data into sections. This type of presentation allows you to minimize repeating values and to display subtotals.
In the example below the table displays data for Resort, Quarter and Revenue. The Quarter column has repeated values. If you set Quarter as a master value, each distinct value of quarter creates a section. You now have four sections, one for each quarter. Each section has a master cell, and a table showing resort and revenue.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$204,851</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q2</td>
<td>$257,982</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q3</td>
<td>$253,425</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q4</td>
<td>$346,289</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$206,605</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q2</td>
<td>$542,185</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q3</td>
<td>$226,126</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q4</td>
<td>$158,965</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q3</td>
<td>$395,190</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q4</td>
<td>$335,930</td>
</tr>
</tbody>
</table>

a. For each value of the master, Quarter, a section is created. One master value appears in a cell inside each section. In this section, the master value is "Q1".
b. The detail can be a table, crosstab or chart. It displays data that relates to the master. In this report, the detail is a table that shows revenue per resort.
c. You can clearly see the sections in a master/detail report by activating the Section Delimiters command on the View menu.

**Figure 5-1: Structuring a master/detail report**

**Structuring a master/detail report**

You set up a master/detail report by setting a variable as a master cell. This section describes the different ways to do this. You can:

- use a variable in a table or crosstab to create a master cell
- add a variable from the Report Manager to create a master cell
Setting Up Master/Detail Reports

Structuring a master/detail report

From a table or crosstab

If the data you want to set as the master is already displayed in a table or crosstab, you can drag it out of the table or crosstab and create a section. To do this:

1. Click inside the column or row that contains the data you want to use as master.
2. Click inside the data again, click and drag the data away from the table or crosstab.

The cursor changes to the Set as Master cursor.

3. Release the mouse in a blank space above the table or crosstab.

The column or row of data you clicked is removed from the table or crosstab. For each of its values, a section is created.

Each section contains:

• a master cell which displays one value
• a table or crosstab

Tip: You can also right-click on the row or column of data you want to set as master and click Set As Master from the menu.
From the Report Manager

If your report contains a chart or the variable you want to set as master but it is not currently in the table or crosstab, you can add a master cell from the Report Manager window. To do this:

1. If Report Manager is not open, click Report Manager from the View menu.
2. In the Report Manager Data tab, click the variable you want to use as a master.
3. Drag the variable from the Report Manager window into the Report window.
   The pointer changes to the insert cell cursor and the status bar displays Drop to create section.
4. Drop the variable in the report above the block.
### Setting Up Master/Detail Reports

#### Structuring a master/detail report

A section is created for each value of the variable.

#### Building a master/master/detail report

A master/master/detail report has sections within sections. You create this type of report in the same way you create a master/detail report by dragging a value out of a table or crosstab or from the Report Manager and creating a second section.

You can create up to nine sections in a report by adding master cells above or below the current master cells.
Example: Making a report with a year and a quarter section

In this example, you have a report with a Quarter section. You want to add a year section so each financial year section displays the data for the four quarters in that year. To do this:

- Drag the Year variable from Report Manager and drop in the report to create a new master cell.

Re-organizing a master/detail report

You can re-organize the section levels in a master/detail report or change the master to get a different view of your data.

Replace a master with a new variable

- Drag a new variable from the table or crosstab or from the Report Manager window and drop it into the master cell.
Setting Up Master/Detail Reports

Managing sections in a master/detail report

Change the order in a master/master/detail

1. Click on one of the master cells.

   From this
   
   
   Bahamas Beach
   
   Accommodation | Revenue |
   
   Food & Drinks | $7,765 |
   
   Recreation | $6,000 |

   to this
   
   Q1
   
   Accommodation | Revenue |
   
   Food & Drinks | $7,765 |
   
   Recreation | $6,000 |

2. Drag the cell and drop it on the other cell.

   The contents are swapped and the section levels are changed.

Sorting, ranking and filters

You can sort, filter and rank data in master/detail reports. You can sort, filter and rank the values in the master cells and/or the data in the tables and crosstabs in the sections. For more information on sorting, ranking and filtering data, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 11 “Filtering and Ranking Data”.

Managing sections in a master/detail report

When you create a section, it covers the entire width of the report. Whatever you add or change in one section is added or changed in all the other sections created by the same master.

Displaying section delimiters

Section delimiters are graphical markings that show you where sections begin and end. Each section is named. Showing these delimiters helps you organize and structure your sections.

To display the section delimiters:

1. From the View menu, click Section Delimiters.

   A check mark displays next to the command showing that it is active.

2. Click once on the report window.

3. The section delimiters display.
Scaling charts in master/detail reports

If you have a master/detail report that contains charts, you can use different scaling for the charts in the different sections. See “Scaling charts in master/detail reports” on page 121 for information on how to do this.

Formatting sections in master/detail reports

You can format the sections in a report by applying shading to the background. If you have set up a report with several sections, you can apply a different type of shading to each section in the report. This can allow you to easily distinguish between the different sections. For information on formatting sections, see “Formatting sections” on page 202.

Hiding sections in master/detail reports

You can hide sections in master/detail reports so that only the sections you are interested in are displayed. For information on how to do this, see “Showing and hiding report components” on page 152.

Undoing a master/detail report

You can undo a master/detail report in the following ways:

• by placing the master in the table or crosstab
• by removing the master from the report
• by removing the data from the master cell but leaving the cell in the report

Placing the master in a table or a crosstab

You can remove a master cell by adding it to a table or crosstab in the section. The cell is inserted as an extra column or row of data.

1. Click the master cell.
2. Click the master cell again and, click the mouse, drag the cell to the edge of the column or row where you want to insert it.
Setting Up Master/Detail Reports

Undoing a master/detail report

3. When the edge of the column or row highlights with a gray hatched border and the status bar displays the message *Drop to copy contents*, release the mouse.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>$224,001</td>
</tr>
<tr>
<td>French Riviera</td>
<td>$238,005</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>$357,170</td>
</tr>
</tbody>
</table>

4. The following message displays:

![Message to delete the section's master cell]

5. Either:

- Click **Yes** to remove the data, the master cell and the section from the report. A new column or row is added to display the data and the section is deleted from the report as shown below:

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$224,001</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$238,005</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q2</td>
<td>$297,922</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q2</td>
<td>$242,156</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q3</td>
<td>$393,422</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q3</td>
<td>$236,126</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q4</td>
<td>$295,289</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q4</td>
<td>$153,566</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q4</td>
<td>$355,500</td>
</tr>
</tbody>
</table>

- Or, click **No** to remove the data and the master cell but to leave the section in the report.
A new column or row is added to display the data and the section remains in the report as shown below:

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>D1</td>
<td>$220,000</td>
</tr>
<tr>
<td>French Riviera</td>
<td>D1</td>
<td>$1,095,500</td>
</tr>
<tr>
<td>Mauiwai Club</td>
<td>D1</td>
<td>$587,170</td>
</tr>
</tbody>
</table>

Deleting the master

1. Select the master cell.
2. From the Edit menu, click Delete.

The following message displays:

Tip: You can also remove a master cell by dragging it into the Report Manager window.

Clearing the master cell

1. Click the master cell.
2. Select Clear from the Edit menu.

The data from the master cell disappears, but the master cell remains.
Setting Up Master/Detail Reports

Undoing a master/detail report
Setting Up Report Layout
Setting Up Report Layout

Overview

This chapter describes how to set up your report layout.
You learn how to:
• set up and manage multi-page reports
• set margins, headers and footers
• control exactly what appears on each page of the report
• manage tables that extend over several pages using running headers and footers for calculations over page breaks
• enhance your report by adding document and tracking information such as author, page numbers, date and time
• prepare a report for viewing

Multi-page reports

When your report contains several pages, there are a number of options in Desktop Intelligence to manage the page layout over multiple pages so that your report reads fluently and coherently and you obtain good printed copy.

Setting what is to appear on each page

You can control how sections, tables and crosstabs, cells and charts appear on each page of a report. For example, in a report divided into sections, you may want to start a new page at the beginning of each new section. Or, you may wish to display a specific chart on every page of your report.

To display a block on every page of a report

1. Right-click the block.
2. Click Format Block from the menu.

<table>
<thead>
<tr>
<th>For a</th>
<th>Click this tab</th>
<th>Click this check box</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell</td>
<td>Alignment</td>
<td>Repeat on Every Page</td>
</tr>
<tr>
<td>table</td>
<td>Page Layout</td>
<td>Repeat Block on Every Page</td>
</tr>
<tr>
<td>crosstab</td>
<td>Page Layout</td>
<td>Repeat Block on Every Page</td>
</tr>
<tr>
<td>chart</td>
<td>General</td>
<td>Repeat on New Page</td>
</tr>
</tbody>
</table>
Note: If you click this check box and one block seems to overlap the other, the table borders may disappear. This known behavior is due to the fact that the two tables do not know how to share the display space that results in missing information.

Note: When you link two tables and you want to repeat blocks on every page, Business Objects recommends that you apply the option to both tables, otherwise the tables may overlap each other.

To display one section or block per page

1. Right-click on the block or in the section.
2. Click Format Block or Format Section from the menu.

<table>
<thead>
<tr>
<th>For a</th>
<th>Click this tab</th>
<th>Click this check box</th>
</tr>
</thead>
<tbody>
<tr>
<td>section</td>
<td>Alignment</td>
<td>Start on a New Page</td>
</tr>
<tr>
<td>table</td>
<td>Page Layout</td>
<td>Start on a New Page</td>
</tr>
<tr>
<td>crosstab</td>
<td>Page Layout</td>
<td>Start on a New Page</td>
</tr>
<tr>
<td>chart</td>
<td>General</td>
<td>Start on a New Page</td>
</tr>
</tbody>
</table>

Managing page breaks

When tables and charts extend over more than one page you need to make sure that they are split coherently and that the elements that help your readers to understand the tables and charts correctly, such as title headers on tables, are added to every new page. You may also want to include page sub-totals and previous page recaps for calculations to make it easier for your readers to follow tables of data over several pages.

The page break options are set on the format dialog boxes. To open the format dialog for a table, crosstab or chart:

1. Right-click on the block.
2. Click Format Block from the menu.

   The Format dialog box that opens depends on the type of block selected.
   • For crosstabs and tables, click the Page Layout tab.

   See page 129 for an illustration of the Page Layout tab.
For charts, click the **General** tab.

- Places the selected chart on a new page.
- Repeats the selected chart on every page of the report.
- Where possible, starts a new page for charts that would otherwise be split by a page break.
Figure 6-1: The page layout tab below shows the page break options for crosstabs. The table options are the same. The only difference is that you can manage page breaks for the across edge as well as the down edge for crosstabs.

Running headers and footers in tables

When a table extends over more than one page, you can insert a recap header on certain calculated amounts to make the table easier to follow. You do this by:

- inserting conditional headers and footers in your table
- inserting the text and the formula for the information you want to display into these header and footer cells

The headers and footers display only if there is a page break in your table. The example below shows how this works for a multi-page bank statement.
Example: How can I display page totals and recap amounts in a multi-page report?

The example below shows a two-page bank statement. To help the bank's client follow this two-page statement, the account status after the list of credits and debits is displayed at the bottom of the first page. This sum is then repeated at the top of the second page before the list of debits and credits continues. These two sums are only displayed if a page break occurs.

<table>
<thead>
<tr>
<th>Date</th>
<th>Identifier</th>
<th>Debit</th>
<th>Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>01/01/98</td>
<td>XXXXXXX</td>
<td>$250</td>
<td></td>
</tr>
<tr>
<td>02/01/98</td>
<td>XXXXXXX</td>
<td>$300</td>
<td></td>
</tr>
<tr>
<td>04/01/98</td>
<td>XXXXXXX</td>
<td></td>
<td>$10,000</td>
</tr>
<tr>
<td>06/01/98</td>
<td>XXXXXXX</td>
<td>$677</td>
<td></td>
</tr>
<tr>
<td>07/01/98</td>
<td>XXXXXXX</td>
<td>$90</td>
<td></td>
</tr>
<tr>
<td>Account Status</td>
<td></td>
<td></td>
<td>$30,683</td>
</tr>
</tbody>
</table>

**To set up a report with running headers and footers**

First, you have to activate the option. To do this:

1. Right-click on the table.
2. Click **Format Table** from the menu.
   
The Format Table dialog box opens.
3. Click the **Page Layout** tab.
4. Check **Page break header after page break** and **Page break footer before page break**.
5. Click **OK** to save and close the dialog box.

Next, you need to enter the formula. To do this:

1. In the **Report** toolbar, click **Page Layout**.

   You can only see page break headers and footers when you are in page layout mode and when the table extends over to the next page.
2. In the Report toolbar, click Structure.
3. Click the header/footer cell and type in the formula. Some formula samples appear in the table below.
4. Press Enter. The formula result displays in the cell.
5. Click in an adjacent cell and enter text to describe what the amount represents.

To add columns and rows to a running header or footer

By default, a page break header or footer has one column or row. You can add as many columns or rows as you need for the information you want to display. The size of the table is adjusted so that all the page break header and footer columns and rows fit onto the page.

1. Click Page Layout from the View menu to go to the page layout view.
2. Select the page break header or footer in the table.
3. Use the Structure toolbar buttons to insert the required columns and rows.
4. Insert the required formulas in the page break header and footer.

Running header and footer examples

Here are some examples of formulas used in page break headers and footers where the measure object to calculate is <Revenue>.

<table>
<thead>
<tr>
<th>To calculate and display</th>
<th>Type the following formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>A subtotal for the current page</td>
<td>=Sum(&lt;Revenue&gt;)</td>
</tr>
<tr>
<td>A running total, that is the sum of all the data displayed in the table up to and including the current page</td>
<td>=RunningSum(&lt;Revenue&gt;)</td>
</tr>
<tr>
<td>A recap amount from the previous page, that is the sum of all the data in the table up to and including the previous page</td>
<td>=RunningSum(&lt;Revenue&gt;) - Sum(&lt;Revenue&gt;)</td>
</tr>
<tr>
<td>The percentage of data displayed in the current page against all data displayed in the table</td>
<td>=Sum(&lt;Revenue&gt;)In CurrentPage/Sum(&lt;Revenue&gt;)In Block</td>
</tr>
</tbody>
</table>
Note: For information on writing formulas, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 17 “Formulas, Local Variables and Functions”. You can also use Input, Output and Reset contexts as well as the keyword arguments ForEach and ForAll in the page break header and footer cells. For information on using this extended syntax see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 15 “Calculation Context and Extended Syntax”.

Formatting page break headers and footers
You can change the font, number, color and other attributes for the text and numbers displayed in the page break header and footer cells. See “Formatting cells” on page 216 for information on how to do this.

Page setup
This section describes how to set up report page margins and how to use and format page headers and page footers. For more information on printing your report, see “Printing documents” on page 72.

Setting margins
When setting margins, the minimum margins size depends on the printer.

Tip: You may be tempted to reduce the margins as much as possible to fit everything on the printed page. Bear in mind, however, that reports are often bound or stored in binders and you need to allow an adequate margin for this.

To set margins:
1. From the File menu, click Page Setup.
   The Page Setup dialog box opens.
2. Click Margins to open the Margins dialog box.
3. Enter sizes for the Left, Right, Top and Bottom margins.
4. Click OK to close the Page Setup margins dialog box.
5. Click OK again to close the Page Setup dialog box.

**Note:** The options in Page Setup (except the Advanced printer options) are saved with your document. Keep this in mind when you are sharing documents. Other users may not have the same page setup standards, such as paper size, or source.

### Using headers and footers

The Header and Footer sections of the page are most frequently used to display information that you want to repeat on every page, such as; page numbers, author name and creation date.

#### Inserting a cell in a page header or footer

If you want to display information (text, pictures, variables) in a header or footer, you must first insert a cell. Here is how to do it:

1. In the **Report** toolbar, click **Page Layout**.
   
   You can only see the header and footer sections in Page Layout View.

2. Click inside the header or footer, then click **Cell** from the **Insert** menu.
   
   The cursor changes to the Insert Cell cursor.

3. Click where you want your cell to appear and, click the mouse and drag to draw a cell.

4. Release the mouse.
   
   A cell appears in the area and the flashing cursor indicates you can enter text.

5. Type your text or formula in the cell and press Enter.
Applying shading to a header or footer

You can apply different color shades and patterns to a header or footer. Here is how:

1. Click **Page Layout** from the **View** menu.
2. Click inside the header or footer, then select the **Page Header** or **Page Footer** from the **Format** menu.
   - The Page Header Format dialog box or the Page Footer dialog box appears. Each dialog box contains the Shading tab only.
3. Select the fill, foreground color and background color.
4. Click **OK** to apply the changes.

Resizing headers, footers and margins

You can decrease or increase the height of headers and footers, and the width of margins, by dragging the mouse:

1. Click to activate **Page Layout** from the **View** menu.
2. Position the pointer over the element you want to resize.
3. When the pointer changes to the resize cursor, click the mouse and drag until the header, footer or margin reach the size you want, then release the mouse.

Using page numbers, times and dates

Desktop Intelligence has pre-defined page number, date and time functions that you can insert in your reports directly from the Insert menu. Each time you save the document these functions update automatically.

Inserting numbers, time and date

To insert a page number or a date at the top of the page (in the page header) or at the bottom of the page (in the page footer):

1. From the **View** menu, click **Page Layout**.
   - The page number commands are available only in Page Layout view.
2. If the margin lines do not display, click **Page Margins** from the **View** menu.
3. From the **Insert** menu, click **Special Field** then **Page Numbers** or **Date and Time** and then an option from the submenu.
The options are described below.

### Page Numbers

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page #</td>
<td>Displays the word Page followed by the current page number</td>
</tr>
<tr>
<td>Page # of #</td>
<td>Displays the current page number and then the total number of pages in the report</td>
</tr>
</tbody>
</table>

### Date and Time

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current</td>
<td>Displays the current date and time (automatically updated each time a report is opened)</td>
</tr>
<tr>
<td>Save Date</td>
<td>Displays the date on which the report was last saved (automatically updated)</td>
</tr>
<tr>
<td>Print Date</td>
<td>Displays the date on which the report was last printed (automatically updated)</td>
</tr>
<tr>
<td>Last Refresh Date</td>
<td>Displays the date on which the data in the report was last refreshed with the most up-to-date data from the database (automatically updated)</td>
</tr>
</tbody>
</table>

The mouse cursor turns to the Insert Cell cursor

4. Click once in the area of the report where you want your page numbers to appear.

A cell displaying the page number inserts in the section.

**Formatting the cell**

When you insert a cell it has the default formatting. To change the formatting, you use the same procedure you use for formatting any other type of cell.

1. Right-click on the page number.
2. Click **Format Cell** from the menu.
   
The Cell Format dialog box opens.
3. Change the formatting as required and then click **OK** to close the dialog box.

**Example:** How do I know when the data in my report was last updated?

In many companies, it is essential to know the exact date or time the report data is updated. In Desktop Intelligence, you can display the last refresh date in a special field. The date automatically updates each time you refresh your report.
Setting Up Report Layout

Using page numbers, times and dates

To do this:
1. Add a caption cell at the top of your report and enter “Last refreshed”, for example.
2. From the Insert menu, click Special Field, then Date and Time, then Last Refresh Date.
   - The cursor changes to the Insert Cell cursor.
3. Click once next to the Last Refreshed caption.

![Daily Sales Report][1]

The date on which the report was last updated is inserted in the report. This date is updated each time you refresh the report.

Changing how the date and time displays

When you click Date and Time from the Insert menu, the date is inserted by default. To re-format the cell to display the time or to reformat the display:
1. Right-click the cell and click Format Cell from the menu.
2. Click the Numbers tab on the Cell Format dialog box.
3. Click Date and Time in the Category list.
   - The display options are shown in the Formats box.
4. Click a format in the Formats box.
   - An example of how the date or time will appear is shown in the Properties box.

**Tip:** If you see a cell that displays ####, it means that the text is too long to be fully displayed in the current cell size. To fix the problem, double-click the cell border to re-size it and correctly display the text.

Inserting the date and time

If you want to insert both the date and time, insert two cells using the Insert/Special Field/Date and Time command and re-format one to display the time.
Inserting document information

For tracking purposes, you may want to display information about the query you used to retrieve the data in the report, the filters you placed on the report and the drill filters you used in drill mode. You can do this automatically by using the Insert Special Field option. The following options are available:

<table>
<thead>
<tr>
<th>Click Insert Special Field</th>
<th>To display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query prompt</td>
<td>the option you chose from the prompt dialog box when you ran the query. If you only chose to retrieve the sales figures for Northern Europe in FY95 for example, Northern Europe FY95 is inserted in the cell.</td>
</tr>
<tr>
<td>Global Filters</td>
<td>the name of the filters you have applied to the whole report. These are the filters placed in the Global folder in the Filters dialog box.</td>
</tr>
<tr>
<td>Drill Filters</td>
<td>the name of the filters currently displayed in the drill toolbar.</td>
</tr>
</tbody>
</table>

**Example:** Inserting a query prompt in a report

In this example, the query prompts you to choose which data you want to retrieve from the database. You choose the name of the sales representative and the year. You want to insert this information into your report to keep track of the data you retrieve. Here’s how to do it:

1. From the **Insert** menu, click **Special Field** and then **Query Prompt**.
   The List of prompts box opens if there is more than one choice.

2. Click the prompt **Which Sales rep?** and click **OK**.
3. Click once where you want the query prompt to display.

The name of the sales representative displays in a new cell.

4. Repeat Step 1 to Step 3 to insert the year you chose when you ran the query.

The name of the sales representative, Galagers, and the year displays in your report.

<table>
<thead>
<tr>
<th>Country</th>
<th>Sales Person</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>France</td>
<td>Galagers</td>
<td>77,505</td>
</tr>
<tr>
<td>US</td>
<td>Galagers</td>
<td>105,366</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td>263,871</td>
</tr>
</tbody>
</table>

This information updates if you run the query again and select different prompt choices.

Your data results may be different with the updated universe.

Using outline view

A convenient way to present reports that contain many sections and a lot of information, is to use outline view. Outline view allows you to fold up the sections in the report to display only the high level information that appear at the top of each section. People who view your reports can display the sections they are interested in to get more details. See also, "Outline view" on page 29.

To activate outline view:

* From the View menu, click Outline.

A bar with arrows displays at the left side of the report window.
The number of buttons appearing at the bottom of the outline bar depends on the number of sections you have in the report. In the report illustrated below, there is a main section and a City section.

If you click S, the main section is folded to display only the title and logo. If you click the 1, all section 1 City sections are folded to display only the section title, the name of the city and the section totals.

To view a report in outline view:
1. Click the Report Manager Map tab.
Setting Up Report Layout

Using outline view

This gives you a list of the sections in the report.

2. Click the section you want to view in the Report Manager Map list.
   The high level information for this section displays in the Report window.

3. Click the arrow next to the section name in the Outline bar.
   The selected section opens up and you can view the details for that section.
Formatting Report Components
Chapter 7

Formatting Page Layout
Overview

This chapter describes how to lay out the different report components on a page to obtain a clear, professional look to your reports. You learn how to:

- position blocks (tables, crosstabs and charts) and cells relative to one another
- align blocks with one another
- set conditions to hide and display blocks so that you can have different page layouts on different pages
- use page backgrounds

Positioning report components

This section describes how to position and align the different components that make up your report.

Relative positioning

Relative positioning means positioning a selected block in relation to markers such as page margins or other blocks. If these markers change in size or position the block is re-positioned accordingly. The example below demonstrates why relative positioning is important.
**Example:** Why is relative positioning important?

You have a table and a chart positioned on a report page. The table is five lines long. You refresh your report to update it with new data and your table is now 10 lines long. If you do not set the position of the chart in relation to the actual position of the table, the new table will overlap the chart as shown in the first illustration below.

If you set the position of the chart in relation to the actual position of the table, the chart is always under the table with the space that has been set.

Using relative positioning is particularly important if you are setting conditions to determine whether a table or chart, for example, is displayed or not. If you do not position components in relation to one another you could end up with overlapping components or with big gaps between them.

**To position a block in relation to another report component**

1. Right-click on the block or cell and click **Format Chart** or **Format Table** from the menu.

The Format dialog box opens.
2. Click the **Appearance** tab:

3. In the **Horizontal Position Relative to** box, click the marker you want to use to position the block or cell horizontally.

4. Enter a number (positive or negative) in the **Left** field to set how much space you want to have between the marker and the selected block.

5. In the **Vertical Position Relative to** box, click the marker you want to use to position the block or cell vertically.

**Note:** When you select **Top Margin** under Vertical Position Relative to, the table is displayed according to the top margin, but there is a empty area between the end of the block and the bottom margin on the first page. The blank corresponds with the title area.
6. Enter a value (positive or negative) in the Top field to set how much space you want to have between the marker and the selected block. The Sample box demonstrates the way the components are positioned.

![Sample diagram showing positioning of components]

7. Click **Apply** or **OK** to display the cells or blocks in their new position.

**Note:** When a report contains only the main section, the Upper section is the top margin of the page. When a report contains sections, the Upper Section is the top of the section in which a block is currently positioned.

### Aligning blocks and cells

You can align report components with one other in the following ways using the Alignment toolbar:

- a. Aligns the left edges
- b. Centers horizontally
- c. Aligns the right edges
- d. Aligns the top edges
- e. Centers vertically
- f. Aligns the bottom edges
- g. Snap to Grid - Forces components to stick to gridlines

1. Display the Alignment toolbar.
2. Select the first component.
   
   For example, if you want to align a cell with a table, you must first select the table.
3. Press Ctrl + click the component you want to align with the first.
4. Click one of the alignment options, then click **OK**.
   
   The selected report components align.
Displaying delimiters

When you are working on your page layout and aligning components, it may be useful to turn on the delimiters. Delimiters are non-printing dotted lines. There are three types of delimiters that you can turn on and off:

<table>
<thead>
<tr>
<th>This delimiter</th>
<th>Shows</th>
</tr>
</thead>
<tbody>
<tr>
<td>cell</td>
<td>the outline of a cell</td>
</tr>
<tr>
<td>margin</td>
<td>the size of page margins; you can only turn margin delimiters on if you are in Page Layout view</td>
</tr>
<tr>
<td>section</td>
<td>where a section begins and ends</td>
</tr>
</tbody>
</table>

To turn cell and section delimiters on:

- From the View menu, click Cell Delimiters or Section Delimiters.

To turn margin delimiters on:

1. From the View menu, click Page Layout.
2. To display the margins, click Page Margins from the View menu.

Manually positioning components using the grid

You can manually drag report components and place them as required on the report page. To help place components accurately you can turn on a page grid.

To display the grid:

- From the View menu, click Grid.

You can use the grid to automatically align the selection as you drag it. To do this:

- Click Snap to Grid on the Alignment toolbar

When you drop a component in a new location, it automatically aligns with the nearest line on the grid.
Note: Displaying the grid can slow down the document display considerably. The speed depends on how small the grid increments are, the zoom display size and the speed of your machine.

To position a component:
1. Select the block(s) or cell(s) you want to position.
2. Hold the cursor over the hatched border of the block.
3. When the cursor changes to the Move arrow, click your mouse and drag.
4. Click inside the cell, click and hold the mouse then drag.
5. Release the mouse when you reach the new position for the block or cell.

Note: In master/detail reports, you can drag a block between sections. When you do this, the data in the block is re-calculated. You can also move blocks between sections using the Report Manager.

Using Report Manager to structure report layout

You can use the Map tab of the Report Manager to work on the structure, layout and formatting of your report. In particular, the Map tab in structure view allows you to manage reports which contain hidden cells, sections and blocks.

To display Report Manager in structure view
1. In the Standard toolbar, click the Report Manager.
2. Click the Map tab.
3. Click the Structure option button.
Formatting Page Layout

Using Report Manager to structure report layout

The Map tab displays:
- a list of all the components in the report represented by an icon
- all the components in the order that they appear in the report
- the report name, and its components including:
  - Main Section
  - Main Section Header
  - sub sections and their cells, charts, crosstabs and tables
  - Main Section Footer

Click an icon in the Report Manager window to display the corresponding component in the report window.

Organizing the report in Report Manager

You can use the Report Manager to organize the tables, cells and charts in your report.

Copying report components

You can copy and paste a component from one section of your report to another. When you paste a component in a new location, the original formatting is retained. For example, if you copy a pie chart from one part of your report to another in the Map window, the chart will retain all the colors, legends, title and other formatting. To do this:

1. Right-click the icon of the component you want to copy.
2. Click **Copy** from the menu.
3. Right-click again and click **Paste** from the menu.
This is a quick and easy way to copy a component and then work on it in the report window.

**Moving report components**

You can also drag a component from a position in the list and drop it in the new position. To do this:

1. Click on the icon of the component you want to move.
2. Click on the icon again and, click the mouse, drag the icon to the new position in the list.
3. Release your mouse.

   The icon displays in the new position in the list and the component displays in the new position in the report window.

**Formatting components in Report Manager**

You can format the components in your report from the Report Manager Map tab. You can format tables, crosstabs, charts, cells and sections as well as work on the format of filters, sorts and breaks.

To do this:

* Right-click on the component icon in the Map list and select the relevant option from the menu.

**Naming components in Report Manager**

You name tables, crosstabs, cells and charts. These names appear in the Report Manager Map list in structure mode. Naming components makes it easier for you and others to find your way to the different parts of the report. With one click, you can go directly to the part of the report that interests you. More importantly, however, naming components is a good idea if you are hiding report components on certain pages. To do this:

1. Click **Structure** from the **View** menu.
2. From the Report Manager Map tab, click once on a component name and then click again.
   
   The name highlights.
3. Enter the new name.
4. Press **Enter** or, click outside of the text box.

**Tip:** You can also name components in the Format Block dialog boxes on the General tab or on the Appearance tab.
Hiding and displaying report components

Desktop Intelligence allows you to create and format report components (tables, crosstabs, charts, cells and sections) and then select which components you want to display on a given page or in a given set of circumstances. This is called conditional formatting.

Conditional formatting allows you to set up reports that display different information and different formatting on different pages.

For example, you can
- use a different table format for customer payment records depending on whether the customer is up-to-date on payments
- create a different page layout for your odd and even pages.

You can hide and display report components in two ways:
- click a check box to temporarily hide a report component
- set up a condition to determine when the report component is hidden or displayed

This section describes how to hide and display report components using both methods and provides a number of illustrated examples.

Showing and hiding report components

You can temporarily hide a report component from the report page.

Tip: This may be useful if you want to hide a cell containing a comment before you print out a report.

To hide a report component:
1. Right-click on the report component.
2. Click Format (Cell, Section, Table, Crosstab, Chart) depending on the type of report component from the menu.
   The Format dialog box appears.
3. The next step depends on the type of component you want to hide:
   - if you selected a section, click the General tab
• if you selected a table, crosstab, cell or chart, click the Appearance tab

4. Click the Hide box and click OK.

The component disappears from the report page and the component name displays in italics in the Map list.

The comment cell is in italics to indicate that it is currently hidden.
Hiding and displaying report components

To display the report component
Since the report component is no longer displayed on the report page, you use the list in the Report Manager Map tab to display the component again. To do this:

1. Right-click on the component name in the Report Manager window.
2. Click Format (Cell, Section, Table, Crosstab, Chart, depending on the type of report component) from the menu.
3. Click the Appearance or General tab.
4. Clear the Hide box and click OK.

Setting a condition to hide a component
You can also use the Desktop Intelligence Formula Editor to set a condition to hide or display a report component. To do this:

1. Right-click on the report component.
2. Click Format (Cell, Section, Table, Crosstab, Chart, depending on the type of report component) from the menu.
   The Format dialog appears.
3. The next step depends on the type of component you want to hide:
   • if you selected a section, click the General tab
   • if you selected a table, crosstab, cell or chart, click the Appearance tab.
4. Click the Hide check box.
5. You can then:
   • click Edit Formula to open the Formula Editor to write your formula.
   or
   • type in your formula directly in the formula box.
6. Click **OK** to apply the condition.

   All components that satisfy the condition are hidden. The component name displays in italics in the Map list in the Report Manager window.

**Note:** For details on the syntax to use for writing formulas see *Desktop Intelligence User's Guide: Accessing Data and Data Analysis*, Chapter 17 Formulas, Local Variables, and Functions.

**Example:** Displaying different table formats for European and US currencies

You produce a weekly report of the sales revenue generated per product line per city in the eFashion retail group. The report contains a section for each city and a variable, called Currency Region, that groups your cities into Europe and US. You want to produce a report to display sales revenue in US dollars and in euros for your three European cities, and sales revenue in US dollars only for your US cities.
To do this, you create two different table formats as shown below:

<table>
<thead>
<tr>
<th>Brussels</th>
<th>Austin</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>Sales revenue</td>
</tr>
<tr>
<td>City Shirts</td>
<td>US dollars</td>
</tr>
<tr>
<td>City Trousers</td>
<td>$705.40</td>
</tr>
<tr>
<td>Dresses</td>
<td>$1,189.20</td>
</tr>
<tr>
<td>Jackets</td>
<td>$696.00</td>
</tr>
<tr>
<td>Leather</td>
<td>$1,773.10</td>
</tr>
<tr>
<td>Overcoats</td>
<td>$1,814.00</td>
</tr>
<tr>
<td>Shirt Waist</td>
<td>$671.70</td>
</tr>
<tr>
<td>Sweaters</td>
<td>$4,877.10</td>
</tr>
<tr>
<td>Sweat T-Shirts</td>
<td>$64,971.20</td>
</tr>
<tr>
<td>Trousers</td>
<td>$106.50</td>
</tr>
<tr>
<td>Total</td>
<td>$167,710.70</td>
</tr>
</tbody>
</table>

One table, named Dollars, has sales revenue in US dollars only. You set a condition to hide this table for all cities in Europe. The syntax is:

=\<\text{Currency region}\>\text{InList(}"\text{Europe})\>
The other table, named euros, displays sales revenue in US dollars and in euros. You set a condition to hide this table for all US cities. The syntax is:

\[ \text{Currency region} \text{InList("US")}. \]

It's important to position both tables in relation to the left edge of the report page when you set up two table formats with conditions that specify to hide one or the other. When one table is hidden, the other will be re-positioned accordingly. For more details on relative positioning, see "Relative positioning" on page 144.

**Example:** Setting up a different page layout for odd and even pages

You are setting up a report that will be printed and bound so you need a different layout for the odd and even pages. The layout will:

- display odd page numbers in the top right-hand corner of the page and the document name in the page footer
- display even page numbers in the top left-hand corner of the page.

Here's how to do it:

**Layout for odd numbered pages**

You are going to place the page numbers in the page header area and the document title in the page footer area.

1. Click **Page Layout** from the **View** menu.
2. Display the first page of your document on screen.
3. Add a special field containing the page number in the right-hand side of the page header area.

4. Right-click on the page number cell and click **Format Cell** from the menu. The Format Cell dialog box is displayed.

5. Click the **Appearance** tab.

6. Click the **Hide Cell** check box and type the following formula in the **Hide Cell** text box.

   ```plaintext
   =Even(Page())
   ```

   **Tip:** Use the formula `=Even(Page())` to hide all components on even pages in your report.

7. Click **OK** to close the Cell Format dialog box.

Follow this same procedure to:
- add the document title to the page footer
- set a condition to hide it on even-numbered pages
Layout for even numbered pages
To set up the even numbered pages:

1. Add a special field containing the page number in the left-hand side of the page header area.

2. Right-click the page number cell and click Format Cell from the menu. The Format Cell dialog box appears.

3. Click the Appearance tab.

4. Click the Hide Cell check box and type the following formula in the Hide Cell text box.

   \[=\text{Odd(Page())}\]

   Tip: Use the formula \[=\text{Odd(Page())}\] to hide all components that you do not want to be shown on odd pages in your report.

5. Click OK to close the Cell Format dialog box.

   This cell is hidden on all odd-numbered pages.

Note: Odd page numbers appear at the top right-hand side of the odd pages only and the even page numbers appear at the top left-hand side of the page. The document title appears on the odd pages only.

Hiding an empty section in a report
When you create or refresh a master/detail report, empty sections may appear, as shown in the example below:

<table>
<thead>
<tr>
<th>Resort</th>
<th>Year</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td></td>
<td></td>
</tr>
<tr>
<td>US</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The year section contains an empty master cell.

There is no data for revenue in Australia and the US for the unidentified year.

This may happen for two reasons:

* the section master cell is empty because you have data in the data provider that has not been organized into one of the section values. Desktop Intelligence designates sections with no value in the master cell as #EMPTY.
you have a section that contains no data because there is no data currently available for that section. You can set a condition to hide these empty sections in a report. You can hide the master cell only, the section only or both master cell and section.

To do this:

1. Click on the Report Manager Map tab and click Navigation view.
2. In the Report Manager list, right-click the empty master cell or the empty section and click Format Section from the menu. The Section Format dialog box opens.
3. Click the General tab.
4. Click the Hide Section Header check box.
5. Type the following formula in the formula box:
   
   =IsNull(<variable>)

   where <variable> is the variable for which you have no data.
6. To hide the empty year master cell in the example above, the formula is:
   
   =IsNull(<Year>)
7. Click OK.

   The empty cell or section is hidden on the report page and displayed in italics in the Report Manager list in the Map tab.

Working with the page background

You can enhance the look of a report by inserting a page background. A page background is a picture display behind the report data.

To insert a page background

You can insert an existing picture as a page background, or use a graphics application to create a new picture:

2. Click the tab of the report in which you want to insert the page background.
3. From the Format menu, click Page and then Background.
The Page Background dialog box appears:

4. Click **New**.
   The Insert Object dialog box appears.
5. Click **Create from File**.
6. Type in the path of the file you want to insert in the File text box or click **Browse** to locate the file.
7. Click the **Link** check box if you want to link the file.
   If you clear this check box, the image is embedded in the report.
8. Click **OK** to close the Insert Object dialog box.
9. Click a **Display** option in the Page Background dialog box, then click **OK**.
   • **Center** displays the background in the center of the page.
   • **Tile** displays the background as multiple tiles.

**Tip:** You can also copy a picture to the clipboard, then click Paste in the Page Background dialog box.

**To edit the current page background**

You can edit a page background in the graphics application in which it was created.
1. Click **Page Layout** from the **View** menu to go to the page layout.
2. From the **Format** menu, click **Page** and then **Background**.
   The Page Background dialog box appears.
3. Click **Edit**.
   The native graphics application associated with the file type launches and the current page background appears.
4. Make your changes to the page background.
5. Exit the graphics application.
6. In the Page Background dialog box, change the Display option:
   • Center displays the background in the center of the page.
   • Tile displays the background as multiple tiles.
7. Click OK.
   The edited page background appears in the report.

To remove the current page background.
1. Click Page Layout from the View menu to go to the page layout.
2. From the Format menu, click Page and then Background.
   The Page Background dialog box appears.
3. Click Remove, then click OK.
   The Page Background dialog box closes, and the page background no longer appears in the report.
Overview

Desktop Intelligence displays data in a report in three basic ways.

- tables
- charts
- free-standing cells

This chapter describes:

- the different types of tables, including crosstabs, that you can use in Desktop Intelligence
- how to create tables and how to organize the way your data is displayed in them
- how to insert and display data in free-standing cells

For information on:

- displaying your data in charts, see “Creating a chart” on page 238 of this guide
- formatting tables and cells, that is working with colors, font and number styles, see Chapter 10: Formatting Sections, Tables, and Cells
- breaking up the data in tables to display calculations, see Chapter 9: Breaking Up Tables

What types of tables?

Desktop Intelligence has three types of tables. Two basic table types display data in a list and in crosstabs, which are a special kind of table that allow you to summarize data. The different table types are described below.

Tables

Desktop Intelligence tables display data in either rows or in columns and contain a header and a footer.

- the header displays information about the row or column; for example, a label or the name of the variable
- the footer displays calculations on the values that appear in the columns or rows
Displaying Data in Tables

What types of tables?

You can display the variable labels along the top row of the table so that you read the data down the columns as shown below:

<table>
<thead>
<tr>
<th>City</th>
<th>Year</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chicago</td>
<td>1996</td>
<td>$737,514</td>
</tr>
<tr>
<td>Chicago</td>
<td>2000</td>
<td>$1,180,569</td>
</tr>
<tr>
<td>Chicago</td>
<td>2001</td>
<td>$1,134,005</td>
</tr>
<tr>
<td>Houston</td>
<td>1999</td>
<td>$1,211,300</td>
</tr>
<tr>
<td>Houston</td>
<td>2000</td>
<td>$1,393,443</td>
</tr>
<tr>
<td>Houston</td>
<td>2001</td>
<td>$2,245,190</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>1996</td>
<td>$932,637</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>2000</td>
<td>$1,531,516</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>2001</td>
<td>$1,958,676</td>
</tr>
<tr>
<td>New York</td>
<td>1999</td>
<td>$1,667,686</td>
</tr>
<tr>
<td>New York</td>
<td>2000</td>
<td>$2,763,503</td>
</tr>
<tr>
<td>New York</td>
<td>2001</td>
<td>$5,151,022</td>
</tr>
<tr>
<td>Same</td>
<td></td>
<td>$20,273,065</td>
</tr>
</tbody>
</table>

The names of the variables display at the top of the table

The values appear underneath the column headings

Calculation totals display in the table footer

You can also display the variable labels along the left edge of the table so that you read the data across the rows as shown below. This table format is typically used in financial reports such as balance sheets.

<table>
<thead>
<tr>
<th>City</th>
<th>Sales revenue</th>
<th>Quantity sold</th>
<th>Margin</th>
<th>Margin as % revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Chicago</td>
<td>Houston</td>
<td>Los Angeles</td>
<td>New York</td>
</tr>
<tr>
<td>$3,022,559</td>
<td>$5,440,967</td>
<td>$4,230,829</td>
<td>$7,900,221</td>
<td>$20,273,065</td>
</tr>
<tr>
<td>17,978</td>
<td>32,804</td>
<td>26,244</td>
<td>44,959</td>
<td>123,482</td>
</tr>
<tr>
<td>$1,264,003</td>
<td>$2,221,008</td>
<td>$1,688,395</td>
<td>$3,072,744</td>
<td>$8,217,138</td>
</tr>
<tr>
<td>41.49 %</td>
<td>40.76 %</td>
<td>39.53 %</td>
<td>40.53 %</td>
<td></td>
</tr>
</tbody>
</table>

The names of the variables display down the left edge of the table

The values are listed along the rows after the row headings

Calculation totals display in the table footer

Crosstab tables

A crosstab is a particular kind of table where data appears in columns and in rows. Corresponding data appears at the intersection of the columns and rows; this part of the crosstab is called the body. The body typically displays numerical data.

A crosstab can display both row totals and column totals as well as a grand total.

You need at least three variables to display data in a crosstab including one measure. The measure is placed in the body of the crosstab.
Creating tables

This section covers inserting tables in reports that already contain data; that is, the variables appear in the Report Manager. There are several ways to insert a new table in a report. You can:

- Drag and drop variables from the Report Manager list to a blank space in the report. The data displays in a table. You can then add other columns as required, rotate the table, move it, turn it into a crosstab and rename the data labels.
- Use the Insert Table or Insert Crosstab wizards.
- Copy an existing table and then replace the variables and delete or add columns and rows as required.

To bring new data into your report, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 1 “Introduction to Accessing Data with Desktop Intelligence”.

The crosstab illustrated below displays sales revenue per year for the top three selling product lines.

<table>
<thead>
<tr>
<th>Year</th>
<th>1999</th>
<th>2000</th>
<th>2001</th>
<th>Sum</th>
</tr>
</thead>
<tbody>
<tr>
<td>T-Shirt</td>
<td>$600,454</td>
<td>$737,635</td>
<td>$1,910,247</td>
<td>$3,338,334</td>
</tr>
<tr>
<td>Accessories</td>
<td>$798,303</td>
<td>$1,688,991</td>
<td>$322,589</td>
<td>$3,009,884</td>
</tr>
<tr>
<td>Shirt</td>
<td>$580,956</td>
<td>$404,684</td>
<td>$445,701</td>
<td>$1,431,341</td>
</tr>
<tr>
<td>Sum</td>
<td>$1,772,711</td>
<td>$2,531,295</td>
<td>$2,856,618</td>
<td>$7,160,624</td>
</tr>
</tbody>
</table>

The Year variable is displayed in the top row. This is the Down Edge of the crosstab.

The Line variable is displayed in the left column. This is the Across Edge of the crosstab.

The Sales Revenue variable appears in the body.

Row and column totals display in the two footers with a grand total in the bottom right-hand cell.

The same crosstab in Structure View shows the placement of the variables in the crosstab.
Inserting a table from Report Manager

A quick and convenient method to insert a table is to drag and drop the variables you want to use from the Report Manager into your report. Here's how to do it:

1. Click **Report Manager** on the **Standard** toolbar, to open the Report Manager window.
2. Click the **Data** tab of the Report Manager.
   The data you can use in your report displays under the Variables folder.
3. Select the variables you want to use in your table in the Report Manager.
   - Use Ctrl to select more than one variable.
4. Click the mouse and drag the variables to the report from the Report Manager.
   The cursor changes to the Create Table cursor and the status bar displays the message *Drop to create a table.*
5. Release the mouse to drop the variables and create a table to display the data.
Displaying Data in Tables

Creating tables

Rotating tables

You can change the orientation of your table to list data in rows instead of columns or the other way round. To do this:

1. Select the table.
2. In the Report toolbar, click Rotate Table.

The table rotates, as shown below.

<table>
<thead>
<tr>
<th>Year</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>$6,000,014</td>
</tr>
<tr>
<td>2000</td>
<td>$13,232,246</td>
</tr>
<tr>
<td>2001</td>
<td>$15,000,143</td>
</tr>
</tbody>
</table>

Re-organizing data in tables

Once you insert a table you can re-organize and delete its columns and rows and add more data to achieve the layout that best represents your data. All table formatting can be accomplished by using your mouse. You do not need to go through dialog boxes or menus.

Swapping two columns or two rows

To swap two columns or two rows:

1. Click any cell in the row or column, other than the header cell.
2. Click on the same row or column again, click the mouse + drag over the second column or row.

The cursor changes to the swap cursor and the status bar reads *Drop to swap contents*.
3. Release the mouse.

The two columns or rows change position in the table.
Displaying Data in Tables

Creating tables

Moving columns and rows

To move a column or row to a different position in the table.

1. Click any cell in the row or column, other than the header cell.
2. Click on the same row or column again.
3. Click the mouse and drag your cursor to where you want to place the row or column.

The cursor changes to the move cursor and the status bar reads Drop to move contents.
4. Release the mouse.

The row or column moves to the new position.

<table>
<thead>
<tr>
<th>Year</th>
<th>Margin</th>
<th>Quantity sold</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>$3,731,971</td>
<td>53,075</td>
<td>$8,035,814</td>
</tr>
<tr>
<td>2000</td>
<td>$5,187,688</td>
<td>79,885</td>
<td>$13,232,246</td>
</tr>
<tr>
<td>2001</td>
<td>$6,587,004</td>
<td>90,296</td>
<td>$15,059,143</td>
</tr>
</tbody>
</table>

Copying columns and rows

To copy a column or row:

1. Click any cell in the row or column, other than the header cell.
2. Click on the same row or column again and, click the mouse + drag your cursor to where you want to place the row or column.
3. Press the Ctrl key on the keyboard.

The cursor changes to the copy cursor and the status bar reads Drop to copy contents.
4. Continue to press Ctrl and release the mouse.

The row or column copies to the new position.

<table>
<thead>
<tr>
<th>Year</th>
<th>Quantity sold</th>
<th>Margin</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>53,075</td>
<td>$3,731,971</td>
<td>$8,035,814</td>
</tr>
<tr>
<td>2000</td>
<td>79,885</td>
<td>$5,187,688</td>
<td>$13,232,246</td>
</tr>
<tr>
<td>2001</td>
<td>90,296</td>
<td>$6,587,004</td>
<td>$15,059,143</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Year</th>
<th>Margin</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>1999</td>
<td>$8,035,814</td>
</tr>
<tr>
<td>2000</td>
<td>2000</td>
<td>$13,232,246</td>
</tr>
<tr>
<td>2001</td>
<td>2001</td>
<td>$15,059,143</td>
</tr>
</tbody>
</table>
Displaying Data in Tables

Creating tables

Keeping source formatting

When you swap, move or copy rows and columns you may only want to move the data and not the particular formatting. You can also copy the formatting along with the values. In the example below, the values in the Year column appear in a larger font size than the other columns.

To keep this formatting on the Year column when you move it to a different position in the table:

- Press Alt as you drop the column or row into its new position.

Adding more data to a table

You can add more data to your table by dragging variables from the Report Manager and inserting new columns or rows in your table.

To insert a row or column in a table:

1. In the Report Manager, click on the variable you want to add to your table.
2. While you click the mouse, drag the cursor to the edge of the column or row you want to add.
3. When the edge of the column or row highlights with a gray hatched border and the status bar displays the message Drop to insert, release the mouse.

A new column or row is added to the table to display the new data.

Tip: You can add more than one variable at a time. Use Ctrl or Shift to select more than one variable from the list in the Report Manager.
Replacing data in a table

You can replace the data in a column or a row by dragging a different variable from the Report Manager window and dropping it onto the table.

1. In the Report Manager, click on the variable you want to add to your table.
2. Click the mouse and drag the cursor over the column or row of data you want to replace.
3. Release the mouse when the column or row is highlighted with a gray hatched border and the status bar displays the message Drop to replace contents.

New data replaces the data in the column or row.

Removing data from a table

You can remove a row or column of data from a table by dragging it back into the Report Manager window. To do this:

1. Click any cell in the row or column, other than the header cell.
2. Click the same row or column again.
3. Click the mouse and drag the cursor into the Report Manager window.
Displaying Data in Tables

Creating tables

4. Release the mouse.
   The column or row of data disappears from the table.

Inserting a crosstab

You can create a crosstab by dragging variables from the Report Manager to the report to create a table and then re-organize the table into a crosstab. To create a crosstab, you need at least two dimensions/details and one measure object.

Turn a table into a crosstab as shown below:

<table>
<thead>
<tr>
<th>Year</th>
<th>Line</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>Sweat T-Shirts</td>
<td>$200,454</td>
</tr>
<tr>
<td>2002</td>
<td>Sweat T-Shirts</td>
<td>$437,839</td>
</tr>
<tr>
<td>2001</td>
<td>Sweat T-Shirts</td>
<td>$1,240,247</td>
</tr>
<tr>
<td>1999</td>
<td>Accessories</td>
<td>$755,263</td>
</tr>
<tr>
<td>2003</td>
<td>Accessories</td>
<td>$1,035,961</td>
</tr>
<tr>
<td>2001</td>
<td>Accessories</td>
<td>$632,909</td>
</tr>
<tr>
<td>2002</td>
<td>Shirt Waist</td>
<td>$395,946</td>
</tr>
<tr>
<td>2003</td>
<td>Shirt Waist</td>
<td>$413,964</td>
</tr>
<tr>
<td>2004</td>
<td>Shirt Waist</td>
<td>$446,761</td>
</tr>
</tbody>
</table>

1. Either select a column and drag it to the upper right corner of the table or, Drag a variable from the Report Manager window to the upper right corner of the table.
2. When the cursor changes to the Turn to Crosstab cursor and the status bar displays the message Drop to turn to crosstab, release the mouse. The table becomes a crosstab.
Displaying Data in Tables

Creating tables

Re-organizing crosstabs

You can re-organize a crosstab by swapping or replacing the variables in the headers or by replacing the variable displayed in the body. The example below shows how to swap two headers:

1. Click in the Year header.
2. Click the Year header again.
3. Click and drag the cursor over the Resort header. The Resort header highlights, the cursor changes to the swap cursor and the status bar reads Drop to swap.
4. Release the mouse. The headers display in the new positions.

Turning a crosstab to a table

You can rearrange the columns and rows in a crosstab into a table. To do this:

1. Click inside the header row of the crosstab.
2. Click in the same row again and hold the mouse, then drag the cursor towards the left border of the crosstab.
3. When a horizontal line appears above the cursor, release the mouse.

Tips on dragging and dropping data

- Carefully select the data you want to move.
- Watch how the cursor changes shape as it moves over different parts of the table and how the highlighting on the table changes. This gives you an indication of what will happen when you release the mouse.
Displaying Data in Tables

Guided table insertion

- Watch the status bar messages for instructions on what keyboard shortcuts you can use and for indications on what happens when you release the mouse.

- In the Standard toolbar, click Undo or Ctrl+Z to undo up to ten actions.

Guided table insertion

You can also insert tables and crosstabs using the New Table Wizard or the New Crosstab Wizard that guide you through the steps to insert a new table or crosstab in your report.

The following procedure describes how to insert a table or crosstab in a report, using existing data from the document. If you want to insert a table or crosstab using new data see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 1 “Introduction to Accessing Data with Desktop Intelligence.

1. Click inside a blank space in the report.

2. Click Insert Table or the Insert Crosstab on the Report toolbar.

   The cursor changes to the insert cursor.

   a. Insert table icon
   b. Insert crosstab icon
   c. Insert table cursor
   d. Insert crosstab cursor

3. Click the position in the report where you want the top left-hand corner of the table or crosstab.
The New Table Wizard opens.

Click the first option, **Use existing data from the document**, then click **Begin**.

**Note:** The choices when you insert a new table or new crosstab are:

<table>
<thead>
<tr>
<th>New Table Wizard Option</th>
<th>Allows you to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use existing data from the document</td>
<td>Choose the variables that appear in the current document for your table</td>
</tr>
<tr>
<td>Build a new query on the universe currently in use</td>
<td>Choose the variables that appear in the current universe for your table</td>
</tr>
<tr>
<td>Access new data in a different way</td>
<td>Access other data sources such as corporate data, universes, or personal files.</td>
</tr>
<tr>
<td>Use an existing query to build a new one</td>
<td>Select an existing query from your report and build a new one. The table is independent of your first query. You can modify it without modifying the query on which it is based.</td>
</tr>
</tbody>
</table>

For more information on the choices described in the table above, see *Desktop Intelligence User's Guide: Accessing Data and Data Analysis*, Chapter 6, “Combining Data from Different Sources” and Chapter 12, “Customizing Queries on Universes”.
4. Select the variables for the table or crosstab.

To select multiple variables, Press Ctrl + the variables.

The next screen shows the selected variables in three folders.

- Columns displays in the header down the left edge of the crosstab.
- Rows displays the header in the top row of the crosstab.

If you are inserting a

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Table</td>
<td>Finish. The table appears in the report.</td>
</tr>
<tr>
<td>Crosstab</td>
<td>Next, then continue the procedure below.</td>
</tr>
</tbody>
</table>
Displaying Data in Tables

Editing tables

Selecting tables, rows and cells

Selecting a table

1. Click a blank space outside the table if it is already selected.
Displaying Data in Tables

Editing tables

2. Press Alt + click once inside the table.
   A hatched gray border appears around the table:

   ![Table Example]

   - Year
   - Lines
   - Sales Revenue
   - 1999
     - Sweat-T-Shirts
     - $989,454
   - 2000
     - Sweat-T-Shirts
     - $737,638
   - 2001
     - Sweat-T-Shirts
     - $1,910,247
   - 1999
     - Accessories
     - $701,263
   - 2000
     - Accessories
     - $1,695,991
   - 2001
     - Accessories
     - $900,503
   - 1999
     - Shirt Waist
     - $305,922
   - 2000
     - Shirt Waist
     - $404,654
   - 2001
     - Shirt Waist
     - $449,721

   Hatched gray border that appears when the table is selected.

To select two or more tables

1. Click a blank space in the report.
2. Drag the mouse until you have covered part of the blocks you want to select.

   ![Selected Tables Example]

   - Year
   - Sales Revenue
   - 1999
     - Accessories
     - $3,089,844
   - City Shirts
     - $104,438
   - City Trousers
     - $86,917
   - Dresses
     - $800,923
   - Jackets
     - $190,127
   - Leather
     - $36,579
   - Overwear
     - $309,117
   - Overcoats
     - $142,777
   - Shirt Waist
     - $1,109,402
   - Sneakers
     - $385,977
   - Sweat-T-Shirts
     - $2,086,946
   - Trousers
     - $361,908

3. Release the mouse.
   A hatched gray border appears around each block.

Selecting columns and rows

To select one column or one row:

1. Place the cursor at the top of the column or at the left-hand side of the row
2. When the cursor changes to a black arrow, pointing downwards for a column or to the right for a row, click once.

3. The column or row appears as below:

<table>
<thead>
<tr>
<th>Accessories</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>City Skirts</td>
<td>$104,430</td>
</tr>
<tr>
<td>City Trouser</td>
<td>$96,617</td>
</tr>
<tr>
<td>Dresses</td>
<td>$80,536</td>
</tr>
<tr>
<td>Jackets</td>
<td>$190,127</td>
</tr>
<tr>
<td>Leather</td>
<td>$85,572</td>
</tr>
<tr>
<td>Overcoats</td>
<td>$142,777</td>
</tr>
<tr>
<td>Shirt Waist</td>
<td>$61,390,400</td>
</tr>
<tr>
<td>Sweaters</td>
<td>$975,977</td>
</tr>
<tr>
<td>Sweat-T-Shirts</td>
<td>$3,338,340</td>
</tr>
<tr>
<td>Trousers</td>
<td>$261,166</td>
</tr>
</tbody>
</table>

The column or row is highlighted, to show that it is selected.

You can also select a column or a row simply by clicking inside it. This method does not select the column or row header, which is the cell that contains the name of the variable.

Selecting adjacent columns or adjacent rows

To select adjacent columns or rows:
1. Select one column or row.
2. Press Shift, then click the adjacent column(s) or row(s).

Selecting columns or rows that are not adjacent

To select columns or rows that are not adjacent:
1. Select the first column or row.
Displaying Data in Tables

Editing tables

2. Press Ctrl, then click the other column(s) or row(s) you want to select.
   **Note:** You can select one or more columns at a time, or one or more rows at a time, but you cannot select a combination of columns and rows.

To select a cell in a table
   • To select a cell, click inside it.
     The cell background is blackened, to indicate that it has been selected:
     ![Selected cell]
   • To select more than one cell, press Ctrl, then click inside each one.

Inserting empty columns and rows

You can add columns and rows to existing tables or crosstabs.

1. Select a column, row or cell.
2. Click one of the insert buttons on the Structure toolbar:
   ![Insert buttons]
   a. Inserts a row above the selection
   b. Inserts a row below the selection
   c. Inserts a column to the left of the selection
   d. Inserts a column to the right of the selection
   e. Inserts a cell above the selection
   f. Inserts a cell below the selection
   g. Inserts a cell to the left of the selection
   h. Inserts a cell to the right of the selection

Naming or renaming a column or row

A new column or row does not have a title when you add it to your table. To name a column or row header:

1. Double-click the header cell.
2. Type a name.
3. Press Enter.

Resizing columns and rows

1. Click the mouse and move the cursor over the right edge of the column (or bottom edge of the row) you want to resize.
2. When the cursor changes to the Resize cursor, click the mouse and drag the edge to increase or decrease the column (or row) to the width (or row height) you want.

<table>
<thead>
<tr>
<th>Year</th>
<th>Items</th>
<th>Sales revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>Sweat T-Shirts</td>
<td>$688,484</td>
</tr>
<tr>
<td>2000</td>
<td>Sweat T-Shirts</td>
<td>$737,639</td>
</tr>
<tr>
<td>2001</td>
<td>Sweat T-Shirts</td>
<td>$1,910,247</td>
</tr>
<tr>
<td>1999</td>
<td>Accessories</td>
<td>$748,263</td>
</tr>
<tr>
<td>2000</td>
<td>Accessories</td>
<td>$1,086,301</td>
</tr>
<tr>
<td>2001</td>
<td>Accessories</td>
<td>$1,072,569</td>
</tr>
<tr>
<td>1999</td>
<td>Shirt Waist</td>
<td>$295,582</td>
</tr>
<tr>
<td>2000</td>
<td>Shirt Waist</td>
<td>$406,864</td>
</tr>
<tr>
<td>2001</td>
<td>Shirt Waist</td>
<td>$449,781</td>
</tr>
</tbody>
</table>

**Tip:** If you double-click on the resize cursor, the column or row is automatically sized to the width or height of the contents.

### Copying, pasting and deleting

You can copy, paste and delete report components using menu commands, toolbar buttons and keyboard shortcuts.

#### Copying tables and crosstabs

To copy tables and crosstabs:

1. Select the table.
2. In the **Standard** toolbar, click **Copy**.
3. Click in the location where you want to display the copy of the table.
4. In the **Standard** toolbar, click **Paste**.

**Tip:** You can also copy a table or crosstab by selecting it, dragging it to a new position and pressing Ctrl as you release the mouse. The table or crosstab is copied to the new location.

#### Deleting columns and rows

To delete columns and rows:

1. Select the column or row.
2. In the **Standard** toolbar, click **Delete**.

**Note:** You cannot delete empty columns of a crosstab. If you need to delete a crosstab, convert it into a table and then delete the table.
Deleting tables

To delete tables:
1. Select the table.
2. In the Standard toolbar, click Delete.

Copying and pasting from Desktop Intelligence to other applications

You can copy objects such as tables and charts in Desktop Intelligence, or copy the whole report contents, and then paste them into a Microsoft Office application, such as Excel or Word.

As in BusinessObjects 6.5 you can save Desktop Intelligence reports directly in Microsoft Excel format.

Free-standing cells

Desktop Intelligence reports have two types of cells:
• cells that make up tables
• free-standing cells

A free-standing cell is a single cell that is not attached to any other report component and can be moved and formatted individually. Free-standing cells have many uses in Desktop Intelligence reports. They are used to contain text, calculations or graphics and among other things for report titles, for adding comments and for displaying page numbers.

Inserting a free-standing cell

To insert a free-standing cell:
1. Click inside a blank space in the report to make sure no other report component is selected.
2. In the Report toolbar, click Insert Cell.
   The cursor changes to the Insert Cell cursor.
3. Click where you want your cell to appear and drag to draw a cell.
A cell appears in the area you draw when you release the mouse. A flashing cursor appears inside the cell to indicate that the cell is active.

**Tip:** Another way to insert a free-standing cell is to copy and paste an existing cell from the report. To do this: Select the cell. Click and hold the mouse. Press Ctrl and drag the mouse. When you release the mouse, a copy of the cell appears.

### Dragging a cell out of a table

You can drag a cell out of a table to display the data contained in it in a free-standing cell. To do this:

1. Select the cell.
2. Click in the cell again then drag and drop the cell out of the table to a blank space in the report.

If you drag a cell containing a dimension or detail object out of a table you create a master/detail report as shown below:

<table>
<thead>
<tr>
<th>City</th>
<th>Year</th>
<th>Sales (Revenue)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chicago</td>
<td>1999</td>
<td>$5,907,914</td>
</tr>
<tr>
<td>Chicago</td>
<td>2000</td>
<td>$1,186,165</td>
</tr>
<tr>
<td>Houston</td>
<td>1999</td>
<td>$1,211,309</td>
</tr>
<tr>
<td>Houston</td>
<td>2000</td>
<td>$1,590,440</td>
</tr>
<tr>
<td>Houston</td>
<td>2001</td>
<td>$2,246,196</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>1999</td>
<td>$862,627</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>2000</td>
<td>$1,581,816</td>
</tr>
<tr>
<td>Los Angeles</td>
<td>2001</td>
<td>$1,666,676</td>
</tr>
<tr>
<td>New York</td>
<td>1999</td>
<td>$2,067,656</td>
</tr>
<tr>
<td>New York</td>
<td>2000</td>
<td>$2,763,503</td>
</tr>
<tr>
<td>New York</td>
<td>2001</td>
<td>$3,151,022</td>
</tr>
<tr>
<td>Sum</td>
<td></td>
<td>$20,273,768</td>
</tr>
<tr>
<td></td>
<td>1999</td>
<td></td>
</tr>
<tr>
<td>City</td>
<td>Sales (Revenue)</td>
<td></td>
</tr>
<tr>
<td>Chicago</td>
<td>$5,907,914</td>
<td></td>
</tr>
<tr>
<td>Houston</td>
<td>$1,211,309</td>
<td></td>
</tr>
<tr>
<td>Los Angeles</td>
<td>$1,581,816</td>
<td></td>
</tr>
<tr>
<td>Los Angeles</td>
<td>$1,666,676</td>
<td></td>
</tr>
<tr>
<td>New York</td>
<td>$2,067,656</td>
<td></td>
</tr>
<tr>
<td>New York</td>
<td>$2,763,503</td>
<td></td>
</tr>
<tr>
<td>New York</td>
<td>$3,151,022</td>
<td></td>
</tr>
<tr>
<td>Sum</td>
<td>$20,273,768</td>
<td></td>
</tr>
</tbody>
</table>
Displaying Data in Tables

**Free-standing cells**

If you drag a measure out of a table you can display a grand total or a section total depending on where you place the cell. In the example below the table total is displayed at the top of the table.

![Table Example]

You can use a grid to automatically align the selection as you drag it. To do so,
- From the **Format** menu, click **Snap to Grid**.
- To view the grid, from the **View** menu click **Grid**.

**Editing cells and cell content**

You can work on free-standing cells in the following ways.

**Typing text in a cell**

Double-click on the cell. If the cell is empty, it has a black border around it and a flashing cursor. If the cell already contains text, the text is also highlighted.

Type in your text and press Enter.

**Tip:** If you get these symbols displayed in a cell ####, this happens because the cell contents are larger than the cell. Resize the cell to fix the problem.
Moving a cell
To move a cell to a different position, click on it once to select it and then click on it again and drag it to a new position.

Resizing a cell
To resize a cell, hold your cursor over the edge of the cell. When the cursor changes to the resize cursor, click and drag the cell border to resize it.

Tip: If you double-click on the resize cursor, the cell is automatically sized to content width. You can also automatically size the cell height by holding your cursor over the top or bottom border and double-clicking on the resize cursor.
Displaying Data in Tables

Free-standing cells
Breaking Up Tables
Overview

This chapter explains how to break up the data in tables and crosstabs and how to make and display simple calculations in tables and crosstabs. The final section of this chapter describes all you need to know about converting currencies to and from euros in Desktop Intelligence.

Working with breaks

This section explains how to break up data in tables and crosstabs and describes the different options available to format and manage these breaks.

What is a break?

A break does what its name implies. It breaks up the data in a table or crosstab by grouping the data according to a selected value. This allows you to display all the data for each value of a dimension variable together, and more importantly, it allows you to display subtotals. The example below demonstrates how breaking up a table works.

Example: How can I show revenue subtotals for each resort in a table?

The table on the left displays the revenue per quarter per resort with the total revenue displayed at the bottom of the table.

The table on the right displays the same data but, by breaking up the data, you can show a subtotal for the revenue generated by each resort for the four quarters of the financial year. A mini table is created for each of the three values of resort. This separation, however, is only visual. The three mini tables still belong to one block.
### Inserting and removing breaks

You can insert and remove breaks with a simple mouse click. The Insert Break icon in the Report toolbar is a toggle button that inserts and removes breaks on data.

#### Inserting a break

To insert a break:

1. Click the column or row where you want to insert a break.
2. In the Report toolbar, click **Insert Break**.

The data in the table is broken up and Insert Break dims.

#### Removing a break

To remove a break:

1. Click where you inserted the break.

In the Report toolbar the Insert Break dims showing that the break has been applied to the selection.

---

**Breaking Up Tables**

**Working with breaks**

---

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$334,661</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$237,672</td>
</tr>
<tr>
<td>Selfridge</td>
<td>Q3</td>
<td>$163,422</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$456,928</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$206,566</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$242,105</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$256,125</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$156,666</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,100</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q2</td>
<td>$341,790</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q3</td>
<td>$356,160</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q4</td>
<td>$356,990</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$3,206,524</td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$334,661</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$237,672</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$253,422</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$245,269</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Sum</td>
<td>$991,144</td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q3</td>
<td>$365,150</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q4</td>
<td>$356,250</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Sum</td>
<td>$1,419,660</td>
</tr>
</tbody>
</table>

---

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Sum</td>
<td>$3,206,524</td>
</tr>
</tbody>
</table>
2. In the Report toolbar, click **Insert Break**. The Break is removed from the table or crosstab.

*Note:* You can only insert breaks on tables or crosstabs, not on data in charts.

**Formatting breaks**

When you first insert a break on data, certain formatting and display options are applied by default. You can edit these settings and set other options in the Breaks dialog box.

To display the Breaks dialog box:

1. Right-click on the column or row where you inserted the break.
2. Click **Format Breaks** from the menu.

*Note:* If no break has been inserted on a table or crosstab, all the options in this dialog box are unavailable.
1. The breaks applied on columns appear in the Down tab. The breaks inserted on rows appear in the Across tab. For a crosstab, both tabs are displayed. For a table, only the appropriate Down or Across tab is displayed.

2. List of breaks currently inserted.

3. Allows you to insert a new break.

4. Remove a break by selecting it, then clicking Remove.

5. You can set break attributes for the selected break in the Break Definition box.

6. By default, a break is inserted on all values of the selected variable. Clicking Values allows you to select only the values you want to include in the break. To activate the Values, first click the Value-Based Break check box.

7. You can control the way a break is managed over page breaks in the Break and Pages box. These attributes are described on page 200.

8. Clicking Edit allows you to apply the selected break on a different variable, or on more than one variable. If the report contains at least two breaks on different levels, you change the break level.
Breaking Up Tables

Working with breaks

Showing headers and footers

When you insert a break, a mini table is created for each value of the variable. You can choose whether or not you want to display a header and/or footer in each mini table.

To do this:
• To display a break header or footer, click the box next to Break Header or Break Footer in the Breaks dialog box.
• To hide a break header or footer, clear the box next to Break Header or Break Footer in the Breaks dialog box.

The illustration below shows two examples of using break headers and footers with a sum calculation on the Revenue column:

This table displays a break footer only, a table header and footer, and a sum calculation.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$306,566</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q2</td>
<td>$242,185</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q3</td>
<td>$226,126</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q4</td>
<td>$169,966</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td><strong>$995,620</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$294,981</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q2</td>
<td>$297,872</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q3</td>
<td>$283,422</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q4</td>
<td>$245,269</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td><strong>$971,444</strong></td>
</tr>
</tbody>
</table>

This table displays a break header and footer, a table footer, and a sum calculation.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$306,566</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q2</td>
<td>$242,185</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q3</td>
<td>$226,126</td>
</tr>
<tr>
<td>French Riviera</td>
<td>Q4</td>
<td>$169,966</td>
</tr>
<tr>
<td><strong>Totals</strong></td>
<td></td>
<td><strong>$995,620</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$294,981</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q2</td>
<td>$297,872</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q3</td>
<td>$283,422</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q4</td>
<td>$245,269</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td><strong>$971,444</strong></td>
</tr>
</tbody>
</table>

Break header displays the sub-total for each section.

Table footer displays the total for the table.
Folding breaks

You can also choose to display only the break headers and footers in a table as shown in the illustration below. The other rows in the table are hidden.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Sum:</td>
<td>$835,420</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Sum:</td>
<td>$971,444</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Sum:</td>
<td>$1,678,568</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$3,286,524</td>
</tr>
</tbody>
</table>

To do this:

• Click the Fold check box in the Breaks dialog box.

Merging cells

When you insert a break on a row or column, several columns or rows may display the same value.

Displaying duplicate cells only once

You can display this value only once. To do this:

• Check Remove Duplicates on the Breaks dialog box.
Breaking Up Tables

Working with breaks

Centering the cell value across merged cells

You can also merge these cells into one and display the name only once. The name is centered over the columns or rows of data that it describes. To do this:

- Check Center Value Across Break on the Breaks dialog box.

The examples below show what happens when these options are applied:

<table>
<thead>
<tr>
<th>Report</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$205,505</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$242,195</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$228,126</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$158,595</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$835,429</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$203,556</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$242,156</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$228,126</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$158,596</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$835,429</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$234,001</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$239,072</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$203,422</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$246,262</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$971,144</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$327,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,700</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$395,600</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$1,479,680</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$371,750</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$395,600</td>
</tr>
<tr>
<td>Total</td>
<td></td>
<td>$1,479,680</td>
</tr>
</tbody>
</table>

Here, the Remove Duplicates option is turned on so the resort name displays only once.

Here, the Remove Duplicates and Center Value Across Break options are turned on. The resort name displays once and centered over the rows it describes.

In the Formatting toolbar, click Center Across Break to remove duplicate values, merge the cells and center the value over the rows or columns it describes.
Example: Centering the Resort value in a column

If the Resort column footer cell is empty when you center the resort value across the break, all rows, including the footer row are merged as shown in the table on the left below.

If you do not want an empty footer cell to be merged:

1. Type a character in the empty resort footer cell.
2. Right-click on the footer cell and select Format Cell from the menu. The Format Cell dialog box opens.
3. Click the Font tab.
4. Set the font color to the same color as the cell background, in this example to white, and click OK.
5. Click the Center Values Across Break check box in the Breaks dialog box.

The empty cells for each value of resort are merged and the footer cells are untouched, as shown in the table on the right below.

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$339,565</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$242,165</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$220,135</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$150,565</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$855,429</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$224,681</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$237,872</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$323,432</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$268,289</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$971,444</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$385,500</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$1,479,660</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$385,500</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$1,479,660</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$385,500</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$1,479,660</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$357,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$395,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$385,500</td>
</tr>
<tr>
<td></td>
<td>Sum</td>
<td>$1,479,660</td>
</tr>
</tbody>
</table>

Sum: $3,206,524
Making a value-based break

You can choose to apply a break only on certain values in your table. In the illustration below, instead of inserting a break on the whole resort column, the break is inserted on the resort French Riviera only. This breaks up the table to show a revenue subtotal for French resorts as illustrated below:

<table>
<thead>
<tr>
<th>Resort</th>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>French Riviera</td>
<td>Q1</td>
<td>$304,566</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$242,166</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$226,125</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$188,665</td>
</tr>
<tr>
<td>Sum: French Riv</td>
<td></td>
<td>$855,423</td>
</tr>
<tr>
<td>Bahamas Beach</td>
<td>Q1</td>
<td>$244,881</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$257,972</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$263,422</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$245,268</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>Q1</td>
<td>$267,170</td>
</tr>
<tr>
<td></td>
<td>Q2</td>
<td>$341,780</td>
</tr>
<tr>
<td></td>
<td>Q3</td>
<td>$396,150</td>
</tr>
<tr>
<td></td>
<td>Q4</td>
<td>$397,650</td>
</tr>
<tr>
<td>Sum:</td>
<td></td>
<td>$1,286,021</td>
</tr>
</tbody>
</table>

Here, the Break Footer, Remove Duplicates, and Value-Based Break options are turned on. The Show Table Header and Footer options display the table header and the table sum.

To do this, begin with a table where you select Show Header and Show Footer check boxes in the Format Table dialog box.
1. Select the Resort column, right click then select **Insert Break**.

![Insert Break](image)

2. Right-click on the **Resort** column and select **Format Break** from the menu.

The Breaks dialog box opens.

![Breaks](image)

3. Click the **Value-Based Break** check box.
When you click this check box, Values becomes available.

4. Click **Values**.
   The list of values box opens, displaying a list of all the values of the Resort dimension.

5. Select **French Riviera** from the list and click **OK**.
6. Click **OK** again to close the Breaks dialog box.
7. Right-click the **Revenue** column and select **Calculations** then **Sum**.
   The calculation result adds the French Riviera section and the entire table as shown above.

**Note:** Using value based breaks successfully depends on having the data available. If the break is based on data that is not in your report, the value-based break cannot work.

### Organizing multiple breaks

You can insert up to nine breaks on a table or crosstab.

When you have more than one break in a table or crosstab, the breaks are assigned levels. Desktop Intelligence assigns the name, level 1 to the first break, level 2 to the second and so on. You can rearrange these levels in the Breaks dialog box. You can also set different options for the different breaks.
In the illustration below, there are two breaks on the data: one on the Resort dimension and one on the Quarter dimension. The data is broken up first by Resort, then by quarter. You can change this organization at any time and add and remove breaks in the Breaks dialog box.

To reorganize the order in which breaks are applied:

1. Right-click on a column or row that contains a break and select \textit{Format Breaks} from the menu.

The Breaks dialog box opens.

2. Click the break name in the list and click \textit{Edit}.

3. Set the order you want the break to be applied and click \textit{OK}.

\begin{table}
\centering
\begin{tabular}{|c|c|c|}
\hline
Quarter & Resort & Service Type  \\
\hline
Q1 & Fresh Rivera & Accommodation  \\
& & $172.48 \\
& & Food & Drink  \\
& & $177.49 \\
& & Rooms  \\
& & $694.68 \\
& & Total  \\
& & $1,054.26 \\
Q2 & Fresh Rivera & Accommodation  \\
& & $385.72 \\
& & Food & Drink  \\
& & $328.29 \\
& & Rooms  \\
& & $496.30 \\
& & Total  \\
& & $1,209.31 \\
Q3 & Fresh Rivera & Accommodation  \\
& & $277.25 \\
& & Food & Drink  \\
& & $494.37 \\
& & Rooms  \\
& & $306.74 \\
& & Total  \\
& & $1,078.36 \\
Q4 & Fresh Rivera & Accommodation  \\
& & $914.61 \\
& & Food & Drink  \\
& & $821.98 \\
& & Rooms  \\
& & $311.50 \\
& & Total  \\
& & $1,848.36 \\
& & Fresh Rivera  \\
& & $199.59 \\
& & Total  \\
& & $935.63 \\
\hline
\end{tabular}
\end{table}
Managing breaks over multiple pages

When a table spans more than one page, there are certain options you can set to make sure that tables are not split incoherently so that certain elements such as column and row headers are repeated on the new page. You can set the following options in the Break and Pages section of the Breaks dialog box.

To open the Breaks dialog box:

- Right-click on a row or column that contains a break and select Format Breaks from the menu.

<table>
<thead>
<tr>
<th>Check this option</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avoid Page Break</td>
<td>Keep each break section of the table or crosstab on the same page, where possible.</td>
</tr>
<tr>
<td>Start a New Page</td>
<td>Display each part of the table or crosstab created by a break on a separate page.</td>
</tr>
<tr>
<td>Repeat the Header on the New Page</td>
<td>Repeat the header on each new page if a table or crosstab extends over more than one page.</td>
</tr>
<tr>
<td>Repeat Break Value on New Page</td>
<td>Repeat the current break value on the new page.</td>
</tr>
</tbody>
</table>
chapter

Formatting Sections, Tables, and Cells
Overview

This chapter describes how to format sections in a report and how to format the cells, rows and columns that make up tables and crosstabs.

Chapter headings include:

• “Formatting sections” on page 202
• “Formatting tables” on page 206
• “Formatting cells” on page 216

Formatting sections

You can format the sections in a report by applying shading to the background.

What are sections?

There are two section types in a Desktop Intelligence report.

Main Section

If you have not created any sections, the main section is the only section in the report and when you apply shading, the whole report (except margins) becomes the same color.

Sections in a Master/Detail report

If you have set up a report with sections, you can apply a different type of shading to each section in the report. This allows you to easily distinguish between the different sections.

The sections you create remain in the main section and a main section header displays at the beginning of the report. A main section footer displays at the end of the report.

You can hide the main section header or the main section footer or both of them if you wish.

Example: Using shading to distinguish between sections

In the illustration below, the report contains two sections: the main section and a Resort section. The Resort section has three values, Bahamas Beach, French Riviera and Hawaiian Club. The main section is shaded blue and the
Resort section yellow which allows you to clearly see where the sections begin and end. As you can see from the illustration, the Resort section is contained within the main section.

**Formatting sections**

1. Right-click in the section you want to format and select *Format Section* from the menu.
2. Click the **Shading** tab:

Click None if you do not want to apply shading to the section.

Click the pattern or shade from the list. If you click Clear, you apply the Background color only. If you click Solid, you apply the Foreground color only. The other settings mix the two colors.

3. Change the settings as required and click **OK**.

**To hide the main section header of footer**

1. Right-click in the main section header or footer area and select Format section.
2. Click the **General** tab.

![Section Format dialog box]

3. Click the **Hide Section Footer** or **Hide Section Header** check box.

   A section header or footer that is hidden appears in italics in the Report Manager Map list.

   **Note:** For more information on hiding and displaying report components, see “Hiding and displaying report components” on page 204.

**To display the section footer or header again**

1. In the Report Manager, click the **Map** tab.
2. If Report Manager is not open, click **Report Manager** from the **View** menu.
3. Click the Structure option.

4. Right-click on Main Section in the list in the Map window and click Format Section from the menu. The Section Format dialog box opens.

5. Click the General tab.

6. Clear the Hide Section Header or Hide Section Footer check box and click OK.

Formatting tables

Tables and crosstabs are made up of headers and footers, columns and rows, and cells. All these elements together make up the block. The cell is the most basic element of a table or crosstab. Rows and columns are made up of groups of cells. When you format tables and crosstabs, you can format cells or blocks.

Formatting blocks

You can format a block by applying shading and borders. The following procedure shows how to do this for a table. The procedure is the same for a crosstab or a chart block:

1. Right-click on the table and select Format Table from the menu. The Table Format dialog box opens.
2. Click the **Border** tab:

![Border tab](image)

3. Click a line style under the Style section.
4. To change the border color, click the color box next to Custom, then select a color from the color palette that opens.
5. Click **OK** to close the palette.
6. Set which sides of the block you want to format.
   You can:
   - Click one or more borders in the Borders box, or
   - Click **Box** to put a border on all four sides of the table.
7. Click **Apply**.
8. Click the **Shading** tab and make the required settings.
   See "Click the Shading tab:" on page 204, for more on the available options on the Shading tab.
9. Click **OK** to close the dialog box.
Example: Applying shading and borders to tables

In the examples below, the table has been shaded yellow. In the first table, all four sides have a double-line border. In the second table, a thick border has been applied to the top and bottom sides only.

Example: Correctly formatting crosstab corners

When you apply shading to a section and then insert a crosstab, the corner cells of the crosstab may be incorrectly shaded or formatted as shown in the example below. In this example, you want the top left-hand corner be shaded as the section shading.

There are two things you have to check:

- the cell shading is set to transparent
- the crosstab shading is set to transparent

To do this:

1. Right-click on the top left-hand cell and select Format Cell from the menu.

   The Cell Format dialog box opens.

2. Click the Shading tab.
3. On the Shading tab, click **None** under Fill.

The cell becomes transparent allowing the section shading to show through.

Tip: If this has not solved the problem, repeat the procedure above. This time, click Crosstab from the Format menu.

**Formatting Appearance**

You can change the position of a block on the page by selecting the position and editing the display criteria. The Appearance tab allows you to position blocks relative to sections, margins or the page both vertically and horizontally. You can also set a condition to display or hide the block if a certain condition is met.

**Example:** **Aligning a block position and creating a condition to hide a block**

The following example shows you how to select the vertical position of the block and how to hide a block that fits a particular condition. The procedure is the same for a crosstab or a chart block:

1. Create a report.
   The example uses the eFashion universe using the Lines, SKU number, Year and Sales Revenue objects.

2. Create a break on year.
   Tip: To learn how to create a break, see “Inserting and removing breaks” on page 239.

3. Select a block on the report

4. Click **Table** from the **Format** menu.
   - Click **Crosstab** or **Chart** from the **Format** menu if your block applies to one.
The Table Format dialog box appears.

5. Click the **Appearance** tab.
6. Under **Vertical Position Relative to**, select **Top Margin** from the list.
7. Click the **Hide Block** check box and enter the formula =<Year>='2001'.
8. Click **OK**.

The table data for 2001 no longer appears and the other tables appear relative to the top of the page.

Since you oriented the block to the top of the page, the block covers the other break space. Your report page looks normal but when you click Print Preview from the File menu, your results look like this:

```
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item1</td>
<td>Item1</td>
<td>Value1</td>
</tr>
<tr>
<td>Item2</td>
<td>Item2</td>
<td>Value2</td>
</tr>
<tr>
<td>Item3</td>
<td>Item3</td>
<td>Value3</td>
</tr>
</tbody>
</table>
```

These results are unacceptable, let's go back and remove the Report Title.
Also note that there is an empty space under the table. This corresponds to the space normally reserved for the title. Because the table position has shifted to the top margin, the table size does not recalculate to fit on the entire page.

**Resizing columns, rows and cells**

You can resize cells, rows and columns.

**Resizing using the mouse**

To change the width:

1. Click the right border of the selection.
2. Click the mouse and drag the border until the selection reaches the width you want.

To change the height of the selection:

1. Click the top border of the selection.
2. Click the mouse and drag the border until the selection reaches the height you want.
Resizing using a menu

1. Select the cells, columns or rows you want to resize.
2. Click Cell Height and Width from the Format menu.
   The Cell Height and Width dialog box appears.

3. Set the width on the Width tab.
4. Click the Height tab and set the height.
5. Click OK.
   The dialog box closes and the selection is resized, according to the settings you entered.

Showing headers and footers

You can choose whether you want to display headers or footers or not on a table and specify how rows and columns are managed. For crosstabs, the header rows are always displayed but you can choose to display or hide the footer row and columns and also choose to display additional information in the header.

To set these options:

1. Right-click on the table or crosstab and select Format Table or Format Crosstab from the menu.
2. Click on the General tab.
   The options you can set are described below.
Tables

Example: Displaying tables in a multi-column layout

You can set up a multi-column or multi-row page layout to fit more information on a page. The example below shows how this works:

<table>
<thead>
<tr>
<th>Column 1</th>
<th>Column 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>Item 2</td>
</tr>
<tr>
<td>Item 3</td>
<td>Item 4</td>
</tr>
<tr>
<td>Item 5</td>
<td>Item 6</td>
</tr>
</tbody>
</table>

In this example, you have a long two column table. By setting the page to display a three column layout, you use the page space more efficiently. You can also set how much space you want to have between each set of columns or rows.

<table>
<thead>
<tr>
<th>Columns</th>
<th>Spacing</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>1/16 Inch</td>
</tr>
</tbody>
</table>
You can only see the results of this setting in page layout view.

**Example:** Displaying duplicate rows in a table

The Avoid Duplicate Rows Aggregation option allows you to display all rows of a report instead of aggregating to avoid displaying rows with the same set of dimensions.

This is demonstrated in the example below:

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Resort</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q1</td>
<td>Bahama Beach</td>
<td>224,000</td>
</tr>
<tr>
<td>Q1</td>
<td>French Riviera</td>
<td>237,872</td>
</tr>
<tr>
<td>Q1</td>
<td>Hawaiian Club</td>
<td>357,170</td>
</tr>
<tr>
<td>Q2</td>
<td>Bahamas Beach</td>
<td>228,128</td>
</tr>
<tr>
<td>Q3</td>
<td>Hawaiian Club</td>
<td>395,500</td>
</tr>
<tr>
<td>Q4</td>
<td>French Riviera</td>
<td>159,666</td>
</tr>
<tr>
<td>Q4</td>
<td>Hawaiian Club</td>
<td>385,600</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q1</td>
<td>750,976</td>
</tr>
<tr>
<td>Q2</td>
<td>821,817</td>
</tr>
<tr>
<td>Q3</td>
<td>684,452</td>
</tr>
<tr>
<td>Q4</td>
<td>779,394</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Q1</td>
<td>224,000</td>
</tr>
<tr>
<td>Q2</td>
<td>159,666</td>
</tr>
<tr>
<td>Q3</td>
<td>395,500</td>
</tr>
<tr>
<td>Q4</td>
<td>385,600</td>
</tr>
</tbody>
</table>

The first table shows the revenue per resort per quarter. Since each resort per quarter is unique, it does not make a difference if duplicate row aggregation is used or not.

The second table shows what happens when the Resort column is removed. The revenue column shows a sum of all resorts for each quarter. Since there are only four quarters, there are only four rows in the table.

The third table shows the effect of using the Avoid Duplicate Rows Aggregation option on the second table. Here the original number of rows is retained, even though the table shows duplicate rows based on the dimension shown (Quarter).
Crosstabs

Showing additional header information

When you display data in a crosstab, the headers show the values of the variables placed in the header row and column. If you click the Show Variable Header check box, you can display the name of the variable as well as the values and also show what the figures in the body cells refer to. This gives additional information to help interpret the data in the crosstab.

Here is an example of how this works:

<table>
<thead>
<tr>
<th></th>
<th>Q1</th>
<th>Q2</th>
<th>Q3</th>
<th>Q4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bahamas Beach</td>
<td>224,981</td>
<td>237,872</td>
<td>263,422</td>
<td>245,269</td>
</tr>
<tr>
<td>French Riviera</td>
<td>209,955</td>
<td>242,105</td>
<td>220,125</td>
<td>169,565</td>
</tr>
<tr>
<td>Hawaiian Club</td>
<td>357,170</td>
<td>341,700</td>
<td>395,150</td>
<td>385,560</td>
</tr>
</tbody>
</table>

Here the values only are shown in the headers and the figures only in the body cells.

The same crosstab with the Show Variable Header option on.
Formatting cells

This section describes how to format cells. The illustration below shows what you can do to format cells and their contents:

Before you can format cells, you must first select them.

Selecting the body without the header

By selecting the body, you can format all the cells it contains at the same time, for example by applying border styles or backgrounds.

The body:

• contains cells where data is displayed in a table or a crosstab
• does not include the title cells that appear at the top of columns and to the left of rows

Selecting the body in a table

To select the body in a table:

1. Place the cursor on the left-hand border of the table, but not at the top where the title cells appear.
2. When the cursor turns into a black arrow pointing towards the table, click once.
A hatched gray border appears around the table, and the body is highlighted to show that it is selected:

<table>
<thead>
<tr>
<th>Year</th>
<th>Number of guests</th>
</tr>
</thead>
<tbody>
<tr>
<td>FY93</td>
<td>187</td>
</tr>
<tr>
<td>FY94</td>
<td>191</td>
</tr>
<tr>
<td>FY95</td>
<td>197</td>
</tr>
</tbody>
</table>

Figure 10-1: A table, with the body selected

To select the body in a crosstab

1. Click once inside the body of the crosstab.
2. If the body contains two or more variables, press Shift and click each one.

A hatched gray border appears around the crosstab, and the body is highlighted to show that it is selected:

<table>
<thead>
<tr>
<th></th>
<th>Golfers Beach</th>
<th>French Riviera</th>
<th>Hawaiian Club</th>
</tr>
</thead>
<tbody>
<tr>
<td>FY93</td>
<td>157</td>
<td>124</td>
<td>177</td>
</tr>
<tr>
<td>FY94</td>
<td>191</td>
<td>147</td>
<td>167</td>
</tr>
<tr>
<td>FY95</td>
<td>197</td>
<td>145</td>
<td>176</td>
</tr>
</tbody>
</table>

Figure 10-2: A crosstab, with the body selected

Using the Formatting toolbar

The quickest and easiest way to apply common formats is to use the toolbars.

To display the Formatting and Borders toolbars:

1. From the View menu, click Toolbars.
   The Toolbars dialog box opens.
2. Click the Formatting and Border toolbar check boxes, then click OK.
   The toolbars display. The available formatting icons are illustrated in the sections that follow.

Repeating cell formats

When you have spent time formatting a cell, you can quickly apply the same formats to other cells. To do this:

1. Select the cells you want to format.
2. From the Edit menu, click Repeat Format.

Tip: You can also use the keyboard shortcut Ctrl+Shift+Y
Copy formatting

You can copy and paste the formatting only of a cell. To do this:

1. Select the cell from which you want to copy the formatting.
2. In the Standard toolbar, click Copy.
3. Select the cell to which you want to paste the formatting.

The formatting is copied but the contents remain unchanged.

Tip: You can also use the keyboard shortcut Ctrl+Shift+V to paste the formatting only.

Formatting text

You can format text in cells in the following ways:

- change the font and font size
- apply color
- apply bold, italics and underline

You can apply some of these text formatting features using the Formatting toolbar:

<table>
<thead>
<tr>
<th>a</th>
<th>b</th>
<th>c</th>
<th>d</th>
<th>e</th>
<th>f</th>
</tr>
</thead>
<tbody>
<tr>
<td>a. Font</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>b. Font size</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>c. Bold</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>d. Italics</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>e. Underline</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>f. Text color</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To apply text formatting

1. Select the cell(s), row(s) or column(s) that contain the text you want to format.
2. Use the Formatting toolbar to apply formatting.
Using the Cell Format dialog box to format text.

To use the Cell Format dialog box to format text:

1. Select the cell(s), row(s) or column(s) that contain the text that you want to format.

2. Click **Cell** from the **Format** menu, or right-click and select **Format Cell** from the menu.

   The Cell Format dialog box appears.

3. Click the **Font** tab to display the text formatting features:

   ![Cell Format Dialog Box](image)

4. Click the text formats you want, then click **Apply** or **OK**.

   The new formats appear in the selection.

Formatting numbers and dates

This section describes how to apply formats supplied by Desktop Intelligence to numbers and dates, and how to create your own formats.

Using the toolbars to format numbers and dates

The Formatting toolbar has several icons you can use to quickly apply certain formats to numbers in cells or on charts.

1. Click **Toolbars** from the **View** menu and select the **Formatting** toolbar.
2. Select the number you want to format and click the number formatting icons.

- a. Formats the number with the default currency style
- b. Formats the number with the default percent style
- c. Formats the number with the default million style
- d. Adds a decimal place
- e. Removes a decimal place

Note: The default currency, million and percent styles are taken from the regional settings properties in the Windows Control Panel.

To format numbers and dates

1. Select the cell(s), row(s) or column(s) that contain the numbers or dates that you want to format.

2. In the Format menu, click Cell or right-click the cell and select Format Cell.

The Cell Format dialog box appears.

3. Click the Number tab:
4. Click a category in the Category list to display its corresponding formats:
   - All: All formats.
   - Custom: Formats that you have created yourself.
   - Number: Formats for decimal values.
   - Currency: Formats for currency values.
   - Date/Time: Date and time formats.
   - Scientific: Formats to display values to the $n$th power.
   - Percentage: Percentage formats.
   - Condition: Mr., Mrs., Miss.
   - Boolean: True, False.
   - Image: Bitmap/TIFF

5. Click a format in the Format list.
   An example of the effect the format has on numbers is shown below the Positive field. Examples also appear below the other fields (Negative, Equal to Zero and Undefined) if the format has been defined for negative numbers, zero and empty cells, respectively.

6. Click **Apply** or **OK**.
   The new formats are applied to the selection.

### Creating your own number and date formats

You can create your own number and date formats, based on standard formats. To illustrate the procedure that you must follow to create your own format, the steps described in this section are based on an example.

**Example:** Creating a number format with three decimal places

The format can be applied to positive and negative values, as well as to zero values and empty cells.

1. In the **Number** tab of the Cell Format dialog box, click the **Number category** from the Category list.
   The corresponding number formats appear in the Format list.

2. Click the number format with two decimal points (0.00).
   The effect that this format has on positive values appears below the Positive field.

3. Click inside the Positive field, then add a zero in third decimal place.
You have now created a format that will display positive values with three decimal places. If you do not wish to enter formats in the remaining fields (Negative, Equal to Zero and Undefined), go to step 6.

4. Click inside the Negative field, then enter the format (0.000).
   Negative values will display with three decimal points.

5. Enter 0.000 in the Equal to Zero and Undefined fields.
   These fields correspond to null values (zero) and empty cells, respectively. In cells that contain null values, “0.000” will be displayed. The format is also applied to empty cells.

6. Click Add.
   The new format appears in the Format list, under the Number category and the Custom category.

7. Click Apply or OK.
   The new number format is available for use.
Applying colors to text

You can apply a color to number formats that you create. For example, if you want negative values to appear in red, type \[\text{Red}\] after the number format in the Negative field.

<table>
<thead>
<tr>
<th>Properties</th>
<th>Positive</th>
<th>Negative</th>
<th>Equal to Zero</th>
<th>Undefined</th>
</tr>
</thead>
<tbody>
<tr>
<td>12345.679</td>
<td>12345.679</td>
<td>[Red]</td>
<td>0.000</td>
<td>0.000</td>
</tr>
</tbody>
</table>

To delete number and date formats that you have created

You can delete number and date formats that you or other users have created.

1. In the **Number** tab of the Cell Format dialog box, click the **Category** where you created the format you want to delete.
2. Select the format(s) that you wish to delete.
3. Click **Remove**, then click **OK**.

Using hyperlinks in Desktop Intelligence reports

You can easily add hyperlinks such as email addresses and web site addresses to your reports. Desktop Intelligence automatically recognizes certain keywords or symbols included in the address, adds any extra syntax and formats the address as a hyperlink. Hyperlinks you add to a Desktop Intelligence report are retained when you save the report in PDF or in HTML format.

Desktop Intelligence automatically recognizes the keywords, syntax and symbols listed in the table below and transforms them into hyperlinks:

<table>
<thead>
<tr>
<th>Keyword or syntax</th>
<th>Automatically recognized and formatted as</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP or www</td>
<td>HyperText Transfer Protocol</td>
</tr>
<tr>
<td>MAILTO or @</td>
<td>Electronic Mail</td>
</tr>
<tr>
<td>FILE</td>
<td>Host-specific Files</td>
</tr>
<tr>
<td>&lt;a href&gt;</td>
<td>specified in the HTML code</td>
</tr>
<tr>
<td>FTP</td>
<td>File Transfer Protocol</td>
</tr>
<tr>
<td>NEWS</td>
<td>Usenet news</td>
</tr>
<tr>
<td>TELNET</td>
<td>Telnet Protocol for Interactive Sessions</td>
</tr>
</tbody>
</table>
How are hyperlinks formatted?

If you have Microsoft Internet Explorer installed, hyperlinks in Desktop Intelligence reports are formatted according to your Internet Explorer settings. If Internet Explorer is not installed on your computer, hyperlinks are formatted in blue (until you click it a first time) and underlined.

Adding a hyperlink

You can type an address directly into a cell or retrieve it through a query if your universe Designer includes hyperlinks in a universe.

1. Select the cell where you want the hyperlink to appear.
2. Type in the address using one of the supported keywords or symbols in the table above and press return.

Desktop Intelligence automatically detects the hyperlink and formats accordingly.

Tip: Selecting and resizing cells containing hyperlinks need special attention. Every time you click on the cell, the hyperlink is activated. Make the cell that contains the hyperlink longer than the actual text inside so that you can select the cell after the address without activating the hyperlink.

Example: Adding a link to a web site in a report

Complementary information on the data in your report is available on a company web site. Including a link to this site from your report allows your report readers to go directly to the source of further information. To add a web site address to your report:

1. Insert a new free-standing cell in your report.
2. Allow some space in the cell after the address to select the cell without activating the hyperlink.
3. Select the cell and type in the address: www.businessobjects.com.
4. Press Enter.
Desktop Intelligence automatically recognizes the key string www as part of a web address and formats the string in blue underline. If you move your mouse over the address, the cursor changes to the hand icon to show it is a hyperlink.

5. Click the link.
6. If you have Internet access, the Desktop Intelligence web site opens in your Internet browser.

www.businessobjects.com

Defining the hyperlink text

Desktop Intelligence also recognizes `<a href` syntax which allows you to define exactly what will be visible in the hyperlink and to define relative paths to files.

In the example syntax below, the hyperlink takes you directly to the Tips & Tricks page on the Business Objects web site but you only see “BusinessObjects Tips & Tricks” displayed in your report:

`<a href="http://www.businessobjects.com/services/infocenter//tips/start/starthome.htm">BusinessObjects Tips & Tricks</a>`

If you move the mouse cursor over the address, a tooltip appears displaying the web address syntax:

BusinessObjects Tips & Tricks

Editing a hyperlink

You can edit a cell containing a hyperlink either directly in the cell or by using the Formula Bar.

Using the Formula Bar

1. Open the Formula Bar by clicking Formula Bar from the View menu.
2. Select the cell containing the hyperlink you want to edit.
The full hyperlink syntax displays in the Formula Bar window.

3. Make the required changes in the Formula Bar window and press Enter. The hyperlink is updated.

**Editing directly in the cell**

1. Double-click the cell containing the hyperlink you want to edit. The hyperlink becomes editable.
2. Make the required changes and press Enter. The hyperlink is updated.

**Aligning cell contents**

Aligning contents means positioning the data in a cell relative to the borders of the cell. For example, you can align data against the left border of its cell.

You can use the Formatting toolbar to align cell contents:

- **a. Left align**
- **b. Center**
- **c. Right align**
- **d. Justify**

**Note:** If your table contains a cell with text in courier font and you click to center align the column, the text may be cut off on some lines. Business Objects recommends that you use another non-True Type font for large table cells.

To align cell contents:

1. Select the cell(s), row(s) or column(s) whose contents you want to align.
2. Click one of the alignment buttons.

You can also use the alignment features in the Cell Format dialog box. To do so:

1. Select the cell(s), row(s) or column(s) whose contents you want to align.
2. Right-click the cell, row or column and click **Format** from the menu. The Cell Format dialog box appears.
3. Click the **Alignment** tab to display the alignment features:

![Alignment tab in the CellFormat dialog box](image)

- **This option aligns text to the right and numbers to the left.**
- **Click this option to display long contents on multiple lines.**
- **To modify the vertical alignment of cell contents, click an option under Vertical.**

4. Select the features that you wish to apply to the selection, then click **OK**. Certain table or crosstab types used in financial reports have a characteristic layout as shown in the illustration below.

![Table illustration](image)

### Indenting cell content

You can set a space between the left cell border and the text or numbers in the cell to give the appearance of an indented list in your table.

1. On the **Alignment** tab, click **Left** to align the cell contents left of the cell.
2. Set a value in the Indents box.
   - A value of one is equal to one space. You cannot enter negative values.
Formatting cells

You can also use the Formatting toolbar:
1. Click the cell.
2. In the Formatting toolbar, click Left Align.
3. Use the buttons to increase and decrease the amount of indent.

Fill and character settings

You can fill in the space between the end of the text in a cell and the cell border with a selected character.

1. On the Alignment tab, click the Fill check box under Settings.
   The Character text box becomes active.

   - Fill
   - Character
   - Smart Tag
   - Flow by Flow Auto Fill
   - Flow by Page

2. Type any one character.
3. Click OK.

Merging cell contents

When you have inserted a break on a row or column, you have several columns or rows displaying the same value. You can remove these duplicate values, merge the empty cells and center the value over the rows or columns it describes.

To do this:
1. Click in the column or row where you have inserted a break.
2. In the Formatting toolbar, click the Center Values Across Break.

Note: For information on inserting and managing breaks see “Breaking Up Tables” on page 187.
Wrapping cell contents

When you have a long label in a header row or column, you can display the text on more than one line.

In the example below, the Number of guests label is much longer than any of the figures displayed under it and this column is taking up unnecessary space in the table. By wrapping the cell contents and then resizing the column, you can get round this problem.

To do this:
1. Right-click on the Number of guests cell and click Format Cell from the menu.
   The Cell Format dialog box opens.
2. Click the Alignment tab.
3. In the Settings section, click the Wrap Text check box.

Tip: If you have column labels on two or more lines, click Bottom in the Vertical section of the Alignment tab to align all labels along the last line of text.

To automatically align rows of wrapped text, click Row by Row Auto Fit. The size of the highest cell in the row is taken as default. Please note that if you manually adjust the size of the row the auto fit feature is deactivated.

Row by Row Auto Fit

To automatically adjust the height of cells, use the Row by Row Auto Fit option. This allows you to reduce or enlarge cell contents to fit within the row size automatically.

To use this option:
1. Select the block or cells.
2. Right click and select Format Cell from the menu.
   The Cell Format dialog box appears.
3. Click the Alignment tab.
4. Under Settings, click the Wrap Text option.
   The Row by Row Auto Fit option becomes active.
5. Select the **Row By Row Auto Fit** check box.
The cell height automatically adjusts to the height of the highest cell.

**Formatting cell borders**

You can format cell borders by applying line styles and colors. The Borders toolbar make it easy to format cell borders:

![Borders Toolbar]

- a. Enables you to select the line style to apply.
- b. Applies the style to the upper border.
- c. Applies the style to the lower border.
- d. Applies the style to the left border.
- e. Applies the style to the right border.
- f. Applies the style to the inner borders.
- g. Applies the style to the outer borders.
- h. Removes the style from all borders.
- i. Selects the color to apply.

To display the Borders toolbar:

- Right-click on any toolbar and select **Borders** from the menu.
- or
- If the **Formatting** toolbar is already displayed, click the drop-down arrow next to the Borders icon.

**To format borders**

1. Select the cell(s), row(s) or column(s) whose borders you want to format.
2. Click a line style and a color.
3. Click the border icons to apply the top, bottom, right or left borders to the cell.

**Using the Cell Format dialog box to format borders**

You can also use the Cell Format dialog box to apply lines and colors to cell borders. To do this:

1. Select the cell(s), row(s) or column(s) that you want to format.
2. Select **Cell** from the **Format** menu, or right click and select **Format Cell** from the menu. The Cell Format dialog box appears.

3. Click the **Border** tab to display the border formatting features:

4. Click a line style under **Style**.

5. To change the border color, click the color box next to the Custom option, then select a color from the color palette.

6. Click **OK** to close the palette.

7. Select the border(s) you want to format. You can select them individually, or, to select the outer borders, click **Box**.

8. Click **Apply** or **OK**. The border line styles and color are applied to the borders you selected.

### Formatting cell backgrounds

You can format the background of cells in the following ways:

- change the color
- apply a pattern
- combine a color and a pattern

To format cell backgrounds:

1. Select the cell(s), row(s) or column(s) that you want to format.
10 | Formatting Sections, Tables, and Cells
Formatting cells

2. Click **Cell** from the **Format** menu. The Cell Format dialog box appears.

3. Click the **Shading** tab.

4. Make the required settings, then click **Apply**. The shading and color attributes are applied.

5. Click **OK** once you are done with your changes.
chapter

Working with and Formatting Charts
Working with and Formatting Charts

Overview

Charts are the graphic equivalent of tables and crosstabs. Desktop Intelligence has a very powerful and easy-to-use charting feature. You can produce sophisticated and visually appealing charts to display a simple summary of your data or complex relationships in it.

This chapter describes:

• How to display data in charts in Desktop Intelligence reports and how to organize the way the data is displayed on the chart.

• How to add and format the different elements (legends, titles, grid lines) to your charts to obtain professional looking results.

Chart types

Desktop Intelligence has several basic chart types, some with two-dimensional and some with three-dimensional views. Here are examples of the available chart types.

Two-dimensional and three-dimensional column
Two-dimensional and three-dimensional horizontal column

Two-dimensional and three-dimensional line
Working with and Formatting Charts

Chart types

Two-dimensional and three-dimensional horizontal line

Two-dimensional and three-dimensional area
Working with and Formatting Charts

Chart types

Two-dimensional and three-dimensional horizontal area

Two-dimensional and three-dimensional pie

XY Scatter chart
Creating a chart

There are several ways to create a chart. You can:

- use the Insert Chart wizard
- turn an existing table or crosstab into a chart
- copy and paste an existing table or crosstab and then turn it into chart

To create a chart you need to use at least one measure object and one dimension or detail object.

Creating a chart using the New Chart Wizard

You can use the New Chart Wizard to insert a chart in a report. The following procedure shows you one way to create a chart using existing data.

1. Click Insert Chart on the Report toolbar or, Click Chart on the Insert menu.
   The cursor changes to the insert chart icon.

2. Click in an empty section of the report and drag the cursor to draw a box around the area where you want the chart to display.
   Note: The size of the box you draw determines the size of the chart.

3. Release your mouse when you reach the size you want.
   The New Chart wizard appears.

The New Chart Wizard helps you insert a chart in the active report. You must specify the data that you want to display in the new chart.

- To display the new chart, you can:
  - Use existing data from the document
  - Build a new query or the universe currently in use
  - Access new data in a different way
  - Use an existing query to build a new one
4. Click the first option, **Use existing data from the document**, then click **Begin**.

**Note:** The choices are:

<table>
<thead>
<tr>
<th>New Chart Wizard Option</th>
<th>Allows you to:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use existing date from the document</td>
<td>Choose the variables that appear in the current document for your chart</td>
</tr>
<tr>
<td>Build a new query on the universe currently in use</td>
<td>Choose the variables that appear in the current universe for your chart</td>
</tr>
<tr>
<td>Access new data in a different way</td>
<td>Access other data sources such as corporate data, universes, or personal files.</td>
</tr>
<tr>
<td>Use an existing query to build a new one</td>
<td>Select an existing query from your report and build a new one. The graph is independent of your first query. You can modify it without modifying the query on which it is based.</td>
</tr>
</tbody>
</table>

For more information on the choices described in the table below, see *Desktop Intelligence User's Guide: Accessing Data and Data Analysis*, Chapter 6, "Combining Data from Different Sources" and Chapter 12, "Customizing Queries on Universes".

5. Press Ctrl and select all the variables you want to display in the chart.

6. Click **Next**.

7. Click the type of chart you want to display from the list and then click a chart style.

8. Click **Finish**.

The chart displays in the report.

**Note:** If you check **Generate a Default Chart**, Desktop Intelligence automatically creates the default chart best suited to the number of variables you have selected in the list. If you check this option, the Chart Autoformat dialog box does not appear. Simply click Finish to generate the chart.
Creating a chart

Turning a table or crosstab into a chart

If you want to convert the display of your table or crosstab into a chart, you can do this automatically in two ways:

First method

1. Select the table or crosstab.
2. Click the arrow next to Chart Type icon in the Report toolbar.
3. Select a chart type from the graphic menu.

Second method

1. Select the table or crosstab and right-click it.
2. Click Turn to Chart from the menu.
   
   For each chart type, several predefined styles are available. Each style provides a variation on the basic chart type as illustrated below.

3. Click the Chart type from the Chart Types list box and then click a chart style.
4. Click OK to close the Chart Autoformat dialog box and save the settings.

Tip: If you want to continue to display the table and add a chart next to it: Copy the table or crosstab, paste it in a new location and then turn it to a chart.

---

**Turning a chart into a table or crosstab**

You can turn a chart into a table or a crosstab.

1. Select the chart then right-click it and select **Turn to Table** or **Turn to Crosstab** from the menu.
   - If you have a two-dimensional chart, Turn to Table displays.
   - If you have a three-dimensional chart, Turn to Crosstab displays.

   The data from the chart displays in a table or crosstab.

**Finding the best chart type for your data**

When you turn a table or crosstab to a chart, Desktop Intelligence selects a default chart type based on the type of block — table or crosstab — and the number of variables in the block. If you prefer a different format than the default choice, try experimenting with other chart types by right-clicking the chart and selecting Chart Auto Format.

Note: If you click Apply before OK, the new chart format may disappear from the report until you close the dialog box.

**Switching between chart types**

You can easily switch from one type of chart to another.

There are two ways to change a chart type. The first method allows you to change from one chart to another. The second method allows you to apply a predefined chart style to the selected chart type.

**To change chart type only**

1. Select the chart.
2. In the **Report** toolbar, click the drop-down arrow in the **Chart Types** list box.
3. Click the new chart type from the menu.

   The data displays using the new chart type.
To change chart type and style

1. Right-click on the chart and select Chart AutoFormat from the menu. The Chart AutoFormat dialog box appears.

2. Click a chart type from the list and then a style for that chart type.
3. Click OK.

The new chart type displays in the report.

Note: If you click Apply before OK, the new chart format may disappear from the report until you close the dialog box. The chart reappears once you click OK.

To change the chart colors

You can format every element of your chart and customize how it appears on the report. For more information on the different chart elements and how to format them, see “Chart elements and how to format them” on page 248.
Organizing chart data

In all chart types, except pie charts, data is plotted on axes. Charts have two or three axes. Measure objects are always plotted on the Y-axis and dimension or detail objects are plotted on the X-axis or the Z-axis.

To organize how your data displays, use the Pivot tab on the Format Chart dialog box. The pivot tab allows you to:

- move data from one axis to another
- re-distribute data between the axes
- add or remove data
- temporarily hide data from your chart
- change the order in which the variable displays on the axis, if you have more than one variable on an axis

Matrix charts

A matrix chart has at least one variable on each of the three axes. When you select a table and turn it into a chart, the data distributes over two axes. When you select a crosstab and turn it into a chart, the data automatically distributes over three axes. The example below shows how you achieve a different view on a column chart by re-distributing the data over three axes.

Example: Re-organizing data in two-dimensional charts

The following charts represent revenue per quarter for the top three lines in the eFashion industry by region. In both charts, the measure variable, Revenue is placed on the Y-axis.
In the first chart, the variables Quarter and Lines, are on the X-axis. This produces a horizontal column chart where all the columns have the same color since they all show Revenue.

In the second chart, the variables have been re-arranged to produce a matrix chart. Quarter has been placed on the Z-axis. The columns are now grouped by Lines and Quarter is represented by a different color column.
Example: Showing multiple lines on a line chart

The two charts below display data for one measure, Revenue, and two dimensions, Lines and Financial Year. In the first illustration the two dimensions appear by default on the X-axis. By moving Lines to the Z-axis, as shown in the second illustration, you display multiple lines on the same chart and plot the revenue for each line.

![Figure 11-1: both dimensions are on the X-axis](image1)

![Figure 11-2: the Year dimension is on the Z-axis](image2)

Example: Re-organizing data on chart axes in three-dimensional charts

In the illustration below, the first chart shows the Quarter variable plotted on the Z-axis and the Service Line variable on the X-axis. In the second chart these two variables have been swapped. We did this by dragging Quarter into the X-axis folder on the Pivot tab of the Chart Format dialog and dragging Service Line into the Z-axis folder. The second chart shows Quarter plotted on the X-axis and Service Line on the Z-axis.
Reorganizing chart data

To reorganize the data in a chart:

1. Right-click on the chart and select Format Chart from the menu. The Chart Format dialog box appears.
2. Click the Pivot tab.

In two-dimensional charts, the variables appear in the X-axis and Y-axis folders. Numeric data appears in the Y-axis folder. In matrix charts, there is at least one variable in each of the three folders.

The Pivot tab shows a representation of the data in the chart:

- The Available Variables box displays a list of the variables you can display in the chart.
- The Used Variables box displays three folders. These folders show the variables that are already displayed on the X-axis, the Y-axis and the Z-axis.
3. Add variables by clicking the variables under Available Variables then click Add.
4. Remove variables by clicking the variables under Used Variables then click Remove.
5. Click Apply to display the changes on your chart.
6. Click OK to close the Chart Format dialog box and save your changes.

Moving Data

While you display the Pivot tab of the Chart Format dialog box, you can move data from one axis to another:

- Drag the variable from its current axis folder and drop it in the new one.

To change the order in which data appears on chart axes:

1. In the Used Variables box, select the variable you want to move.
2. Click Move Up or Move Down.
3. Click Apply or OK.

The data shifts on the chart to reflect your changes.

Removing or hiding data

While you display the Pivot tab of the Chart Format dialog box, you can hide or remove variables from the chart.

1. In the Used Variables box, select the variable you want to remove or hide.
2. Remove or hide more than one variable at the same time, by pressing Ctrl and selecting the variables.
3. Click Remove or Hide.

- Removed variables are deleted from the variables list and the data is permanently removed from the chart.
- Hidden variables do not appear in the Used Variables box and the variable data does not display on the chart.

4. To add a variable from the Available Variables list, click it, then click Add.
   The variable appears in the folder you selected.

Tip: To display a previously hidden variable, click it in the Used Variables list, then click Show.
Note: You can also re-organize chart data using slice-and-dice mode. See Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Chapter 10 "Using Slice and Dice Mode".

Chart elements and how to format them

The illustration below shows the elements of a chart and what you can do to format them.

<table>
<thead>
<tr>
<th>Chart element</th>
<th>You can</th>
</tr>
</thead>
<tbody>
<tr>
<td>a. plot area</td>
<td>Change the color, border and shade</td>
</tr>
<tr>
<td>b. Y-axis labels</td>
<td>Apply text, number and date formats</td>
</tr>
<tr>
<td>c. Y-axis, numeric data</td>
<td>Change the scale and style of the</td>
</tr>
<tr>
<td>d. X-axis</td>
<td>Change the style</td>
</tr>
<tr>
<td>e. X-axis labels</td>
<td>Apply text and date formats</td>
</tr>
<tr>
<td>f. chart title</td>
<td>Change the color, border and shade</td>
</tr>
<tr>
<td>g. chart block</td>
<td>Display and format</td>
</tr>
<tr>
<td>h. data series</td>
<td>Change the color, border and shade</td>
</tr>
<tr>
<td>i. tick marks on X-axis</td>
<td>Display/hide, change the style and color</td>
</tr>
<tr>
<td>j. legend key</td>
<td>Apply text, background and border formats</td>
</tr>
</tbody>
</table>
Selecting chart elements

You set the formatting attributes for chart elements on the Format dialog box. There are different ways in which you can open this dialog box. You can:

1. Right-click on the chart element and select Format [chart element] from the menu.
   
   **Note:** This command [chart element] is dynamic — it refers to the chart element that you selected. For example, if you right-click on the chart axis, the menu command is Format Axis Label.

2. Double-click the chart element that you want to format.

3. Click a chart element, such as the slice of a pie chart, then click the [chart element] command on the Format menu.

   **Tip:** The dialog box displays for the relevant menu command. The name and tabs depend on the chart element that you first select.

Formatting the chart block

This section describes general formatting options.

Choosing chart elements to display

You can display and hide axes, walls, a legend or a title on your chart.

To do this:

1. Right-click on the chart and select Format Chart from the menu.
   
   The Chart Format dialog box opens.

2. Click the General tab.
Working with and Formatting Charts

Formatting the chart block

3. Set the required options as described below:

   - Type in a name for the chart
   - Place the chart on a new page
   - Repeat the current chart on every page of the report
   - Adjust the size of the chart to fit within the plot area on the report
   - Adjust the scale of the Y-axis to fit within the plot area

4. Click OK to save the settings and close the dialog box.

Formatting the chart block

The chart block is the term used to describe all the elements that make up a chart and the area that contains these elements. It includes the plot area, the title, the legend and the data series labels. You can resize the chart block and apply a border and shading to it.

To do this:

1. Right-click on the chart and click Format Chart from the menu.
2. Click the Border tab.
3. Select the options for the border style and color as illustrated below:

   - Click **None** to clear the style from all borders.
   - Apply the style to outer borders.
   - Select the borders you want to format.

4. Click **Apply** to save the settings.

5. Click the **Shading** tab.
Working with and Formatting Charts

6. Select the options to set the color for the chart as shown below:

- Click **None** to clear any shading. The background becomes transparent.
- Click the pattern or shade from the list.
- If you click **Clear**, you apply the Background color only.
- If you click **Solid**, you apply the Foreground color only.
- Click the other settings to mix the two colors.

### Resizing the chart block

You may need to resize your chart block. The easiest way to resize your chart is to use your mouse.

1. Press Alt + click inside the chart.
   A border with handles appears around the chart.

A handle appears on each border and corner of a selected chart.

2. Move the cursor over a handle.

3. When the cursor changes to a double-headed arrow, click the handle.
4. Drag the handle until the chart’s height or width reaches the required size.
   To adjust the height and width simultaneously drag a handle on a corner of the chart.
5. Release the mouse.
6. Repeat these steps to make further adjustments.

**Enlarging the plot area to the size of the chart block**

When you enlarge the size of the chart block, the plot area does not enlarge with the block proportionately.

When you reduce the size of the chart block, however, the chart’s plot area reduces proportionately.

To keep the plot area proportionate to the chart’s size when you enlarge the chart block:

1. Enlarge the chart.
2. Right-click on the chart and select **Format Chart** from the menu.
   The Chart Format dialog box appears.
3. Click the **General** tab.
4. Click **Adjust Plot Area to Chart Size** check box and click **OK**.
   The plot area increases in proportion to the size of the chart.

**Example:** Adjusting the plot area to the chart size — before and after

The first illustration shows the chart has been enlarged. The second illustration shows the result when you click **Adjust Plot Area to Chart Size** check box. The graph fits inside the enlarged area.
Formatting the plot area

The plot area displays the data series and the axes and is contained within the chart block:

You can format the plot area by applying color, shade or a border.

To format the plot area

1. Right-click in an empty part of the plot area. Do not click any other chart element.

2. Select Format Plot Area.

The Plot Area Format dialog box with the Pattern tab appears:

3. Select the formats that you want to apply and click Apply or OK.
Working with and Formatting Charts

Formatting the data series

Data series maps the data in a chart. In a pie chart, for example, a data series is a slice of the pie. In a line chart, it is a line, in a column chart, a column, and so on.

To format the data series

1. Right-click on the data series.
2. Click Data Series from the menu.
   
   The Data Series Format dialog box opens.

3. Make the required changes and click Apply or OK.

<table>
<thead>
<tr>
<th>For</th>
<th>You can format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column, Area, Pie, 3-D Line</td>
<td>Border, color, shading</td>
</tr>
<tr>
<td>2-D Line, XY Scatter</td>
<td>Line style, marker style</td>
</tr>
</tbody>
</table>

Deselect the Line check box to remove data series lines

Select the line color to apply

Select the line style to apply

Deselect Marker if you want to display no markers, but only lines

Select the marker style to apply

Figure 11-3: Data Series Format dialog box for 2-D Line and XY Scatter charts
Formatting each chart type

The following section describes formatting that you can only use on certain chart types.

Column charts

You can enhance the appearance of your column charts by modifying column spacing.

The chart on the right shows:
- Space between columns in the same set

The chart on the right shows:
- Overlapping columns in the same set
- Negative values

Changing the column format

To change the column chart settings:
1. Right-click on the chart and select **Format Chart** from the menu.
   The Chart Format dialog box displays.
2. Click the **Series** tab.
3. Select the group you want to format under Groups and Data series.
4. Under Group Type, click the column chart icon.
   - Type a value between 0 and 500 in the **Gap Width** box.
     The Gap Width places space between the columns.
   or
   - Type a value in the Overlap box.
     The Overlap places the columns on top of each other.
5. Click the **Show Negative Values** check box if you want to display negative values on your column chart.
6. Click **Apply** to view and verify the changes on the chart.
7. Click **OK** to save your changes and close the dialog box.

**Area charts**

There are elements that you can add to line and area charts to highlight different aspects of your data.

- **Drop lines**
  - Inserts lines that extend from a point in the chart down to the X-axis.

- **Up-down bars**
  - Inserts bars that extend from the highest value of one data series to the lowest value of another data series.
  
  **Note:** You can only display up-down bars in a chart that displays data for two measures.

- **High low lines**
  - Inserts lines that go from the highest to the lowest value for numeric data.
  
  **Note:** You can only display high-low lines in a chart that displays data for two measures.

**Displaying the area and line chart data series**

To change the area and line chart options:

1. Right-click on the chart and select **Format Chart** from the menu.
2. Click the **Series** tab in the dialog box that appears.
3. In the **Groups and Data series** pane, click the line or area chart icon.
4. Click the options you want to display on your chart:
   - High-Low Lines, Drop Lines and/or Up-Down Bars for line charts.
   - Drop Lines for area charts.
5. Click **Apply** to display the changes on the chart.
6. Click **OK** to close the dialog box and save your changes.
Three-dimensional charts

The illustration below shows the elements specific to a three-dimensional chart and what you can do to format them:

- a. Change the color, border and shade of the side wall.
- b. Change the color, border and shade of the back wall.
- c. Adjust the 3-D view and rotate it.
- d. Display the Z-axis, and format its axis labels.
- e. Change the color, border and shade of the floor.

Formatting chart walls

In some three-dimensional charts, you can display and format three walls: the back wall, side wall and floor.

To display walls:
See “Choosing chart elements to display” on page 249.

To format walls:
1. Right-click on the wall you want to format.
2. Click Format Wall from the menu.

The Wall Format dialog box appears. It contains the Pattern tab only. For information on how to apply formats using this dialog box, see page 254.
Formatting the three-dimensional view

A chart's three-dimensional view consists of its elevation, rotation and ratio. With some chart types, you can also adjust the chart's depth and thickness. When you create a three-dimensional chart you may need to experiment with these settings to get the best possible view.

To set these options:
1. Right-click on the chart and select **Format Chart** from the menu.
2. Click the **Series** tab.
3. Click **3-D view**.
4. Change the settings as described below and click **OK** or **Apply**.

Defining the three-dimensional view of a chart

<table>
<thead>
<tr>
<th>Series tab</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>3-D view settings</td>
<td></td>
</tr>
<tr>
<td><strong>Elevation box</strong></td>
<td>Set a value by clicking <strong>Up</strong> or <strong>Down</strong>, or Enter a value between -90 and 90. Elevation is measured in degrees.</td>
</tr>
<tr>
<td><strong>Rotation box</strong></td>
<td>Set a value by clicking <strong>Up</strong> or <strong>Down</strong>, or Enter a value between 0 and 360. Rotation is measured in degrees. The value you set rotates the chart horizontally.</td>
</tr>
<tr>
<td><strong>Height % of Base box</strong></td>
<td>Enter a value between 5 and 500. The value corresponds to the ratio between the height and width of the chart. For example, 200% means that the chart will be twice as high as it is wide (from left to right).</td>
</tr>
<tr>
<td><strong>AutoScale</strong></td>
<td>Click AutoScale to set the scale of the chart to cover the plot area. <strong>Note:</strong> The AutoScale does not apply for pie charts.</td>
</tr>
</tbody>
</table>

**Note:** For pie charts, the angle you set in the Rotation box is the angle at which the first slice of the pie begins. An angle between 0 and 360, begins clockwise from top.

Defining the depth and thickness of a three-dimensional chart.

1. In the **Chart Depth** box, type a value between 20 and 2000.
   The value you type determines the depth of the chart floor. The higher the value, the deeper the floor.
2. In the **Gap Width** box, type a value between 0 and 500. This value determines the distance in depth between the data series displayed in the chart.

**Note:** This feature is not available for pie charts.

### Formatting chart axes and axis labels

The horizontal and vertical axes of a chart are called the *X*-axis and the *Y*-axis respectively.

Matrix charts contain a third axis, the *Z*-axis.

You can work on chart axes and axis labels in the following ways:

- format the text, numbers or dates of the axis labels
- change the orientation of the axis labels (horizontally, vertically, etc.)
- apply different axis styles and colors
- display tick marks, and change their style
- change the scale of the *Y*-axis
Axis labels

1. Right-click on the axis.
2. The illustration below shows a chart with the Y-axis selected.

3. Click Format Axis Label from the menu.
   The Axis Format dialog box opens.
   • If you selected the Y-axis, the dialog box contains five tabs, as shown below.
   • If you selected the X-axis or the Z-axis, the dialog box does not contain the Scale tab, as this tab is used to change the scale of the Y-axis only.

   ![Axis Format dialog box]

   • Use the Number tab to edit number and date formats on the axis labels.
Working with and Formatting Charts

Formatting chart axes and axis labels

- Use the **Alignment** tab to change the orientation of the axis labels:
  - Select an orientation, then click Apply.
  - Deselect Tick Mark if you do not want to display a tick marks.
  - Position the tick marks by clicking an option
  - Select the line style to apply to the chart axes.
  - Click to display the color palette and select a color to apply.
  - Deselect Line if you want to hide the axis lines.

- Use the **Font** tab to apply different text formats to the axis labels.
- Use the **Pattern** tab to display and edit tick marks. You can also change the axes' line style and color:
  - Click the **Scale** tab and enter changes to the scale of the Y-axis. See below.
Axis scale

The scale of a chart determines the minimum and maximum values on the chart's Y-axis, where numeric data such as Revenue is plotted. The scale also includes the intervals between the values on the axis. You can change the scale to broaden or narrow the range of values displayed.

To define the scale of a chart

1. Click the axis label of the Y-axis.
   This can be the primary or the secondary axis.
2. Click Axis Labels on the Format menu.
3. Click the Scale tab.
4. In the Value (Y) Axis Scale box, click any of the following options:
   - Minimum, displays the lowest value as the minimum value on the Y-axis. To specify a different value, type the minimum value in the box.
   - Maximum, displays the highest value as the maximum value on the Y-axis. To specify a different value, type the maximum value in the box.
   - Major Unit, sets an automatic interval between the values on the Y-axis. To specify the interval you want, type a value in the box.
5. In the Scale box, click Decimal for a scale in decimal numbers, or Logarithmic for a scale to the power of 10, based on the range of data plotted in the chart.
6. Click Apply or OK.

Logarithmic scale

A logarithmic scale enables you to display very low values, or values that cover a broad range.

If you enter decimal values for the chart's scale and then click Logarithmic, remember to edit the values accordingly.

Negative or null values are not displayed in logarithmic charts. The value of the Major Unit option must be to the power of 10. If you enter a value to a different power, it will be rounded up to the nearest power of 10.
Scaling charts in Master/Detail reports

In a Master/Detail report a chart is displayed for each value of the master in a separate section. The range of values may be different in each section. You can use different scaling for each chart or for each section so that the values on the chart display differently.

To do this:
1. Right-click on one of the charts in the Master/Detail report.
2. Click **Format Chart** from the menu.
3. Click the **General** tab.
4. Click the **Adjust Scale to Value Range** check box.
Helping users to read your chart

You can make your charts easier for your audience to read and interpret by adding information, for example a chart title or a legend. These are described in the following section.
Chart title

A chart title is a cell in which text is displayed. You can edit and format the text, as well as move the title and format the cell.

Adding a chart title
1. Right-click anywhere inside the chart and select Insert Title from the menu.
2. Double-click the chart title.
   The default title is highlighted
3. Type in the name and press Enter.

Positioning the chart title
• Click inside the chart title and drag it with your mouse to the required position.

Formatting the chart title
You can apply custom formats to the chart title.
1. Right-click inside the chart title.
2. Click Format Title from the menu.
   The Title Format dialog box appears.
3. Make your changes on the four tabs: Number, Alignment, Font and Pattern.
4. Click OK.

Resizing the chart title
If the text in the chart title does not fit in the title cell, you can resize it.
1. Click the title.
   A hatched border with handles appear around it.
2. Use the handles to re-size the cell.

Note: If you drag the title cell’s border beyond a chart boundary, Desktop Intelligence automatically enlarges the chart accordingly.

Deleting the chart title
• Right-click on the chart title and select Delete from the menu.
Chart legend

The chart legend explains what the data in the chart represents. It is a rectangular box, containing the names of the variables (the legend text) and their corresponding color, shade and border (the legend key):

Displaying a chart legend

• Right-click on the chart and select **Insert Legend** from the menu.

Formatting and moving the legend

You can format the legend by changing its border, color and shade. You can also move the legend to a different place in the chart. To do so:

1. Click the border of the legend.
2. Click **Legend** from the **Format** menu.

The Legend Format dialog box appears:

3. Click the **Placement** tab and select an option to reposition the legend within the chart area.
4. Click the **Pattern** tab and select the border style and color, and the pattern and color.
5. Click the **Alignment** tab and select the alignment of the legend text.
6. Click the **Font** tab and select the font for the legend text.
7. Click **OK** or **Apply**.

The modified legend appears in its new position, with its new formats.
Tip: You can also move the chart legend by clicking it and dragging it.

**Formatting the legend key**

You can change the border, shade and color of the legend key. The formats that you apply are immediately visible in the chart’s data series. For example, if you change the color of a square in the legend from yellow to red, the corresponding data in the chart is also changed to red.

- Right-click the legend key and select **Legend Key** from the menu.
  
  The Legend Key Format dialog box appears. It contains the Pattern tab.

**Formatting the legend text**

You can change the font attributes or format the legend text by (for example, font, font size), and by realigning it. The formats that you apply only appear in the legend text, not in the text of the chart’s axis labels.

1. Right-click the legend text and select **Format Legend Text** from the menu.
  
  The Legend Text Format dialog box appears. It contains Alignment and a Font tab.

2. Make the required settings.

3. Click **Apply** to apply the changes on each tab and maintain the dialog box open.

4. Click **OK** to save all the changes and close the dialog box.
  
  The new formats appear in the legend text.

**Resizing the legend**

1. Select the Legend.
  
  A hatched border with handles appears around it.

2. Use the handles to re-size the legend box.

**Deleting the legend**

- Right-click on the legend and select **Delete** from the menu.
Data labels

Data labels appear next to a chart’s data series, for example next to each slice of a pie chart. They indicate the exact values or percentages of the data series. In the pie chart illustrated below, the data labels show revenue share per resort:

Displaying data labels

1. Right-click the data series (for example, a slice of a pie chart) and select Insert Data Labels from the menu.

The Data Labels dialog box appears:

   ![Data Labels dialog box]

   a. Displays the exact value, for example, $10,235.
b. Displays the percentage of each data series.
c. Displays the “name” of the data series, for example, Revenue.
d. Displays the “name” and the percentage of each data series.

2. Click the data label type you want and click OK.

Formatting data labels

You can apply specific number and text formats to data labels, as well as realign them. You can also change data labels, or remove them.

1. Right-click on the data label and select Format Data Labels from the menu.

The Data Labels Format dialog box appears.
2. Edit the formats specific to each tab: Number, Alignment, and Font.

**Changing or removing data labels**

1. Right-click on the data label and select **Insert Data Labels** from the menu.
   The Insert Data Labels dialog box appears.
2. To remove the data labels, click **None**.
3. Click the type of data label that you want to display and click **Apply**.
4. Click **OK**.

**Gridlines**

Gridlines help you to see a chart’s values more easily. They begin at the chart’s axes and extend across its walls.

![Chart with Gridlines](chart-with-gridlines.png)

**Note:** You cannot display axes and gridlines in pie charts.

**Displaying gridlines**

1. Right-click inside the chart and select **Display Axes/Gridlines** from the menu.
   The Axes and Gridlines dialog box appears.
2. Set the required options and click **Apply**.
3. Click **OK** to close the Axes and Gridlines dialog box.

Formatting gridlines

You can format gridlines by changing their color and line style.

1. Right-click on the axis or gridline and select **Format Axis Label** from the menu.

   The Axis Label Format dialog box appears

2. Click the **Pattern** tab.

   For information on how to use this tab, refer to page 262.

**Note:** You can only format one axis and its associated gridlines at a time. For example, if you click an X-axis gridline, the formats you select in the Axis Label Format dialog box apply to the X-axis and its gridlines only.
Using different chart types on one chart

A useful feature in Desktop Intelligence is that you can display data in more than one way on the same chart. For example, you can display some data in a line and other data in columns in the same chart as shown below. This allows you to make a distinctive visual comparison between data.

Using groups on charts

In order to use different chart types, Desktop Intelligence uses groups. You add the variables you want to display on the chart to the different groups and then assign different chart types to different groups. To do this:

1. Right-click on the chart and select **Format Chart** from the menu.
The Chart Format dialog box opens.

2. Click on the **Series** tab.
   By default, a chart has only one group.

3. Click **Add** to add a new group.
   A new group is added.

4. Right-click on the **Groups and Data Series** pane and select **Variables** from the menu.

5. Click or create the variable you want to add, then click **Insert**.
   The new variable appears in the group folder.

6. To view the variables now in the group, click the plus (+) sign.
Using different chart types on one chart

Tip: If the variable you want to use in the group is already displayed in the Series tab, you can drag it to the new group.

7. Select the new group and click a chart type and subtype.

8. Click OK to close the dialog box and display the result on your chart.

Choosing the type of chart

When you choose a chart type for a group, certain charts have sub-types from which you can choose. Also bear in mind the types of charts you want to combine as some combinations give better results than others. The table below gives you some recommendations.

The Group Type offers only one possibility if you selected a scatter chart or a pie chart. If you selected an area, column or line chart, two-dimensional (2-D) or three-dimensional (3-D), you can choose between a standard chart, a stacked chart or a 100% stacked chart.

<table>
<thead>
<tr>
<th>Chart Type</th>
<th>Available Subtypes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area/line/column</td>
<td>Standard, stacked chart or 100% stacked area, line or column chart respectively</td>
</tr>
<tr>
<td>Scatter</td>
<td>Standard scatter</td>
</tr>
<tr>
<td>Pie</td>
<td>Standard pie</td>
</tr>
</tbody>
</table>

The following table shows the chart combinations that give the best results.

<table>
<thead>
<tr>
<th>Group 1 chart type</th>
<th>Group 2 chart type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column</td>
<td>Line</td>
</tr>
<tr>
<td>Column</td>
<td>Area</td>
</tr>
<tr>
<td>3-D Column</td>
<td>3-D Line</td>
</tr>
<tr>
<td>3-D Column</td>
<td>3-D Area</td>
</tr>
<tr>
<td>Scatter</td>
<td>Scatter</td>
</tr>
<tr>
<td>Pie</td>
<td>Not possible</td>
</tr>
</tbody>
</table>

Using a secondary Y-axis

If you have two measures on a chart you can use a secondary Y-axis. This allows you to display different values on each of the axes and different scales which can make your chart more readable.

The primary axis is displayed on the left, the secondary axis on the right.
You can display all the groups in a chart on the primary axis or all on the secondary axis. However, you will often obtain the best result by placing one group on the primary axis and one group on the secondary axis.

**Example:** Comparing revenue and quantity sold in a chart

In this chart, a clear and effective visual comparison is made by showing the difference in a column chart between projected and actual revenue and then using a line chart to compare quantity sold.

To create this type of chart:

Use the Insert Chart wizard to select the variables. The chart has four variables: Quarter, Projected Sales Revenue, Sales revenue and Quantity sold. Choose a simple column style from the wizard.
A different colored column represents each measure. You want to represent the different units of measure, since revenue is calculated in dollars and quantity sold in number of units. The default values that display on the Y-axis represent dollars so you cannot even see the Quantity sold column on the chart.

You can improve this chart in two ways:

- use a different chart type for quantity sold and for revenue
- display data on two axes, one axis with values in dollars and the other with number of units

To make these improvements:

1. Right-click on the chart and select **Format Chart** from the menu.
2. Click on the Series tab of the Chart Format dialog box.
3. Under the Groups and Data Series, open the Group 1 list.

   You see that, by default, all the measures have been placed in the same group and are on the same axis.

4. Drag the **Quantity sold** variable from Primary Y-axis to the Secondary Y-axis.

   A new group is created on the Secondary Y-axis.

5. Select **Group 2** and click **Line** from the Group Type list.
The icon next to the Group 2 list is a line chart icon.

6. Click **OK** to close the dialog box and see the result.

Revenue and Quantity sold display on different chart types. The difference between actual and projected revenue and the accompanying progression in quantity of units sold is more clear. To further enhance your chart set an overlap for the two columns and format the Primary-Y axis labels to display the dollar symbol.
Deleting charts

First select the chart before deleting

1. Click a blank space outside the chart to select it.
   The chart is only partially selected if you see black points on part of the chart. Only this part of the chart deletes, unless you reselect the entire chart.

2. Press Alt and click once inside the chart.
   A hatched gray border appears around the chart. You should not see any black points anywhere on the chart:

3. Right click and select Delete from the menu.
   The chart disappears.

To select two or more charts

1. Click a blank space in the report.
2. Drag the mouse until you have covered part of each chart you want to select.
3. Release the mouse.
   A hatched gray border appears around each selected chart.
Displaying a calculation on data in charts

In the report illustrated below, the share of revenue per resort in FY95 is shown in a pie chart. The calculation on the data in the chart, total revenue for the year, is shown in a cell above the chart:

You can display a calculation on data in a chart in the following way:

1. Insert a cell in the section where you want the calculation to appear.
2. Type an equal to sign (=).
3. If you are using a variable to make the calculation, type:
   - a less than sign (<)
   - the name of the variable
   - a greater than sign (>).
   For example, to display the Revenue variable in the cell, type =<Revenue>.
4. If you are using a formula to make the calculation, type the formula after the equal (=) sign.
5. Press Enter to view the result of the calculation.

Tip: You can also drag a calculation from a table or a crosstab and drop it in the section where the chart appears. For more on calculations, see Desktop Intelligence User’s Guide: Accessing Data and Data Analysis, Creating Calculations.
Working with and Formatting Charts

Displaying a calculation on data in charts
Including Graphics and Other Objects in Reports
Including Graphics and Other Objects in Reports

Overview

Desktop Intelligence works with data from and in other applications. This means that you can bring in data and pictures from other Windows applications, and display these in Desktop Intelligence reports. You can also transfer data from Desktop Intelligence reports to other applications, such as Microsoft Excel.

Desktop Intelligence supports Microsoft Object Linking and Embedding version 2 (OLE 2). This feature creates objects from files that come from other applications that also support OLE 2. An OLE 2 object can be a word processing file, a spreadsheet, a picture, and so on.

You can:

• embed an OLE 2 object in a Desktop Intelligence report, which means that the object physically resides in the report
• link OLE 2 objects, which means that the data or picture remains in its native application and is displayed in Desktop Intelligence thanks to a dynamic link
• link or embed Desktop Intelligence reports in other applications that support OLE 2

Desktop Intelligence also supports the Microsoft Dynamic Data Exchange (DDE) feature. This feature enables you to use data from Desktop Intelligence reports in other applications. DDE ensures that the data in the remote application is dynamically updated when the data in the host application, that is, Desktop Intelligence, changes.

Note: You can also exchange data from Desktop Intelligence with other applications by exporting data to different file formats. For example, you can export the results of a query to dBASE or Microsoft Excel format.

Using data and pictures from other applications

You can use data and pictures from other applications in Desktop Intelligence, for example, objects that you or other users created in remote applications. A Microsoft Word document is an object that you can insert in a Desktop Intelligence report.
Inserting data and pictures from other applications

Object Linking and Embedding (OLE 2), developed by Microsoft Corporation, enables you to share data and pictures between Windows applications. Desktop Intelligence supports OLE 2, which means that you can insert OLE 2 objects inside Desktop Intelligence reports, and use Desktop Intelligence reports as OLE 2 objects in other applications.

What is the difference between linked and embedded objects?

When you link or embed an object in a Desktop Intelligence report, you display an object from another application. The differences between linking and embedding are as follows:

- When you link an object, it does not physically reside in the Desktop Intelligence report. It is represented there, but the link allows it to remain in its native application. Desktop Intelligence updates the object's representation in the Desktop Intelligence report.
  - For example, if you insert a picture with a link, then modify the picture in its native application, you also modify the picture in Desktop Intelligence.
- When you embed an object, it physically resides in Desktop Intelligence.

How do you insert an object in a report?

You insert objects in reports by clicking Object from the Insert menu.

The Insert Object dialog box appears and enables you to:

- click the file that corresponds to the object that you want to insert
- start a remote application, for example Microsoft Word, in which you can create an object to insert

Note: To insert an object in a report, you must first select a cell. In any case, Desktop Intelligence prompts you to insert a cell in the active section and displays the object in the cell.

To create and insert a new object

1. Click the cell where you want the object to appear.
2. Click Object from the Insert menu.
   The Insert Object dialog box that appears,
3. Click Create New.
Including Graphics and Other Objects in Reports

Using data and pictures from other applications

4. Click the type of object you want to create from the Object type list, as shown:

5. Click OK.

Depending on the type of object you want to create, one of two things occurs:

- If the application you use to create the object supports OLE 2, the application appears in the cell you select. The application becomes active and replaces Desktop Intelligence in the title bar.
- If the application does not support OLE 2, the object opens on top of the Desktop Intelligence window.

6. Create the object in the remote application.

7. Return to Desktop Intelligence:

- If the remote application supports OLE 2, you simply have to click outside it.
- If the application does not support OLE 2, select Exit.

The object appears in the cell you selected.

To insert an existing object

1. Select the cell where the object will appear, then select Object from the Insert menu.
2. In the Insert Object dialog box, click Create from File.

![Insert Object dialog box]

3. Locate the file (object) you want to insert, by entering a path in the File text box, or click Browse to select the file.

4. Click Link if you want to link the object. If you do not click Link, you embed the object in the report.

5. Click OK to close the dialog box.

The object appears in the cell you selected.

Note: If you do not click a cell before selecting Object from the Insert menu, Desktop Intelligence invites you to create a new cell in which the object will appear.

Tip: Avoid saving reports as PDF documents that contain OLE 2 objects as you may encounter problems viewing the OLE 2 objects.

To insert a logo or other image in a report and save the report as a PDF document or share it via Enterprise Server products installed on UNIX, save the image as a bitmap (.bmp). You can do this in Microsoft Paint or a similar application.

### Editing inserted OLE 2 objects

Once you have inserted an object in a Desktop Intelligence report, you can edit the object. You can edit the:

- object itself by calling the application in which it was created. You can then work on the object’s file, then save it. The new version of the object is displayed in Desktop Intelligence.
- link between Desktop Intelligence and the object’s source file. This is the case for objects that you insert with a link, rather than objects that you embed.
Including Graphics and Other Objects in Reports

**Using data and pictures from other applications**

**Tip:** If you move the object’s file to a different location, you should edit the link. If you do not, the link is lost and the object is no longer displayed in the report.

There are two ways to edit objects.

**Editing an inserted object**

OLE 2 enables you to edit an object within Desktop Intelligence. This feature is only available if the application in which the object was created supports OLE 2.

If in-place editing is not available, you can open the object in its native application. You can then edit the object, save its file, and return to Desktop Intelligence, where the edited object is displayed.

**To edit an object in place**

When you edit an object in Desktop Intelligence, the commands and toolbars you need to edit the object appear. The application name in the title bar changes from Desktop Intelligence to the name of the remote application.

You can edit an object in Desktop Intelligence in one of three ways:

- double-click the object in the report
- click the object to select it, then click **Edit** from the **Edit** menu
- right-click the object then click **Edit Object** from the menu

A hatched border appears around the object. When you finish editing the object, click anywhere outside the object’s borders to return to the Desktop Intelligence, and save the active document.

**To edit an object in its native application**

If the object’s application does not support editing within Desktop Intelligence, you must open the application when you want to edit the object. You can do this in three ways:

- double-click the object.
  
  The application used to create the object opens.
- click the object once, then click **Object** then **Open** from the **Edit** menu.
- right-click the object then click **Object** then **Open** from the menu.

  The object appears in its native application.

To return to Desktop Intelligence, click **File** then **Save** then **Exit** to quit the application. The edited object appears in the report.
Using pictures in reports

You can display pictures in Desktop Intelligence reports. You can display a picture in a cell, or use a picture as a page background on every page of the report.

The pictures that you use can be static files, or they can be objects enabled by OLE 2 (Object Linking and Embedding).

Inserting a picture in a cell

This section describes how to insert static pictures in report cells. Examples of inserting static pictures in cells include using a logo in a title cell at the top of a report, or a picture of a product that features in a report.

To insert a static picture in a new cell:

1. Click in a blank part of the report.
2. Select Picture from the Insert menu.
3. Click in a blank part of the report once again.
4. Click the mouse, then drag to draw the cell where you want the picture to appear.

To insert a static picture in an existing cell:

1. Click inside the cell.
2. Click Picture from the Insert menu.
   The Open dialog box appears.
3. Select the picture’s file.
4. Click Open.
   The picture appears in the cell.

Tip: You can insert a picture by double-clicking inside a cell and typing the picture’s path and file name (for example, c:\pictures\picture.bmp). Click inside the cell and select Cell from the Format menu. In the Number tab of the Cell Format dialog box, select the Image category and Bitmap or TIFF format. When you click OK or Apply, the picture appears in the cell.
Using prompts in reports

You can include other types of information in your Desktop Intelligence report that provides additional information to that in your report sections. This example tells you how to insert an ActiveX prompt that takes advantage of internet technology.

Example: Inserting an active-X ticker, in your Desktop Intelligence report

You want to insert a cell that displays the stock quotes live. You know one by Microsoft, called MoneyCentral Quotes at this web address:

To insert the object in your report:

1. Insert a large cell in your report in the place where you want the ticker to display.

2. Enter the following code inside the cell (not in the formula editor):

   ```html
   <OBJECT type="application/x-oleobject"
           classid="clsid:52A0E293-85E8-11D2-BB22-00104B0EA281"
           Codebase="http://fdl.msn.com/public/investor/v7/ticker.cab#version=7,1999,1104,1" width=100%
           height=34>
   <param name="ServerRoot" value="http://moneycentral.msn.com"><param name="NewsTarget"
   value="_newstop">
   <param name="DefaultCategories" value="Commerce">
   <param name="SpecialsServerURL" value="http://ads.msn.com/ads/invtic/specials.txt">
   <param name="InvestorHeadlines" value="http://moneycentral.msn.com/articles/data/InvHead.asp"></OBJECT>
   ```

   **Note:** This code displays the ticker at http://moneycentral.msn.com/investor/home.asp.

3. Click Yes to install the ticker on your browser, if a dialog box appears asking if you want to install the MSN Investor.

4. Right click on the cell and select Format cell from the menu.

5. Click the Number tab and click the Read as HTML check box.

6. Select Save as HTML from the File menu.

7. Enter a name for the file and save it in your User Docs folder.

8. From your browser window, open the HTML report. The ticker displays the stock quotes.
Business Objects
Information Resources
Documentation and information services

Business Objects offers a full documentation set covering its products and their deployment. Additional support and services are also available to help maximize the return on your business intelligence investment. The following sections detail where to get Business Objects documentation and how to use the resources at Business Objects to meet your needs for technical support, education, and consulting.

Documentation

You can find answers to your questions on how to install, configure, deploy, and use Business Objects products from the documentation.

What’s in the documentation set?

View or download the Business Objects Documentation Roadmap, available with the product documentation at http://www.businessobjects.com/support/. The Documentation Roadmap references all Business Objects guides and lets you see at a glance what information is available, from where, and in what format.

Where is the documentation?

You can access electronic documentation at any time from the product interface, the web, or from your product CD.

Documentation from the products

Online help and guides in Adobe PDF format are available from the product Help menus. Where only online help is provided, the online help file contains the entire contents of the PDF version of the guide.

Documentation on the web

The full electronic documentation set is available to customers on the web from support web site at: http://www.businessobjects.com/support/.

Documentation on the product CD

Look in the docs directory of your product CD for versions of guides in Adobe PDF format.
Send us your feedback

Do you have a suggestion on how we can improve our documentation? Is there something you particularly like or have found useful? Drop us a line, and we will do our best to ensure that your suggestion is included in the next release of our documentation: documentation@businessobjects.com.

**Note:** If your issue concerns a Business Objects product and not the documentation, please contact our Customer Support experts. For information about Customer Support visit: http://www.businessobjects.com/support/.

Customer support, consulting and training

A global network of Business Objects technology experts provides customer support, education, and consulting to ensure maximum business intelligence benefit to your business.

How can we support you?

Business Objects offers customer support plans to best suit the size and requirements of your deployment. We operate customer support centers in the following countries:

- USA
- Australia
- Canada
- United Kingdom
- Japan

Online Customer Support

The Business Objects Customer Support web site contains information about Customer Support programs and services. It also has links to a wide range of technical information including knowledgebase articles, downloads, and support forums.

http://www.businessobjects.com/support/
Looking for the best deployment solution for your company?

Business Objects consultants can accompany you from the initial analysis stage to the delivery of your deployment project. Expertise is available in relational and multidimensional databases, in connectivities, database design tools, customized embedding technology, and more.

For more information, contact your local sales office, or contact us at:
http://www.businessobjects.com/services/consulting/

Looking for training options?

From traditional classroom learning to targeted e-learning seminars, we can offer a training package to suit your learning needs and preferred learning style. Find more information on the Business Objects Education web site:
http://www.businessobjects.com/services/training
# Useful addresses at a glance

<table>
<thead>
<tr>
<th>Address</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Business Objects product information</strong></td>
<td>Information about the full range of Business Objects products.</td>
</tr>
<tr>
<td><a href="http://www.businessobjects.com">http://www.businessobjects.com</a></td>
<td></td>
</tr>
<tr>
<td><strong>Product documentation</strong></td>
<td>Business Objects product documentation, including the Business Objects Documentation Roadmap.</td>
</tr>
<tr>
<td><a href="http://www.businessobjects.com/support">http://www.businessobjects.com/support</a></td>
<td></td>
</tr>
<tr>
<td><strong>Business Objects Documentation mailbox</strong></td>
<td>Send us feedback or questions about documentation.</td>
</tr>
<tr>
<td><a href="mailto:documentation@businessobjects.com">documentation@businessobjects.com</a></td>
<td></td>
</tr>
<tr>
<td><strong>Online Customer Support</strong></td>
<td>Information on Customer Support programs, as well as links to technical articles, downloads, and online forums.</td>
</tr>
<tr>
<td><a href="http://www.businessobjects.com/support/">http://www.businessobjects.com/support/</a></td>
<td></td>
</tr>
<tr>
<td><strong>Business Objects Consulting Services</strong></td>
<td>Information on how Business Objects can help maximize your business intelligence investment.</td>
</tr>
<tr>
<td><a href="http://www.businessobjects.com/services/consulting/">http://www.businessobjects.com/services/consulting/</a></td>
<td></td>
</tr>
<tr>
<td><strong>Business Objects Education Services</strong></td>
<td>Information on Business Objects training options and modules.</td>
</tr>
<tr>
<td><a href="http://www.businessobjects.com/services/training">http://www.businessobjects.com/services/training</a></td>
<td></td>
</tr>
</tbody>
</table>
Index

Numerics

2000
- year 32

2-D charts
- formatting line charts 255
- using Z-axis 244

3-D charts
- formatting walls and floor 258
- using Z-axis 245, 258

3-D view
- formatting 259

A

accelerator keys 27

across edge
- of crosstab 166, 215

across tabs
- defining breaks 191

adding
- breaks 190
- columns to tables, crosstabs 180
- rows to crosstabs 180

summary information 48

adding data to reports
- see also BusinessObjects User’s Guide

Accessing Data and Data Analysis 166

Adjust Scale to Value Range
- option 264

aligning
- axis labels 262
- blocks 147
- cell contents 226
- cells 147

and date 134

Apply Standard Style
- command 103

applying
- standard report styles 103

value-based breaks 196

area charts
- formatting 255

AutoFormats, for charts 242

autoscale
- setting on 3-D charts 259

Avoid Duplicate Rows Aggregation
- table option 214

axes
- formatting 260

formatting numbers on 261

hiding 270

axis labels
- applying line styles 262

- applying text formats 262

- applying tick marks 262

- changing orientation 262

- defining scale 262

- formatting 262

illustrated 260

B

back wall
- on 3-D chart, formatting 258

background
- color, setting 252

- shading, making transparent 252

blank reports
- creating 37

blocks
- aligning 147

- chart, formatting 250

- chart, resizing 252

- formatting 202

- formatting borders 206

- moving 149

- positioning 144

- setting conditions to hide 154
## Index

**body** 216  
- in crosstabs 166  
- selecting crosstab body 217  
- selecting table body 216  

**borders**  
- applying to chart walls 258  
- borders toolbar 230  
- formatting cell borders 230  
- formatting chart borders 250  
- formatting crosstab borders 206  
- formatting section borders 206  
- formatting table borders 206  

**breaks** 200  
- adding 190  
- applying on more than one variable 191  
- Breaks dialog box, illustrated 191  
- center across break 228  
- changing break level 191  
- custom 196  
- defining 188  
- editing 190, 191  
- editing on across tab 191  
- editing on down tab 191  
- folding 193  
- inserting 191  
- inserting on a page 127  
- managing over multiple pages 200  
- opening Breaks dialog box 190  
- removing 190, 191  
- setting standard report style 101  
- showing headers and footers 192  
- value-based breaks 191, 196  

**Business Objects**  
- consulting services 292, 293  
- support services 291  
- training services 292, 293, 293  

**BusinessObjects**  
- logging in from Start menu 17  
- starting from InfoView 19  

**C**  
- calculation contexts  
  - see also, BusinessObjects User’s Guide  
- Accessing Data and Data Analysis 188  
- calculations  
- using on charts 279  

**cells**  
- adding hyperlinks to 223  
- aligning 147  
- aligning contents 226  
- copying formatting only 218  
- editing free-standing 184  
- formatting 232  
- formatting backgrounds 231  
- formatting borders 230  
- free-standing 182  
- hiding 152  
- indenting content 227  
- inserting 180, 182  
- inserting pictures 287  
- master 115  
- merging 228  
- moving 149  
- positioning 144  
- repeat on every page 126  
- resizing 211  
- selecting 180  
- setting conditions to hide 154  
- setting standard report styles 103  
- starting on new page 126  
- wrapping contents 229  

**character limit**  
- report tab 39  

**chart legend key**  
- formatting 268  

**charts**  
- autoformatting 240  
- avoiding page breaks in 250  
- axis labels 260  
- creating 238  
- data series 255  
- deleting 278  
- displaying data labels 269  
- displaying gridlines 270  
- displaying title 266  
- formatting 250, 259, 260, 262, 262, 269  
- hiding 152  
- hiding axes 270  
- inserting data labels 269  
- making calculations 279
Index

matrix 243
plot area 249
positioning 144
reorganizing data on axes 243
repeat on new page 126
repeating on every page 250
resizing 252
selecting chart elements 249
setting chart type 274
switching between chart types 241
turning into a table 240
turning to tables, crosstabs 241
types, illustrated 234
using groups 272
using New Chart Wizard 238
using preset formats 242
walls 255
what elements make a chart 248
XY scatter 255
Z-axis 258

clearing
master cells in master/detail reports 123
colors
applying to cell backgrounds 231
applying to cell borders 230
applying to charts 255
column charts
displaying negative values 256
formatting columns 255
setting column overlap 256
setting gap between columns 256
columns
adding to tables, crosstabs 180
gap setting 256
inserting 180, 182
naming 180
resizing 180, 211
selecting 180
selecting in tables and crosstabs 178
table and crosstab, copying 169
table and crosstab, deleting 171
table and crosstab, swapping 168
conditional formatting 152

conditions

desktop intelligence reporting techniques and formatting user's guide 297

consultants, Business Objects 292
Copy All command (Edit menu) 90
copying
and pasting data from BusinessObjects 89
and pasting data to an Office application 89
cell formatting 170
data to other applications 88
tables and crosstabs 181
corporate categories
viewing document properties 51
corporate documents
viewing corporate categories 51
viewing properties 51
creating
blank reports 37
reports 37
creating calculations
see also, BusinessObjects User's Guide
Accessing Data and Data Analysis 188
cross tabs
across edge 166
across edge display 215
adding cells, columns, rows to 180
building using drag and drop 172
copying 181
deleting 181
displaying charts as 241
down edge 166
down edge display 215
editing 177
formatting corners 208
hiding 152
illustrated 166
insert wizard 174
inserting 172
positioning 144
repeat on every page 126
selecting 178
setting standard report style 100
showing headers and footers 212
starting on new page 126
currency
default format and regional settings 31
Index

style 219, 220
custom breaks 196
customer support 291
customizing block background shading 252
breaks on data 196
standard report styles 97

data accessing, see also BusinessObjects User’s Guide - Accessing Data and Data Analysis 87
adding to tables 170
DDE see dynamic data exchange
dragging and dropping 173
moving from axis to axis on charts 247
pivoting on charts 243
removing from chart display 247
data labels changing 269
deleting 269
displaying on chart 269
formatting 269, 269
data providers updating 68
data series defined 255
formatting on charts 255
Data tab Report Manager 33
dates applying formats to cell contents 219
custom formats 221
deleting formats 223
formatting 219, 223
inserting in reports 134
setting 32, 88
DDE 88
DDE see dynamic data exchange
default
file extension for documents 57
default. ret
file, about 95
file, distributing 104
recreating 105
deleting charts 278
data from charts 247
master/detail cells and sections 121
number and date formats 223
reports 39
table and crosstab columns 171
table and crosstab rows 171
tables and crosstabs 181
delimiters displaying 148
displaying margin 148
displaying section 148
section 129
depth setting on 3-D charts 259
display across edge 215
down edge 215
displaying calculations in charts 279
chart title 266
data labels on charts 269
gridlines on charts 270
page numbers in reports 134
Report Manager 33
reports inside documents 39
section header and footer 205
summary information 46
toolbars 22, 115
displaying BusinessObjects setting workspace size 28
document
summary information 46
document properties viewing 51
documentation
feedback on 291
on product CD 290
on the web 290
roadmap 290
documents 16
finding and retrieving 49
password protecting 58

refreshing 68

.rep file extension 57

.rtf file extension 61

saving as Excel 65

saving as PDF files 61

saving as text files 61

saving automatically 58

saving for all users 57

saving in html format 63

saving in rich text format 61

setting up automatic refresh 58

txt file extension 61

down edge

down tab

defining breaks 191

drag-and-drop

moving blocks 149

moving cells 149

moving cells, columns, rows 173

Drill Filters 137

don’t show on line charts 257

duplicate

rows, showing 214

Dynamic Data Exchange 88

Editing

blocks 177

breaks 190, 191

free-standing cells 184

OLE 2 objects 286

page backgrounds 161

education. See training

elevation

setting on 3-D charts 259

email

addresses, adding links from reports 223

empty sections

(#EMPTY) 159

even

pages, setting up layout 157

Even() function 157

Excel

saving as 65

exporting

data 88

data as a text file 84

data to a dBASE file 84

data to a RDBMS table 84

data to a worksheet 84

exporting data

e external formats 84

options 86

using copy and paste 89

F

feedback, on documentation 291

file extensions

html 63

.rep 57

.ret 95

.rtf 61

.txt 61

.xls 65

file locations

templates 107

filtering

see BusinessObjects User’s Guide

Accessing Data and Data Analysis 120

finding documents

about 49

using shortcut buttons 44

where option 49

floor

formatting on 3-D chart 258

on 3-D chart, formatting 258

folding

breaks 193

sections 138

footer

applying shading to 134

break 192

inserting a cell in 133

page 133

page break 129, 129

resizing 134

Index
Index

running in tables 129
showing in tables and crosstabs 212
table 164
foreground
color, setting 252
formatting
blocks 202
cells and their contents 232
cells borders 230
chart floor 258
chart legend 267
chart plot area 254
chart walls 255
columns 256
conditional 152, 154
copying and pasting 218
copying column and row 170
crosstab borders 206
crosstab corners 208
data labels 269
data series 255, 255
footers 132
headers 132
numbers and dates 219, 223
repeating cell formats 217
section borders 206
sections 202
table borders 206
text 218
toolbars 217
formulas
in page break headers and footers 131
in running headers and footers 131
free-standing cells
hiding 152
inserting 182
setting standard report style 103
FTP 223
functions
Even() 157
IsNull() 160
Odd() 157

G

gap

setting on column charts 256
width, setting on 3-D charts 260
Global Filters 137
Gopher 224
grid 148, 184
gridlines
displaying 270, 270
formatting 271
illustrated 265
on charts, defined 270
groups
on charts 272
on charts, illustrated example 275

H

header
additional information in crosstabs 215
applying shading to 134
break 192
inserting a cell in 133
page 133
page break 129, 129
resizing 134
running in tables 129
showing in tables and crosstabs 212
table 164
help
accessing 25
messages in status bar 26
hiding
cells 152
chart axes 270
charts 152
crosstabs 152
data in charts 247
data labels on charts 269
empty sections 159
gridlines 270
report components 152
section header and footer 205
sections 152
tables 152
toolbars 22
high low lines
showing on line charts 257
Index

html
  saving documents in  63
HTTP  223
hyperlinks
  adding to reports  223
  editing  225

I
  indenting
    cell content  227
  information resources  289, 290
  InfoView
    starting BusinessObjects from  19
inserting
  breaks  191
  calculations on data in charts  279
  cells  180, 182
  columns  180, 182
  crosstabs  172
  current date and time  135
  data in tables  170
  drill filters  137
  free-standing cells  182
  global filters  137
  last refresh date  135
  last save date
    saving in report  135
  page #  135
  page # of #  135
  page backgrounds  160
  page numbers  134
  pictures in cells  287
  print date  135
  query prompt  137
  rows  180, 182
  special field  134
  tables  167
  time  134
  tracking information  134
inserting new data
  see also BusinessObjects User’s Guide
  Accessing Data and Data Analysis  166
IsNull()
  function  160
  using to hide empty sections  160

K
  keyboard
    shortcuts  27

L
  labels
    changing on charts  269
  languages
    saving templates  60
  layout
    multi-column or multi-row  213
    odd and even pages  157
    page  129
    report  149
  legend
    displaying on chart  267
    formatting  267
    formatting key  268
  line charts
    showing drop lines  257
    showing high low lines  257
    showing multiple lines  245
    showing up-down bars  257
  line styles
    applying to cell borders  230
    applying to chart axes  262
  logarithmic
    scale on charts  263
  logging in
    to BusinessObjects  19

M
  mailto
    using hyperlinks  223
  main
    section  202
  managing  190
    breaks  190
  Map tab
    Report Manager  33, 150
  margins
    aligning blocks and cells with  147
    resizing  134
    setting  132

Desktop Intelligence Reporting Techniques and Formatting User’s Guide  301
Index

master
  cells 115
master/detail reports
  building master/master/detail reports 118
  clearing master cell 123
  illustrated 115
  moving blocks between sections 149
  placing master in table or crosstab 121
  scaling on charts 264
  structuring existing reports as 115
  undoing 121
matrix charts 243
maximum
  report sections 118
menus
  context-sensitive 27
  right-click 27
merging
  cells 228
messages
  in status bar 26
Microsoft Excel
  saving as 65, 65
million
  style 220
modes
  offline 17
moving
  blocks 149
  cells 149
  cells, columns, rows, using drag-and-drop 173
  using drag-and-drop 149
multi-page
  reports 126

N
naming
  cells 151
  charts 151
  columns and rows 180
  crosstabs 151
  tables 151
navigating
  in reports 35
negative values
displaying on column charts 256
New Chart Wizard
  options 175, 239
NEWS 223
NNTP 224
numbers
  applying formats to cell contents 219
  checking regional settings 31
  custom formats 221
  deleting formats 223
  formatting 219, 219, 223
  formatting on chart axes 261
  inserting page 134
object linking and embedding 282–285
  creating new objects to insert 283
  editing objects 286
  Excel restriction 66
  inserting existing objects 284
odd
  pages, setting up layout 157
Odd() function 157
offline mode
  using 17
OLE 2 see object linking and embedding
Online Customer Support 291
opening
  BusinessObjects documents 42
  documents 43
  several documents together 43
ordering data
  see BusinessObjects User’s Guide
  Accessing Data and Data Analysis 120
orientation
  table 213
  table, changing 168
  text, setting for axis labels 262
outline view 138
overlap
  setting on column charts 256
Index

P

page
  layout options 129
  layout, viewing 28
  margins see margins
  numbers, inserting 134
  setup 132
  totals and subtotals, displaying 130
page backgrounds 160
  editing 161
  inserting 160
  pasting 161
  removing 162
  setting standard report style 103
page break
  footer 129
  footer before page break 130
  header 129
  header after page break 130
page breaks
  and charts 250
  managing 127
page layout
  different for odd and even pages 157
passwords
  for launching BusinessObjects 17, 17
  protecting documents 58
pasting
  formats 218
  page backgrounds 161
patterns
  applying to chart walls 258
PDF
  saving BusinessObjects documents as 61
  percent style 220
pictures
  Bitmap format (Cell Format dialog box) 287
  editing page backgrounds 161
  inserting in cells 287
  page backgrounds 160
  pasting page backgrounds 161
  removing page backgrounds 162
  using in reports 162, 287
pie charts
  formatting 255

pivoting data
  hiding data 247
  on charts 243
plot area
  formatting 254
  illustrated 254
  resizing 253
positioning
  blocks 144
  cells 144
  charts 144
  crosstabs 144
  report components 144
  tables 144
primary
  Y-axis 274
printing
  documents 72
  page setup 74
  setting up the page 72
prompts
  inserting information in a report 137
properties
  saving with documents 59
  PROSPERO directory service 224
Q
Query Prompt 137
R
ranking
  see BusinessObjects User's Guide
  Accessing Data and Data Analysis 120
RDBMS
  exporting data to an RDBMS 88
recap amounts
  displaying 130
recreating
  default.ret 105
redo
  an action 40
refreshing
  documents 68
  documents automatically 58

Desktop Intelligence Reporting Techniques and Formatting User's Guide 303
Index

regional settings
  checking and changing 31
relative
  positioning 144
removing
  breaks 190, 191
  data labels 269
  page backgrounds 162
renaming
  reports 39
repeat
  cell formats 217
Repeat Block on Every Page
  command 126
Repeat on Every Page
  command 126
Repeat on New Page
  command 126
repeating
  charts on every page 250
Report Manager
  hiding and displaying 33
  inserting tables from 167
  using to structure reports 149
report tab
  character limit 39
reports
  creating 37
  creating blank reports 37
  deleting 39
  displaying inside document 39
  displaying page numbers 134
  hiding components 152
  inserting crosstabs 172
  layout, setting default 96
  master/detail 114
  master/master/detail 118
  multi-page 126
  opening 43
  page backgrounds 160
  refreshing 68
  renaming 39
  saving as Excel 65
  standard, defined 94
  structuring as master/detail 115
  updating 68
  using pictures in 162, 287
  working on structure of 149
resizing
  blocks 252
  cells 211
  chart blocks 252
  charts 252
  columns 211
  columns and rows 180
  footers 134
  header 134
  margins 134
  plot area 253
  rows 211
resources 289, 290
retrieving documents
  about 49
revenue
  and quantity sold, comparing on chart 275
rich text format
  saving documents in 61
rotating
  tables 168
rotation
  setting on 3-D charts 259
rows
  adding to tables, crosstabs 180
  inserting 180, 182
  naming 180
  resizing 180, 211
  selecting 180
  selecting in tables and crosstabs 178, 179
  table and crosstab, deleting 171
  table and crosstab, swapping 168, 169
RTF
  see rich text format 61
running
  headers and footers 129
S
  saving
    adding summary info 59
    summary information 48
  saving documents
Index

as Excel spreadsheet 65
as html files 63
as PDF files 61
as templates 60
as text files 61
automatically 58
in html format 63
in PDF format 61
in rich text format 61
Save for all users option 57
scale
adjust scale to value range 264
adjusting in master/detail reports 264
defining display on a chart 263
logarithmic 263
using decimal on a chart 263
scatter charts
formatting data series 255
secondary
Y-axis 274
sections
creating in reports 114
displaying delimiters 120, 148
folding in outline view 138
formatting 202
formatting borders 206
hiding 152
hiding and displaying 205
hiding when empty 159
main 202
maximum in a report 118
moving blocks between sections 149
setting standard report styles 101
starting on new page 126
selecting
cells 180
chart elements 249
columns 180
columns in tables and crosstabs 178
rows 180
rows and columns 179
rows in tables and crosstabs 178
tables, crosstabs 178
two or more blocks 178, 278
set as master
in master/detail reports 116
setting
date format 88
shading
applying to cell backgrounds 231
background, creating custom colors 252
headers and footers 134
setting background color 252
setting foreground color 252
shortcut buttons
using 44
shortcuts
keyboard 27
Show Variable Header
crosstab option 215
side wall
on 3-D chart, formatting 258
Snap to Grid command 148, 184
sorting
see BusinessObjects User’s Guide
Accessing Data and Data Analysis 120
special field
date and time 134
drill filters 137
global filters 137
page numbers 134
query prompt 137
special fields
inserting date and time 135
inserting last refresh date 135
inserting page number 135
inserting print date 135
save date 135
standard report
definition 94
standard report styles
and templates 106
applying 103
customizing 97
Start on a New Page
command 127
status bar
messages 26
structure
view 28
Index

view in Report Manager 149
styles
  currency 219, 220
  million 220
  percent 220
styles
  standard report 97
  template 96
subtotals
  page, displaying 130
summary info
  adding 48, 59
  displaying 46
support
  customer 291
  locations 291
  technical 291
  web site 291

tables
  adding cells, columns to 180
  adding data 170
  building using drag and drop 167
  copying 181
  creating 167
  deleting 181
  displaying charts as 241
  editing 177
  headers and footers 164
  hiding 152
  insert wizard 174
  multi-column or row layout 213
  orientation 213
  reorganizing data in 168
  repeat block on every page 126
  rotating 168
  selecting 178
  setting standard report style 100
  showing duplicate rows 214
  showing headers and footers 212
  starting on new page 126
  turning into from a chart 240
  types, defined and illustrated 164
technical support 291
TELNET 223
templates
  and standard report styles 106
  and universe formats 107
  applying 108
  changing the default folder 105
  defined 96
  replacing variables 109
  saving as 60
  setting default 97
  setting up 107
  structure 96
  style 96
  style and structure 109
  upgrading 109
  using language folders 60
text
  applying text formats to axis labels 262
  formatting 218
  wrapping cell contents 229
tick marks
  displaying on chart axes 262
  illustrated 260
time
  inserting 134
tips
  on dragging and dropping data 173
title
  displaying on chart 266
toolbars
  alignment 147
  borders toolbar, illustrated 230
  displaying 115
  formatting 217
  formatting, illustrated 218
  hiding and displaying 22
  structure 131
totals
  page, displaying 130
tracking
  inserting document information 134, 137
training, on Business Objects products 292
transparent background
  shading, setting 252
Index

turn to chart
command 240

TXT
exporting data as 84
TXT file display
and BusinessObjects version 89
double quotes 89

U
undo
an action 40
undoing master/detail reports 121
clearing master cell 123
placing master in table or crosstab 121
universes
setting a default 97
updating
data 68
documents 68
up-down bars
showing on line charts 257
upgrading
and templates 109
user identification 17
when logging on 17

V
value-based breaks 191, 196
values
negative, displaying on column charts 256
variable
header, show in crosstabs 215
variables
hiding in charts 247
moving from axis to axis on charts 247
organizing on charts 243
viewing
BusinessObjects documents 42
document properties 51
report in outline view 138
report page layout 28, 134
report structure 28, 149

W
WAIS 224
wall
back, formatting on 3-D chart 258
side, formatting on 3-D chart 258
web
connection 68
customer support 291
getting documentation via 290
useful addresses 293
web sites
support 291
training 292
website
adding links to from reports 223
Windows
regional settings 31
wizards
inserting a chart 238
inserting a crosstab 174
inserting a new report 42, 42
inserting a table 174
workspace
BusinessObjects 21
illustration 21
organizing 27

X
X-axis
hiding 271
illustrated 260
organizing data on 243
XLS
exporting to Excel 84
saving as 65
XML
exporting to 84
using as a data provider, see BusinessObjects User’s Guide - Accessing Data and Data Analysis 84
XY scatter
charts 255

Desktop Intelligence Reporting Techniques and Formatting User’s Guide 307
Index

Y
Y-axis
  hiding 271
  illustrated 260
  organizing data on 243
  primary 274, 277
  secondary 274, 277
year 2000 32

Z
Z-axis
  displaying data on in 2-D charts 244
  displaying data on in 3-D charts 245
  formatting 258
  hiding 271
  organizing data on 243
  zooming
    setting display size 28